Lidgren.Network Namespace

[image]

Lidgren Network Library documentation
Lidgren.Network Namespace
Send Feedback
Lidgren Network Library

Classes

 | Class | Description
Public class | NetAESEncryption | AES encryption
Public class | NetBitVector | Fixed size vector of booleans
Public class | NetBitWriter | Helper class for NetBuffer to write/read bits
Public class | NetBlockEncryptionBase | Base for a non-threadsafe encryption class
Public class | NetClient | Specialized version of NetPeer used for a "client" connection. It does not accept any incoming connections and maintains a ServerConnection property
Public class | NetConnection | Represents a connection to a remote peer
Public class | NetConnectionStatistics | Statistics for a NetConnection instance
Public class | NetDESEncryption | DES encryption
Public class | NetException | Exception thrown in the Lidgren Network Library
Public class | NetIncomingMessage | Incoming message either sent from a remote peer or generated within the library
Public class | NetOutgoingMessage | Outgoing message used to send data to remote peer(s)
Public class | NetPeer | Represents a local peer capable of holding zero, one or more connections to remote peers
Public class | NetPeerConfiguration | Partly immutable after NetPeer has been initialized
Public class | NetPeerStatistics | Statistics for a NetPeer instance
Public class | NetQueue<(Of <(<'T>)>)> | Thread safe (blocking) expanding queue with TryDequeue() and EnqueueFirst()
Public class | NetRandom | A fast random number generator for .NET Colin Green, January 2005
Public class | NetRC2Encryption | RC2 encryption
Public class | NetServer | Specialized version of NetPeer used for "server" peers
Public class | NetSRP | Helper methods for implementing SRP authentication
Public class | NetTime | Time service
Public class | NetTripleDESEncryption | Triple DES encryption
Public class | NetUPnP | UPnP support class
Public class | NetUtility | Utility methods
Public class | NetXorEncryption | Example class; not very good encryption
Public class | NetXtea | Methods to encrypt and decrypt data using the XTEA algorithm

Interfaces

 | Interface | Description
Public interface | INetEncryption | Interface for an encryption algorithm

Enumerations

 | Enumeration | Description
Public enumeration | NetConnectionStatus | Status for a NetConnection instance
Public enumeration | NetDeliveryMethod | How the library deals with resends and handling of late messages
Public enumeration | NetIncomingMessageType | The type of a NetIncomingMessage
Public enumeration | NetPeerStatus | Status for a NetPeer instance
Public enumeration | NetSendResult | Result of a SendMessage call


INetEncryption Interface

[image]

Lidgren Network Library documentation
INetEncryption Interface
Members See Also Send Feedback
Interface for an encryption algorithm

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public interface INetEncryption
Visual Basic
Public Interface INetEncryption
Visual C++
public interface class INetEncryption

See Also

INetEncryption Members
Lidgren.Network Namespace


INetEncryption Members

[image] [image]

Lidgren Network Library documentation
INetEncryption Members
INetEncryption Interface Methods See Also Send Feedback

The INetEncryption type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt an incoming message in place
Public method | Encrypt | Encrypt an outgoing message in place

See Also

INetEncryption Interface


INetEncryption Methods

[image] [image]

Lidgren Network Library documentation
INetEncryption Methods
INetEncryption Interface See Also Send Feedback

The INetEncryption type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt an incoming message in place
Public method | Encrypt | Encrypt an outgoing message in place

See Also

INetEncryption Interface


Decrypt Method

[image]

Lidgren Network Library documentation
INetEncryption..::..Decrypt Method
INetEncryption Interface See Also Send Feedback
Decrypt an incoming message in place

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
bool Decrypt(
    NetIncomingMessage msg
)
Visual Basic
Function Decrypt ( _
    msg As NetIncomingMessage _
) As Boolean
Visual C++
bool Decrypt(
    NetIncomingMessage^ msg
)

Parameters

msg
Type: Lidgren.Network..::..NetIncomingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.INetEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.INetEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

See Also

INetEncryption Interface


Encrypt Method

[image]

Lidgren Network Library documentation
INetEncryption..::..Encrypt Method
INetEncryption Interface See Also Send Feedback
Encrypt an outgoing message in place

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
bool Encrypt(
    NetOutgoingMessage msg
)
Visual Basic
Function Encrypt ( _
    msg As NetOutgoingMessage _
) As Boolean
Visual C++
bool Encrypt(
    NetOutgoingMessage^ msg
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.INetEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.INetEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

See Also

INetEncryption Interface


NetAESEncryption Class

[image]

Lidgren Network Library documentation
NetAESEncryption Class
Members See Also Send Feedback
AES encryption

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetAESEncryption : INetEncryption
Visual Basic
Public Class NetAESEncryption _
    Implements INetEncryption
Visual C++
public ref class NetAESEncryption : INetEncryption

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetAESEncryption

See Also

NetAESEncryption Members


NetAESEncryption Members

[image] [image]

Lidgren Network Library documentation
NetAESEncryption Members
NetAESEncryption Class Constructors Methods See Also Send Feedback

The NetAESEncryption type exposes the following members.

Constructors

 | Name | Description
Public method | NetAESEncryption(String) | NetAESEncryption constructor
Public method | NetAESEncryption(array<Byte>[]()[][], array<Byte>[]()[][]) | NetAESEncryption constructor
Public method | NetAESEncryption(String, Int32) | NetAESEncryption constructor

Methods

 | Name | Description
Public method | Decrypt | Decrypt incoming message
Public method | Encrypt | Encrypt outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetAESEncryption Class


NetAESEncryption Constructor

[image] [image]

Lidgren Network Library documentation
NetAESEncryption Constructor
NetAESEncryption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NetAESEncryption(String) | NetAESEncryption constructor
Public method | NetAESEncryption(array<Byte>[]()[][], array<Byte>[]()[][]) | NetAESEncryption constructor
Public method | NetAESEncryption(String, Int32) | NetAESEncryption constructor

See Also

NetAESEncryption Class
NetAESEncryption Members


NetAESEncryption Constructor (String)

[image]

Lidgren Network Library documentation
NetAESEncryption Constructor (String)
NetAESEncryption Class See Also Send Feedback
NetAESEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetAESEncryption(
    string key
)
Visual Basic
Public Sub New ( _
    key As String _
)
Visual C++
public:
NetAESEncryption(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetAESEncryption.#ctor(System.String)"]

See Also

NetAESEncryption Class
NetAESEncryption Overload


NetAESEncryption Constructor (Byte[], Byte[])

[image]

Lidgren Network Library documentation
NetAESEncryption Constructor (array<Byte>[]()[][], array<Byte>[]()[][])
NetAESEncryption Class See Also Send Feedback
NetAESEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetAESEncryption(
    byte[] key,
    byte[] iv
)
Visual Basic
Public Sub New ( _
    key As Byte(), _
    iv As Byte() _
)
Visual C++
public:
NetAESEncryption(
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)

Parameters

key
Type: array< System..::..Byte >[]()[][]

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetAESEncryption.#ctor(System.Byte[],System.Byte[])"]

iv
Type: array< System..::..Byte >[]()[][]

[Missing <param name="iv"/> documentation for "M:Lidgren.Network.NetAESEncryption.#ctor(System.Byte[],System.Byte[])"]

See Also

NetAESEncryption Class
NetAESEncryption Overload


NetAESEncryption Constructor (String, Int32)

[image]

Lidgren Network Library documentation
NetAESEncryption Constructor (String, Int32)
NetAESEncryption Class See Also Send Feedback
NetAESEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetAESEncryption(
    string key,
    int bitsize
)
Visual Basic
Public Sub New ( _
    key As String, _
    bitsize As Integer _
)
Visual C++
public:
NetAESEncryption(
    String^ key,
    int bitsize
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetAESEncryption.#ctor(System.String,System.Int32)"]

bitsize
Type: System..::..Int32

[Missing <param name="bitsize"/> documentation for "M:Lidgren.Network.NetAESEncryption.#ctor(System.String,System.Int32)"]

See Also

NetAESEncryption Class
NetAESEncryption Overload


NetAESEncryption Methods

[image] [image]

Lidgren Network Library documentation
NetAESEncryption Methods
NetAESEncryption Class See Also Send Feedback

The NetAESEncryption type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt incoming message
Public method | Encrypt | Encrypt outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetAESEncryption Class


Decrypt Method

[image]

Lidgren Network Library documentation
NetAESEncryption..::..Decrypt Method
NetAESEncryption Class See Also Send Feedback
Decrypt incoming message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Decrypt(
    NetIncomingMessage msg
)
Visual Basic
Public Function Decrypt ( _
    msg As NetIncomingMessage _
) As Boolean
Visual C++
public:
virtual bool Decrypt(
    NetIncomingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetIncomingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetAESEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetAESEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Implements

INetEncryption..::..Decrypt(NetIncomingMessage)

See Also

NetAESEncryption Class


Encrypt Method

[image]

Lidgren Network Library documentation
NetAESEncryption..::..Encrypt Method
NetAESEncryption Class See Also Send Feedback
Encrypt outgoing message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Encrypt(
    NetOutgoingMessage msg
)
Visual Basic
Public Function Encrypt ( _
    msg As NetOutgoingMessage _
) As Boolean
Visual C++
public:
virtual bool Encrypt(
    NetOutgoingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetAESEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetAESEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Implements

INetEncryption..::..Encrypt(NetOutgoingMessage)

See Also

NetAESEncryption Class


NetBitVector Class

[image]

Lidgren Network Library documentation
NetBitVector Class
Members See Also Send Feedback
Fixed size vector of booleans

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public sealed class NetBitVector
Visual Basic
Public NotInheritable Class NetBitVector
Visual C++
public ref class NetBitVector sealed

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetBitVector

See Also

NetBitVector Members


NetBitVector Members

[image] [image]

Lidgren Network Library documentation
NetBitVector Members
NetBitVector Class Constructors Methods Properties See Also Send Feedback

The NetBitVector type exposes the following members.

Constructors

 | Name | Description
Public method | NetBitVector | NetBitVector constructor

Methods

 | Name | Description
Public method | Clear | Sets all bits/booleans to zero/false
Public method | Count | Returns the number of bits/booleans set to one/true
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the bit/bool at the specified index
Public method | GetFirstSetIndex | Gets the first (lowest) index set to true
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Returns true if all bits/booleans are set to zero/false
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RotateDown | Shift all bits one step down, cycling the first bit to the top
Public method | Set | Sets or clears the bit/bool at the specified index
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Bit | Gets the bit/bool at the specified index
Public property | Capacity | Gets the number of bits/booleans stored in this vector

See Also

NetBitVector Class


NetBitVector Constructor

[image]

Lidgren Network Library documentation
NetBitVector Constructor
NetBitVector Class See Also Send Feedback
NetBitVector constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetBitVector(
    int bitsCapacity
)
Visual Basic
Public Sub New ( _
    bitsCapacity As Integer _
)
Visual C++
public:
NetBitVector(
    int bitsCapacity
)

Parameters

bitsCapacity
Type: System..::..Int32

[Missing <param name="bitsCapacity"/> documentation for "M:Lidgren.Network.NetBitVector.#ctor(System.Int32)"]

See Also

NetBitVector Class


NetBitVector Methods

[image] [image]

Lidgren Network Library documentation
NetBitVector Methods
NetBitVector Class See Also Send Feedback

The NetBitVector type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Sets all bits/booleans to zero/false
Public method | Count | Returns the number of bits/booleans set to one/true
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the bit/bool at the specified index
Public method | GetFirstSetIndex | Gets the first (lowest) index set to true
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEmpty | Returns true if all bits/booleans are set to zero/false
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RotateDown | Shift all bits one step down, cycling the first bit to the top
Public method | Set | Sets or clears the bit/bool at the specified index
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

See Also

NetBitVector Class


Clear Method

[image]

Lidgren Network Library documentation
NetBitVector..::..Clear Method
NetBitVector Class See Also Send Feedback
Sets all bits/booleans to zero/false

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

NetBitVector Class


Count Method

[image]

Lidgren Network Library documentation
NetBitVector..::..Count Method
NetBitVector Class See Also Send Feedback
Returns the number of bits/booleans set to one/true

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int Count()
Visual Basic
Public Function Count As Integer
Visual C++
public:
int Count()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitVector.Count"]

See Also

NetBitVector Class


Get Method

[image]

Lidgren Network Library documentation
NetBitVector..::..Get Method
NetBitVector Class See Also Send Feedback
Gets the bit/bool at the specified index

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Get(
    int bitIndex
)
Visual Basic
Public Function Get ( _
    bitIndex As Integer _
) As Boolean
Visual C++
public:
bool Get(
    int bitIndex
)

Parameters

bitIndex
Type: System..::..Int32

[Missing <param name="bitIndex"/> documentation for "M:Lidgren.Network.NetBitVector.Get(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitVector.Get(System.Int32)"]

See Also

NetBitVector Class


GetFirstSetIndex Method

[image]

Lidgren Network Library documentation
NetBitVector..::..GetFirstSetIndex Method
NetBitVector Class See Also Send Feedback
Gets the first (lowest) index set to true

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int GetFirstSetIndex()
Visual Basic
Public Function GetFirstSetIndex As Integer
Visual C++
public:
int GetFirstSetIndex()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitVector.GetFirstSetIndex"]

See Also

NetBitVector Class


IsEmpty Method

[image]

Lidgren Network Library documentation
NetBitVector..::..IsEmpty Method
NetBitVector Class See Also Send Feedback
Returns true if all bits/booleans are set to zero/false

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitVector.IsEmpty"]

See Also

NetBitVector Class


RotateDown Method

[image]

Lidgren Network Library documentation
NetBitVector..::..RotateDown Method
NetBitVector Class See Also Send Feedback
Shift all bits one step down, cycling the first bit to the top

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void RotateDown()
Visual Basic
Public Sub RotateDown
Visual C++
public:
void RotateDown()

See Also

NetBitVector Class


Set Method

[image]

Lidgren Network Library documentation
NetBitVector..::..Set Method
NetBitVector Class See Also Send Feedback
Sets or clears the bit/bool at the specified index

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Set(
    int bitIndex,
    bool value
)
Visual Basic
Public Sub Set ( _
    bitIndex As Integer, _
    value As Boolean _
)
Visual C++
public:
void Set(
    int bitIndex,
    bool value
)

Parameters

bitIndex
Type: System..::..Int32

[Missing <param name="bitIndex"/> documentation for "M:Lidgren.Network.NetBitVector.Set(System.Int32,System.Boolean)"]

value
Type: System..::..Boolean

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetBitVector.Set(System.Int32,System.Boolean)"]

See Also

NetBitVector Class


ToString Method

[image]

Lidgren Network Library documentation
NetBitVector..::..ToString Method
NetBitVector Class See Also Send Feedback
Returns a string that represents this object

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitVector.ToString"]

See Also

NetBitVector Class


NetBitVector Properties

[image] [image]

Lidgren Network Library documentation
NetBitVector Properties
NetBitVector Class See Also Send Feedback

The NetBitVector type exposes the following members.

Properties

 | Name | Description
Public property | Bit | Gets the bit/bool at the specified index
Public property | Capacity | Gets the number of bits/booleans stored in this vector

See Also

NetBitVector Class


Bit Property

[image]

Lidgren Network Library documentation
NetBitVector..::..Bit Property
NetBitVector Class See Also Send Feedback
Gets the bit/bool at the specified index

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool this[
    int index
] { get; set; }
Visual Basic
Public Default Property Bit ( _
    index As Integer _
) As Boolean
    Get
    Set
Visual C++
public:
property bool default[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::..Int32

See Also

NetBitVector Class


Capacity Property

[image]

Lidgren Network Library documentation
NetBitVector..::..Capacity Property
NetBitVector Class See Also Send Feedback
Gets the number of bits/booleans stored in this vector

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int Capacity { get; }
Visual Basic
Public ReadOnly Property Capacity As Integer
    Get
Visual C++
public:
property int Capacity {
    int get ();
}

See Also

NetBitVector Class


NetBitWriter Class

[image]

Lidgren Network Library documentation
NetBitWriter Class
Members See Also Send Feedback
Helper class for NetBuffer to write/read bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static class NetBitWriter
Visual Basic
Public NotInheritable Class NetBitWriter
Visual C++
public ref class NetBitWriter abstract sealed

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetBitWriter

See Also

NetBitWriter Members


NetBitWriter Members

[image] [image]

Lidgren Network Library documentation
NetBitWriter Members
NetBitWriter Class Methods See Also Send Feedback

The NetBitWriter type exposes the following members.

Methods

Name | Description
ReadByte | Read 1-8 bits from a buffer into a byte
ReadBytes | Read several bytes from a buffer
ReadUInt32 | Reads the specified number of bits into an UInt32
ReadVariableUInt32 | Reads a UInt32 written using WriteUnsignedVarInt(); will increment offset!
WriteByte | Write a byte consisting of 1-8 bits to a buffer; assumes buffer is previously allocated
WriteBytes | Write several whole bytes
WriteUInt32 | Writes the specified number of bits into a byte array
WriteUInt64 | Writes the specified number of bits into a byte array
WriteVariableUInt32 | Write Base128 encoded variable sized unsigned integer

See Also

NetBitWriter Class


NetBitWriter Methods

[image] [image]

Lidgren Network Library documentation
NetBitWriter Methods
NetBitWriter Class See Also Send Feedback

The NetBitWriter type exposes the following members.

Methods

Name | Description
ReadByte | Read 1-8 bits from a buffer into a byte
ReadBytes | Read several bytes from a buffer
ReadUInt32 | Reads the specified number of bits into an UInt32
ReadVariableUInt32 | Reads a UInt32 written using WriteUnsignedVarInt(); will increment offset!
WriteByte | Write a byte consisting of 1-8 bits to a buffer; assumes buffer is previously allocated
WriteBytes | Write several whole bytes
WriteUInt32 | Writes the specified number of bits into a byte array
WriteUInt64 | Writes the specified number of bits into a byte array
WriteVariableUInt32 | Write Base128 encoded variable sized unsigned integer

See Also

NetBitWriter Class


ReadByte Method

[image]

Lidgren Network Library documentation
NetBitWriter..::..ReadByte Method
NetBitWriter Class See Also Send Feedback
Read 1-8 bits from a buffer into a byte

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte ReadByte(
    byte[] fromBuffer,
    int numberOfBits,
    int readBitOffset
)
Visual Basic
Public Shared Function ReadByte ( _
    fromBuffer As Byte(), _
    numberOfBits As Integer, _
    readBitOffset As Integer _
) As Byte
Visual C++
public:
static unsigned char ReadByte(
    array<unsigned char>^ fromBuffer,
    int numberOfBits,
    int readBitOffset
)

Parameters

fromBuffer
Type: array< System..::..Byte >[]()[][]

[Missing <param name="fromBuffer"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadByte(System.Byte[],System.Int32,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadByte(System.Byte[],System.Int32,System.Int32)"]

readBitOffset
Type: System..::..Int32

[Missing <param name="readBitOffset"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadByte(System.Byte[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitWriter.ReadByte(System.Byte[],System.Int32,System.Int32)"]

See Also

NetBitWriter Class


ReadBytes Method

[image]

Lidgren Network Library documentation
NetBitWriter..::..ReadBytes Method
NetBitWriter Class See Also Send Feedback
Read several bytes from a buffer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static void ReadBytes(
    byte[] fromBuffer,
    int numberOfBytes,
    int readBitOffset,
    byte[] destination,
    int destinationByteOffset
)
Visual Basic
Public Shared Sub ReadBytes ( _
    fromBuffer As Byte(), _
    numberOfBytes As Integer, _
    readBitOffset As Integer, _
    destination As Byte(), _
    destinationByteOffset As Integer _
)
Visual C++
public:
static void ReadBytes(
    array<unsigned char>^ fromBuffer,
    int numberOfBytes,
    int readBitOffset,
    array<unsigned char>^ destination,
    int destinationByteOffset
)

Parameters

fromBuffer
Type: array< System..::..Byte >[]()[][]

[Missing <param name="fromBuffer"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

numberOfBytes
Type: System..::..Int32

[Missing <param name="numberOfBytes"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

readBitOffset
Type: System..::..Int32

[Missing <param name="readBitOffset"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

destination
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destination"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

destinationByteOffset
Type: System..::..Int32

[Missing <param name="destinationByteOffset"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

See Also

NetBitWriter Class


ReadUInt32 Method

[image]

Lidgren Network Library documentation
NetBitWriter..::..ReadUInt32 Method
NetBitWriter Class See Also Send Feedback
Reads the specified number of bits into an UInt32

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static uint ReadUInt32(
    byte[] fromBuffer,
    int numberOfBits,
    int readBitOffset
)
Visual Basic
Public Shared Function ReadUInt32 ( _
    fromBuffer As Byte(), _
    numberOfBits As Integer, _
    readBitOffset As Integer _
) As UInteger
Visual C++
public:
static unsigned int ReadUInt32(
    array<unsigned char>^ fromBuffer,
    int numberOfBits,
    int readBitOffset
)

Parameters

fromBuffer
Type: array< System..::..Byte >[]()[][]

[Missing <param name="fromBuffer"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadUInt32(System.Byte[],System.Int32,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadUInt32(System.Byte[],System.Int32,System.Int32)"]

readBitOffset
Type: System..::..Int32

[Missing <param name="readBitOffset"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadUInt32(System.Byte[],System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitWriter.ReadUInt32(System.Byte[],System.Int32,System.Int32)"]

See Also

NetBitWriter Class


ReadVariableUInt32 Method

[image]

Lidgren Network Library documentation
NetBitWriter..::..ReadVariableUInt32 Method
NetBitWriter Class See Also Send Feedback
Reads a UInt32 written using WriteUnsignedVarInt(); will increment offset!

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static uint ReadVariableUInt32(
    byte[] buffer,
    ref int offset
)
Visual Basic
Public Shared Function ReadVariableUInt32 ( _
    buffer As Byte(), _
    ByRef offset As Integer _
) As UInteger
Visual C++
public:
static unsigned int ReadVariableUInt32(
    array<unsigned char>^ buffer,
    int% offset
)

Parameters

buffer
Type: array< System..::..Byte >[]()[][]

[Missing <param name="buffer"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadVariableUInt32(System.Byte[],System.Int32@)"]

offset
Type: System..::..Int32 %

[Missing <param name="offset"/> documentation for "M:Lidgren.Network.NetBitWriter.ReadVariableUInt32(System.Byte[],System.Int32@)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitWriter.ReadVariableUInt32(System.Byte[],System.Int32@)"]

See Also

NetBitWriter Class


WriteByte Method

[image]

Lidgren Network Library documentation
NetBitWriter..::..WriteByte Method
NetBitWriter Class See Also Send Feedback
Write a byte consisting of 1-8 bits to a buffer; assumes buffer is previously allocated

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static void WriteByte(
    byte source,
    int numberOfBits,
    byte[] destination,
    int destBitOffset
)
Visual Basic
Public Shared Sub WriteByte ( _
    source As Byte, _
    numberOfBits As Integer, _
    destination As Byte(), _
    destBitOffset As Integer _
)
Visual C++
public:
static void WriteByte(
    unsigned char source,
    int numberOfBits,
    array<unsigned char>^ destination,
    int destBitOffset
)

Parameters

source
Type: System..::..Byte

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteByte(System.Byte,System.Int32,System.Byte[],System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteByte(System.Byte,System.Int32,System.Byte[],System.Int32)"]

destination
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destination"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteByte(System.Byte,System.Int32,System.Byte[],System.Int32)"]

destBitOffset
Type: System..::..Int32

[Missing <param name="destBitOffset"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteByte(System.Byte,System.Int32,System.Byte[],System.Int32)"]

See Also

NetBitWriter Class


WriteBytes Method

[image]

Lidgren Network Library documentation
NetBitWriter..::..WriteBytes Method
NetBitWriter Class See Also Send Feedback
Write several whole bytes

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static void WriteBytes(
    byte[] source,
    int sourceByteOffset,
    int numberOfBytes,
    byte[] destination,
    int destBitOffset
)
Visual Basic
Public Shared Sub WriteBytes ( _
    source As Byte(), _
    sourceByteOffset As Integer, _
    numberOfBytes As Integer, _
    destination As Byte(), _
    destBitOffset As Integer _
)
Visual C++
public:
static void WriteBytes(
    array<unsigned char>^ source,
    int sourceByteOffset,
    int numberOfBytes,
    array<unsigned char>^ destination,
    int destBitOffset
)

Parameters

source
Type: array< System..::..Byte >[]()[][]

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

sourceByteOffset
Type: System..::..Int32

[Missing <param name="sourceByteOffset"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

numberOfBytes
Type: System..::..Int32

[Missing <param name="numberOfBytes"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

destination
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destination"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

destBitOffset
Type: System..::..Int32

[Missing <param name="destBitOffset"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteBytes(System.Byte[],System.Int32,System.Int32,System.Byte[],System.Int32)"]

See Also

NetBitWriter Class


WriteUInt32 Method

[image]

Lidgren Network Library documentation
NetBitWriter..::..WriteUInt32 Method
NetBitWriter Class See Also Send Feedback
Writes the specified number of bits into a byte array

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static int WriteUInt32(
    uint source,
    int numberOfBits,
    byte[] destination,
    int destinationBitOffset
)
Visual Basic
Public Shared Function WriteUInt32 ( _
    source As UInteger, _
    numberOfBits As Integer, _
    destination As Byte(), _
    destinationBitOffset As Integer _
) As Integer
Visual C++
public:
static int WriteUInt32(
    unsigned int source,
    int numberOfBits,
    array<unsigned char>^ destination,
    int destinationBitOffset
)

Parameters

source
Type: System..::..UInt32

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt32(System.UInt32,System.Int32,System.Byte[],System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt32(System.UInt32,System.Int32,System.Byte[],System.Int32)"]

destination
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destination"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt32(System.UInt32,System.Int32,System.Byte[],System.Int32)"]

destinationBitOffset
Type: System..::..Int32

[Missing <param name="destinationBitOffset"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt32(System.UInt32,System.Int32,System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt32(System.UInt32,System.Int32,System.Byte[],System.Int32)"]

See Also

NetBitWriter Class


WriteUInt64 Method

[image]

Lidgren Network Library documentation
NetBitWriter..::..WriteUInt64 Method
NetBitWriter Class See Also Send Feedback
Writes the specified number of bits into a byte array

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static int WriteUInt64(
    ulong source,
    int numberOfBits,
    byte[] destination,
    int destinationBitOffset
)
Visual Basic
Public Shared Function WriteUInt64 ( _
    source As ULong, _
    numberOfBits As Integer, _
    destination As Byte(), _
    destinationBitOffset As Integer _
) As Integer
Visual C++
public:
static int WriteUInt64(
    unsigned long long source,
    int numberOfBits,
    array<unsigned char>^ destination,
    int destinationBitOffset
)

Parameters

source
Type: System..::..UInt64

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt64(System.UInt64,System.Int32,System.Byte[],System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt64(System.UInt64,System.Int32,System.Byte[],System.Int32)"]

destination
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destination"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt64(System.UInt64,System.Int32,System.Byte[],System.Int32)"]

destinationBitOffset
Type: System..::..Int32

[Missing <param name="destinationBitOffset"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt64(System.UInt64,System.Int32,System.Byte[],System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBitWriter.WriteUInt64(System.UInt64,System.Int32,System.Byte[],System.Int32)"]

See Also

NetBitWriter Class


WriteVariableUInt32 Method

[image]

Lidgren Network Library documentation
NetBitWriter..::..WriteVariableUInt32 Method
NetBitWriter Class See Also Send Feedback
Write Base128 encoded variable sized unsigned integer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static int WriteVariableUInt32(
    byte[] intoBuffer,
    int offset,
    uint value
)
Visual Basic
Public Shared Function WriteVariableUInt32 ( _
    intoBuffer As Byte(), _
    offset As Integer, _
    value As UInteger _
) As Integer
Visual C++
public:
static int WriteVariableUInt32(
    array<unsigned char>^ intoBuffer,
    int offset,
    unsigned int value
)

Parameters

intoBuffer
Type: array< System..::..Byte >[]()[][]

[Missing <param name="intoBuffer"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteVariableUInt32(System.Byte[],System.Int32,System.UInt32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteVariableUInt32(System.Byte[],System.Int32,System.UInt32)"]

value
Type: System..::..UInt32

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetBitWriter.WriteVariableUInt32(System.Byte[],System.Int32,System.UInt32)"]

Return Value

number of bytes written

See Also

NetBitWriter Class


NetBlockEncryptionBase Class

[image]

Lidgren Network Library documentation
NetBlockEncryptionBase Class
Members See Also Send Feedback
Base for a non-threadsafe encryption class

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public abstract class NetBlockEncryptionBase : INetEncryption
Visual Basic
Public MustInherit Class NetBlockEncryptionBase _
    Implements INetEncryption
Visual C++
public ref class NetBlockEncryptionBase abstract : INetEncryption

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetBlockEncryptionBase
Lidgren.Network..::..NetXtea

See Also

NetBlockEncryptionBase Members


NetBlockEncryptionBase Members

[image] [image]

Lidgren Network Library documentation
NetBlockEncryptionBase Members
NetBlockEncryptionBase Class Constructors Methods Properties See Also Send Feedback

The NetBlockEncryptionBase type exposes the following members.

Constructors

 | Name | Description
Public method | NetBlockEncryptionBase | NetBlockEncryptionBase constructor

Methods

 | Name | Description
Public method | Decrypt | Decrypt an incoming message encrypted with corresponding Encrypt
Protected method | DecryptBlock | Decrypt a block of bytes
Public method | Encrypt | Encrypt am outgoing message with this algorithm; no writing can be done to the message after encryption, or message will be corrupted
Protected method | EncryptBlock | Encrypt a block of bytes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BlockSize | Block size in bytes for this cipher

See Also

NetBlockEncryptionBase Class


NetBlockEncryptionBase Constructor

[image]

Lidgren Network Library documentation
NetBlockEncryptionBase Constructor
NetBlockEncryptionBase Class See Also Send Feedback
NetBlockEncryptionBase constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetBlockEncryptionBase()
Visual Basic
Public Sub New
Visual C++
public:
NetBlockEncryptionBase()

See Also

NetBlockEncryptionBase Class


NetBlockEncryptionBase Methods

[image] [image]

Lidgren Network Library documentation
NetBlockEncryptionBase Methods
NetBlockEncryptionBase Class See Also Send Feedback

The NetBlockEncryptionBase type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt an incoming message encrypted with corresponding Encrypt
Protected method | DecryptBlock | Decrypt a block of bytes
Public method | Encrypt | Encrypt am outgoing message with this algorithm; no writing can be done to the message after encryption, or message will be corrupted
Protected method | EncryptBlock | Encrypt a block of bytes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetBlockEncryptionBase Class


Decrypt Method

[image]

Lidgren Network Library documentation
NetBlockEncryptionBase..::..Decrypt Method
NetBlockEncryptionBase Class See Also Send Feedback
Decrypt an incoming message encrypted with corresponding Encrypt

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Decrypt(
    NetIncomingMessage msg
)
Visual Basic
Public Function Decrypt ( _
    msg As NetIncomingMessage _
) As Boolean
Visual C++
public:
virtual bool Decrypt(
    NetIncomingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetIncomingMessage
message to decrypt

Return Value

true if successful; false if failed

Implements

INetEncryption..::..Decrypt(NetIncomingMessage)

See Also

NetBlockEncryptionBase Class


DecryptBlock Method

[image]

Lidgren Network Library documentation
NetBlockEncryptionBase..::..DecryptBlock Method
NetBlockEncryptionBase Class See Also Send Feedback
Decrypt a block of bytes

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
protected abstract void DecryptBlock(
    byte[] source,
    int sourceOffset,
    byte[] destination
)
Visual Basic
Protected MustOverride Sub DecryptBlock ( _
    source As Byte(), _
    sourceOffset As Integer, _
    destination As Byte() _
)
Visual C++
protected:
virtual void DecryptBlock(
    array<unsigned char>^ source,
    int sourceOffset,
    array<unsigned char>^ destination
) abstract

Parameters

source
Type: array< System..::..Byte >[]()[][]

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetBlockEncryptionBase.DecryptBlock(System.Byte[],System.Int32,System.Byte[])"]

sourceOffset
Type: System..::..Int32

[Missing <param name="sourceOffset"/> documentation for "M:Lidgren.Network.NetBlockEncryptionBase.DecryptBlock(System.Byte[],System.Int32,System.Byte[])"]

destination
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destination"/> documentation for "M:Lidgren.Network.NetBlockEncryptionBase.DecryptBlock(System.Byte[],System.Int32,System.Byte[])"]

See Also

NetBlockEncryptionBase Class


Encrypt Method

[image]

Lidgren Network Library documentation
NetBlockEncryptionBase..::..Encrypt Method
NetBlockEncryptionBase Class See Also Send Feedback
Encrypt am outgoing message with this algorithm; no writing can be done to the message after encryption, or message will be corrupted

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Encrypt(
    NetOutgoingMessage msg
)
Visual Basic
Public Function Encrypt ( _
    msg As NetOutgoingMessage _
) As Boolean
Visual C++
public:
virtual bool Encrypt(
    NetOutgoingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetBlockEncryptionBase.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetBlockEncryptionBase.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Implements

INetEncryption..::..Encrypt(NetOutgoingMessage)

See Also

NetBlockEncryptionBase Class


EncryptBlock Method

[image]

Lidgren Network Library documentation
NetBlockEncryptionBase..::..EncryptBlock Method
NetBlockEncryptionBase Class See Also Send Feedback
Encrypt a block of bytes

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
protected abstract void EncryptBlock(
    byte[] source,
    int sourceOffset,
    byte[] destination
)
Visual Basic
Protected MustOverride Sub EncryptBlock ( _
    source As Byte(), _
    sourceOffset As Integer, _
    destination As Byte() _
)
Visual C++
protected:
virtual void EncryptBlock(
    array<unsigned char>^ source,
    int sourceOffset,
    array<unsigned char>^ destination
) abstract

Parameters

source
Type: array< System..::..Byte >[]()[][]

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetBlockEncryptionBase.EncryptBlock(System.Byte[],System.Int32,System.Byte[])"]

sourceOffset
Type: System..::..Int32

[Missing <param name="sourceOffset"/> documentation for "M:Lidgren.Network.NetBlockEncryptionBase.EncryptBlock(System.Byte[],System.Int32,System.Byte[])"]

destination
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destination"/> documentation for "M:Lidgren.Network.NetBlockEncryptionBase.EncryptBlock(System.Byte[],System.Int32,System.Byte[])"]

See Also

NetBlockEncryptionBase Class


NetBlockEncryptionBase Properties

[image] [image]

Lidgren Network Library documentation
NetBlockEncryptionBase Properties
NetBlockEncryptionBase Class See Also Send Feedback

The NetBlockEncryptionBase type exposes the following members.

Properties

 | Name | Description
Public property | BlockSize | Block size in bytes for this cipher

See Also

NetBlockEncryptionBase Class


BlockSize Property

[image]

Lidgren Network Library documentation
NetBlockEncryptionBase..::..BlockSize Property
NetBlockEncryptionBase Class See Also Send Feedback
Block size in bytes for this cipher

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public abstract int BlockSize { get; }
Visual Basic
Public MustOverride ReadOnly Property BlockSize As Integer
    Get
Visual C++
public:
virtual property int BlockSize {
    int get () abstract;
}

See Also

NetBlockEncryptionBase Class


NetClient Class

[image]

Lidgren Network Library documentation
NetClient Class
Members See Also Send Feedback
Specialized version of NetPeer used for a "client" connection. It does not accept any incoming connections and maintains a ServerConnection property

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetClient : NetPeer
Visual Basic
Public Class NetClient _
    Inherits NetPeer
Visual C++
public ref class NetClient : public NetPeer

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetPeer
Lidgren.Network..::..NetClient

See Also

NetClient Members


NetClient Members

[image] [image]

Lidgren Network Library documentation
NetClient Members
NetClient Class Constructors Methods Properties See Also Send Feedback

The NetClient type exposes the following members.

Constructors

 | Name | Description
Public method | NetClient | NetClient constructor

Methods

 | Name | Description
Public method | Connect(IPEndPoint) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(IPEndPoint, NetOutgoingMessage) | Connect to a remote server (Overrides NetPeer..::..Connect(IPEndPoint, NetOutgoingMessage).)
Public method | Connect(String, Int32) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(String, Int32, NetOutgoingMessage) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | CreateMessage()()()() | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(Int32) | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(String) | Creates a new message for sending and writes the provided string to it (Inherited from NetPeer.)
Public method | Disconnect | Disconnect from server
Public method | DiscoverKnownPeer(IPEndPoint) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverKnownPeer(String, Int32) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverLocalPeers | Emit a discovery signal to all hosts on your subnet (Inherited from NetPeer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConnection | Get the connection, if any, for a certain remote endpoint (Inherited from NetPeer.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Introduce | Send NetIntroduction to hostExternal and clientExternal; introducing client to host (Inherited from NetPeer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadMessage | Read a pending message from any connection, if any (Inherited from NetPeer.)
Public method | Recycle | Recycles a NetIncomingMessage instance for reuse; taking pressure off the garbage collector (Inherited from NetPeer.)
Public method | SendDiscoveryResponse | Send a discovery response message (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetDeliveryMethod) | Sends message to server
Public method | SendMessage(NetOutgoingMessage, NetDeliveryMethod, Int32) | Sends message to server
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, IList<(Of <<'(NetConnection>)>>), NetDeliveryMethod, Int32) | Send a message to a list of connections (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, IList<(Of <<'(IPEndPoint>)>>)) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, IPEndPoint) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, String, Int32) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | Shutdown | Disconnects all active connections and closes the socket (Inherited from NetPeer.)
Public method | Start | Binds to socket and spawns the networking thread (Inherited from NetPeer.)
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)
Public method | WaitMessage | Read a pending message from any connection, blocking up to maxMillis if needed (Inherited from NetPeer.)

Properties

 | Name | Description
Public property | Configuration | Gets the configuration used to instanciate this NetPeer (Inherited from NetPeer.)
Public property | Connections | Gets a copy of the list of connections (Inherited from NetPeer.)
Public property | ConnectionsCount | Gets the number of active connections (Inherited from NetPeer.)
Public property | ConnectionStatus | Gets the connection status of the server connection (or NetConnectionStatus.Disconnected if no connection)
Public property | MessageReceivedEvent | Signalling event which can be waited on to determine when a message is queued for reading. Note that there is no guarantee that after the event is signaled the blocked thread will find the message in the queue. Other user created threads could be preempted and dequeue the message before the waiting thread wakes up. (Inherited from NetPeer.)
Public property | Port | Gets the port number this NetPeer is listening and sending on, if Start() has been called (Inherited from NetPeer.)
Public property | ServerConnection | Gets the connection to the server, if any
Public property | Socket | Gets the socket, if Start() has been called (Inherited from NetPeer.)
Public property | Statistics | Statistics on this NetPeer since it was initialized (Inherited from NetPeer.)
Public property | Status | Gets the NetPeerStatus of the NetPeer (Inherited from NetPeer.)
Public property | Tag | Gets or sets the application defined object containing data about the peer (Inherited from NetPeer.)
Public property | UniqueIdentifier | Gets a unique identifier for this NetPeer based on Mac address and ip/port. Note! Not available until Start() has been called! (Inherited from NetPeer.)
Public property | UPnP | Returns an UPnP object if enabled in the NetPeerConfiguration (Inherited from NetPeer.)

See Also

NetClient Class


NetClient Constructor

[image]

Lidgren Network Library documentation
NetClient Constructor
NetClient Class See Also Send Feedback
NetClient constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetClient(
    NetPeerConfiguration config
)
Visual Basic
Public Sub New ( _
    config As NetPeerConfiguration _
)
Visual C++
public:
NetClient(
    NetPeerConfiguration^ config
)

Parameters

config
Type: Lidgren.Network..::..NetPeerConfiguration

[Missing <param name="config"/> documentation for "M:Lidgren.Network.NetClient.#ctor(Lidgren.Network.NetPeerConfiguration)"]

See Also

NetClient Class


NetClient Methods

[image] [image]

Lidgren Network Library documentation
NetClient Methods
NetClient Class See Also Send Feedback

The NetClient type exposes the following members.

Methods

 | Name | Description
Public method | Connect(IPEndPoint) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(IPEndPoint, NetOutgoingMessage) | Connect to a remote server (Overrides NetPeer..::..Connect(IPEndPoint, NetOutgoingMessage).)
Public method | Connect(String, Int32) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(String, Int32, NetOutgoingMessage) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | CreateMessage()()()() | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(Int32) | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(String) | Creates a new message for sending and writes the provided string to it (Inherited from NetPeer.)
Public method | Disconnect | Disconnect from server
Public method | DiscoverKnownPeer(IPEndPoint) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverKnownPeer(String, Int32) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverLocalPeers | Emit a discovery signal to all hosts on your subnet (Inherited from NetPeer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConnection | Get the connection, if any, for a certain remote endpoint (Inherited from NetPeer.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Introduce | Send NetIntroduction to hostExternal and clientExternal; introducing client to host (Inherited from NetPeer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadMessage | Read a pending message from any connection, if any (Inherited from NetPeer.)
Public method | Recycle | Recycles a NetIncomingMessage instance for reuse; taking pressure off the garbage collector (Inherited from NetPeer.)
Public method | SendDiscoveryResponse | Send a discovery response message (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetDeliveryMethod) | Sends message to server
Public method | SendMessage(NetOutgoingMessage, NetDeliveryMethod, Int32) | Sends message to server
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, IList<(Of <<'(NetConnection>)>>), NetDeliveryMethod, Int32) | Send a message to a list of connections (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, IList<(Of <<'(IPEndPoint>)>>)) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, IPEndPoint) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, String, Int32) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | Shutdown | Disconnects all active connections and closes the socket (Inherited from NetPeer.)
Public method | Start | Binds to socket and spawns the networking thread (Inherited from NetPeer.)
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)
Public method | WaitMessage | Read a pending message from any connection, blocking up to maxMillis if needed (Inherited from NetPeer.)

See Also

NetClient Class


Connect Method

[image] [image]

Lidgren Network Library documentation
NetClient..::..Connect Method
NetClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect(IPEndPoint) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(IPEndPoint, NetOutgoingMessage) | Connect to a remote server (Overrides NetPeer..::..Connect(IPEndPoint, NetOutgoingMessage).)
Public method | Connect(String, Int32) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(String, Int32, NetOutgoingMessage) | Create a connection to a remote endpoint (Inherited from NetPeer.)

See Also

NetClient Class
NetClient Members


Connect Method (IPEndPoint, NetOutgoingMessage)

[image]

Lidgren Network Library documentation
NetClient..::..Connect Method (IPEndPoint, NetOutgoingMessage)
NetClient Class See Also Send Feedback
Connect to a remote server

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override NetConnection Connect(
    IPEndPoint remoteEndpoint,
    NetOutgoingMessage hailMessage
)
Visual Basic
Public Overrides Function Connect ( _
    remoteEndpoint As IPEndPoint, _
    hailMessage As NetOutgoingMessage _
) As NetConnection
Visual C++
public:
virtual NetConnection^ Connect(
    IPEndPoint^ remoteEndpoint,
    NetOutgoingMessage^ hailMessage
) override

Parameters

remoteEndpoint
Type: System.Net..::..IPEndPoint
The remote endpoint to connect to
hailMessage
Type: Lidgren.Network..::..NetOutgoingMessage
The hail message to pass

Return Value

server connection, or null if already connected

See Also

NetClient Class
Connect Overload


CreateMessage Method

[image] [image]

Lidgren Network Library documentation
NetClient..::..CreateMessage Method
NetClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateMessage()()()() | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(Int32) | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(String) | Creates a new message for sending and writes the provided string to it (Inherited from NetPeer.)

See Also

NetClient Class
NetClient Members


Disconnect Method

[image]

Lidgren Network Library documentation
NetClient..::..Disconnect Method
NetClient Class See Also Send Feedback
Disconnect from server

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Disconnect(
    string byeMessage
)
Visual Basic
Public Sub Disconnect ( _
    byeMessage As String _
)
Visual C++
public:
void Disconnect(
    String^ byeMessage
)

Parameters

byeMessage
Type: System..::..String
reason for disconnect

See Also

NetClient Class


DiscoverKnownPeer Method

[image] [image]

Lidgren Network Library documentation
NetClient..::..DiscoverKnownPeer Method
NetClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DiscoverKnownPeer(IPEndPoint) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverKnownPeer(String, Int32) | Emit a discovery signal to a single known host (Inherited from NetPeer.)

See Also

NetClient Class
NetClient Members


SendMessage Method

[image] [image]

Lidgren Network Library documentation
NetClient..::..SendMessage Method
NetClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendMessage(NetOutgoingMessage, NetDeliveryMethod) | Sends message to server
Public method | SendMessage(NetOutgoingMessage, NetDeliveryMethod, Int32) | Sends message to server
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, IList<(Of <<'(NetConnection>)>>), NetDeliveryMethod, Int32) | Send a message to a list of connections (Inherited from NetPeer.)

See Also

NetClient Class
NetClient Members


SendMessage Method (NetOutgoingMessage, NetDeliveryMethod)

[image]

Lidgren Network Library documentation
NetClient..::..SendMessage Method (NetOutgoingMessage, NetDeliveryMethod)
NetClient Class See Also Send Feedback
Sends message to server

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetSendResult SendMessage(
    NetOutgoingMessage msg,
    NetDeliveryMethod method
)
Visual Basic
Public Function SendMessage ( _
    msg As NetOutgoingMessage, _
    method As NetDeliveryMethod _
) As NetSendResult
Visual C++
public:
NetSendResult SendMessage(
    NetOutgoingMessage^ msg,
    NetDeliveryMethod method
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetClient.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetDeliveryMethod)"]

method
Type: Lidgren.Network..::..NetDeliveryMethod

[Missing <param name="method"/> documentation for "M:Lidgren.Network.NetClient.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetDeliveryMethod)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetClient.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetDeliveryMethod)"]

See Also

NetClient Class
SendMessage Overload


SendMessage Method (NetOutgoingMessage, NetDeliveryMethod, Int32)

[image]

Lidgren Network Library documentation
NetClient..::..SendMessage Method (NetOutgoingMessage, NetDeliveryMethod, Int32)
NetClient Class See Also Send Feedback
Sends message to server

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetSendResult SendMessage(
    NetOutgoingMessage msg,
    NetDeliveryMethod method,
    int sequenceChannel
)
Visual Basic
Public Function SendMessage ( _
    msg As NetOutgoingMessage, _
    method As NetDeliveryMethod, _
    sequenceChannel As Integer _
) As NetSendResult
Visual C++
public:
NetSendResult SendMessage(
    NetOutgoingMessage^ msg,
    NetDeliveryMethod method,
    int sequenceChannel
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetClient.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetDeliveryMethod,System.Int32)"]

method
Type: Lidgren.Network..::..NetDeliveryMethod

[Missing <param name="method"/> documentation for "M:Lidgren.Network.NetClient.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetDeliveryMethod,System.Int32)"]

sequenceChannel
Type: System..::..Int32

[Missing <param name="sequenceChannel"/> documentation for "M:Lidgren.Network.NetClient.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetDeliveryMethod,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetClient.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetDeliveryMethod,System.Int32)"]

See Also

NetClient Class
SendMessage Overload


SendUnconnectedMessage Method

[image] [image]

Lidgren Network Library documentation
NetClient..::..SendUnconnectedMessage Method
NetClient Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendUnconnectedMessage(NetOutgoingMessage, IList<(Of <<'(IPEndPoint>)>>)) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, IPEndPoint) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, String, Int32) | Send a message to an unconnected host (Inherited from NetPeer.)

See Also

NetClient Class
NetClient Members


ToString Method

[image]

Lidgren Network Library documentation
NetClient..::..ToString Method
NetClient Class See Also Send Feedback
Returns a string that represents this object

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetClient.ToString"]

See Also

NetClient Class


NetClient Properties

[image] [image]

Lidgren Network Library documentation
NetClient Properties
NetClient Class See Also Send Feedback

The NetClient type exposes the following members.

Properties

 | Name | Description
Public property | Configuration | Gets the configuration used to instanciate this NetPeer (Inherited from NetPeer.)
Public property | Connections | Gets a copy of the list of connections (Inherited from NetPeer.)
Public property | ConnectionsCount | Gets the number of active connections (Inherited from NetPeer.)
Public property | ConnectionStatus | Gets the connection status of the server connection (or NetConnectionStatus.Disconnected if no connection)
Public property | MessageReceivedEvent | Signalling event which can be waited on to determine when a message is queued for reading. Note that there is no guarantee that after the event is signaled the blocked thread will find the message in the queue. Other user created threads could be preempted and dequeue the message before the waiting thread wakes up. (Inherited from NetPeer.)
Public property | Port | Gets the port number this NetPeer is listening and sending on, if Start() has been called (Inherited from NetPeer.)
Public property | ServerConnection | Gets the connection to the server, if any
Public property | Socket | Gets the socket, if Start() has been called (Inherited from NetPeer.)
Public property | Statistics | Statistics on this NetPeer since it was initialized (Inherited from NetPeer.)
Public property | Status | Gets the NetPeerStatus of the NetPeer (Inherited from NetPeer.)
Public property | Tag | Gets or sets the application defined object containing data about the peer (Inherited from NetPeer.)
Public property | UniqueIdentifier | Gets a unique identifier for this NetPeer based on Mac address and ip/port. Note! Not available until Start() has been called! (Inherited from NetPeer.)
Public property | UPnP | Returns an UPnP object if enabled in the NetPeerConfiguration (Inherited from NetPeer.)

See Also

NetClient Class


ConnectionStatus Property

[image]

Lidgren Network Library documentation
NetClient..::..ConnectionStatus Property
NetClient Class See Also Send Feedback
Gets the connection status of the server connection (or NetConnectionStatus.Disconnected if no connection)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetConnectionStatus ConnectionStatus { get; }
Visual Basic
Public ReadOnly Property ConnectionStatus As NetConnectionStatus
    Get
Visual C++
public:
property NetConnectionStatus ConnectionStatus {
    NetConnectionStatus get ();
}

See Also

NetClient Class


ServerConnection Property

[image]

Lidgren Network Library documentation
NetClient..::..ServerConnection Property
NetClient Class See Also Send Feedback
Gets the connection to the server, if any

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetConnection ServerConnection { get; }
Visual Basic
Public ReadOnly Property ServerConnection As NetConnection
    Get
Visual C++
public:
property NetConnection^ ServerConnection {
    NetConnection^ get ();
}

See Also

NetClient Class


NetConnection Class

[image]

Lidgren Network Library documentation
NetConnection Class
Members See Also Send Feedback
Represents a connection to a remote peer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetConnection
Visual Basic
Public Class NetConnection
Visual C++
public ref class NetConnection

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetConnection

See Also

NetConnection Members


NetConnection Members

[image] [image]

Lidgren Network Library documentation
NetConnection Members
NetConnection Class Methods Properties See Also Send Feedback

The NetConnection type exposes the following members.

Methods

 | Name | Description
Public method | Approve()()()() | Approves this connection; sending a connection response to the remote host
Public method | Approve(NetOutgoingMessage) | Approves this connection; sending a connection response to the remote host
Public method | Deny()()()() | Denies this connection; disconnecting it
Public method | Deny(String) | Denies this connection; disconnecting it
Public method | Disconnect | Disconnect from the remote peer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalTime | Gets local time value comparable to NetTime.Now from a remote value
Public method | GetRemoteTime | Gets the remote time value for a local time value produced by NetTime.Now
Public method | GetSendQueueInfo | Zero windowSize indicates that the channel is not yet instantiated (used) Negative freeWindowSlots means this amount of messages are currently queued but delayed due to closed window
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendMessage | Send a message to this remote connection
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AverageRoundtripTime | Gets the current average roundtrip time in seconds
Public property | LocalHailMessage | Gets the local hail message that was sent as part of the handshake
Public property | Peer | Gets the peer which holds this connection
Public property | RemoteEndpoint | Gets the remote endpoint for the connection
Public property | RemoteHailMessage | The message that the remote part specified via Connect() or Approve() - can be null.
Public property | RemoteTimeOffset | Time offset between this peer and the remote peer
Public property | RemoteUniqueIdentifier | Gets the unique identifier of the remote NetPeer for this connection
Public property | Statistics | Gets various statistics for this connection
Public property | Status | Gets the current status of the connection (synced to the last status message read)
Public property | Tag | Gets or sets the application defined object containing data about the connection

See Also

NetConnection Class


NetConnection Methods

[image] [image]

Lidgren Network Library documentation
NetConnection Methods
NetConnection Class See Also Send Feedback

The NetConnection type exposes the following members.

Methods

 | Name | Description
Public method | Approve()()()() | Approves this connection; sending a connection response to the remote host
Public method | Approve(NetOutgoingMessage) | Approves this connection; sending a connection response to the remote host
Public method | Deny()()()() | Denies this connection; disconnecting it
Public method | Deny(String) | Denies this connection; disconnecting it
Public method | Disconnect | Disconnect from the remote peer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalTime | Gets local time value comparable to NetTime.Now from a remote value
Public method | GetRemoteTime | Gets the remote time value for a local time value produced by NetTime.Now
Public method | GetSendQueueInfo | Zero windowSize indicates that the channel is not yet instantiated (used) Negative freeWindowSlots means this amount of messages are currently queued but delayed due to closed window
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendMessage | Send a message to this remote connection
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

See Also

NetConnection Class


Approve Method

[image] [image]

Lidgren Network Library documentation
NetConnection..::..Approve Method
NetConnection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Approve()()()() | Approves this connection; sending a connection response to the remote host
Public method | Approve(NetOutgoingMessage) | Approves this connection; sending a connection response to the remote host

See Also

NetConnection Class
NetConnection Members


Approve Method

[image]

Lidgren Network Library documentation
NetConnection..::..Approve Method
NetConnection Class See Also Send Feedback
Approves this connection; sending a connection response to the remote host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Approve()
Visual Basic
Public Sub Approve
Visual C++
public:
void Approve()

See Also

NetConnection Class
Approve Overload


Approve Method (NetOutgoingMessage)

[image]

Lidgren Network Library documentation
NetConnection..::..Approve Method (NetOutgoingMessage)
NetConnection Class See Also Send Feedback
Approves this connection; sending a connection response to the remote host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Approve(
    NetOutgoingMessage localHail
)
Visual Basic
Public Sub Approve ( _
    localHail As NetOutgoingMessage _
)
Visual C++
public:
void Approve(
    NetOutgoingMessage^ localHail
)

Parameters

localHail
Type: Lidgren.Network..::..NetOutgoingMessage
The local hail message that will be set as RemoteHailMessage on the remote host

See Also

NetConnection Class
Approve Overload


Deny Method

[image] [image]

Lidgren Network Library documentation
NetConnection..::..Deny Method
NetConnection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Deny()()()() | Denies this connection; disconnecting it
Public method | Deny(String) | Denies this connection; disconnecting it

See Also

NetConnection Class
NetConnection Members


Deny Method

[image]

Lidgren Network Library documentation
NetConnection..::..Deny Method
NetConnection Class See Also Send Feedback
Denies this connection; disconnecting it

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Deny()
Visual Basic
Public Sub Deny
Visual C++
public:
void Deny()

See Also

NetConnection Class
Deny Overload


Deny Method (String)

[image]

Lidgren Network Library documentation
NetConnection..::..Deny Method (String)
NetConnection Class See Also Send Feedback
Denies this connection; disconnecting it

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Deny(
    string reason
)
Visual Basic
Public Sub Deny ( _
    reason As String _
)
Visual C++
public:
void Deny(
    String^ reason
)

Parameters

reason
Type: System..::..String
The stated reason for the disconnect, readable as a string in the StatusChanged message on the remote host

See Also

NetConnection Class
Deny Overload


Disconnect Method

[image]

Lidgren Network Library documentation
NetConnection..::..Disconnect Method
NetConnection Class See Also Send Feedback
Disconnect from the remote peer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Disconnect(
    string byeMessage
)
Visual Basic
Public Sub Disconnect ( _
    byeMessage As String _
)
Visual C++
public:
void Disconnect(
    String^ byeMessage
)

Parameters

byeMessage
Type: System..::..String
the message to send with the disconnect message

See Also

NetConnection Class


GetLocalTime Method

[image]

Lidgren Network Library documentation
NetConnection..::..GetLocalTime Method
NetConnection Class See Also Send Feedback
Gets local time value comparable to NetTime.Now from a remote value

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public double GetLocalTime(
    double remoteTimestamp
)
Visual Basic
Public Function GetLocalTime ( _
    remoteTimestamp As Double _
) As Double
Visual C++
public:
double GetLocalTime(
    double remoteTimestamp
)

Parameters

remoteTimestamp
Type: System..::..Double

[Missing <param name="remoteTimestamp"/> documentation for "M:Lidgren.Network.NetConnection.GetLocalTime(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetConnection.GetLocalTime(System.Double)"]

See Also

NetConnection Class


GetRemoteTime Method

[image]

Lidgren Network Library documentation
NetConnection..::..GetRemoteTime Method
NetConnection Class See Also Send Feedback
Gets the remote time value for a local time value produced by NetTime.Now

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public double GetRemoteTime(
    double localTimestamp
)
Visual Basic
Public Function GetRemoteTime ( _
    localTimestamp As Double _
) As Double
Visual C++
public:
double GetRemoteTime(
    double localTimestamp
)

Parameters

localTimestamp
Type: System..::..Double

[Missing <param name="localTimestamp"/> documentation for "M:Lidgren.Network.NetConnection.GetRemoteTime(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetConnection.GetRemoteTime(System.Double)"]

See Also

NetConnection Class


GetSendQueueInfo Method

[image]

Lidgren Network Library documentation
NetConnection..::..GetSendQueueInfo Method
NetConnection Class See Also Send Feedback
Zero windowSize indicates that the channel is not yet instantiated (used) Negative freeWindowSlots means this amount of messages are currently queued but delayed due to closed window

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void GetSendQueueInfo(
    NetDeliveryMethod method,
    int sequenceChannel,
    out int windowSize,
    out int freeWindowSlots
)
Visual Basic
Public Sub GetSendQueueInfo ( _
    method As NetDeliveryMethod, _
    sequenceChannel As Integer, _
    <OutAttribute> ByRef windowSize As Integer, _
    <OutAttribute> ByRef freeWindowSlots As Integer _
)
Visual C++
public:
void GetSendQueueInfo(
    NetDeliveryMethod method,
    int sequenceChannel,
    [OutAttribute] int% windowSize,
    [OutAttribute] int% freeWindowSlots
)

Parameters

method
Type: Lidgren.Network..::..NetDeliveryMethod

[Missing <param name="method"/> documentation for "M:Lidgren.Network.NetConnection.GetSendQueueInfo(Lidgren.Network.NetDeliveryMethod,System.Int32,System.Int32@,System.Int32@)"]

sequenceChannel
Type: System..::..Int32

[Missing <param name="sequenceChannel"/> documentation for "M:Lidgren.Network.NetConnection.GetSendQueueInfo(Lidgren.Network.NetDeliveryMethod,System.Int32,System.Int32@,System.Int32@)"]

windowSize
Type: System..::..Int32 %

[Missing <param name="windowSize"/> documentation for "M:Lidgren.Network.NetConnection.GetSendQueueInfo(Lidgren.Network.NetDeliveryMethod,System.Int32,System.Int32@,System.Int32@)"]

freeWindowSlots
Type: System..::..Int32 %

[Missing <param name="freeWindowSlots"/> documentation for "M:Lidgren.Network.NetConnection.GetSendQueueInfo(Lidgren.Network.NetDeliveryMethod,System.Int32,System.Int32@,System.Int32@)"]

See Also

NetConnection Class


SendMessage Method

[image]

Lidgren Network Library documentation
NetConnection..::..SendMessage Method
NetConnection Class See Also Send Feedback
Send a message to this remote connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetSendResult SendMessage(
    NetOutgoingMessage msg,
    NetDeliveryMethod method,
    int sequenceChannel
)
Visual Basic
Public Function SendMessage ( _
    msg As NetOutgoingMessage, _
    method As NetDeliveryMethod, _
    sequenceChannel As Integer _
) As NetSendResult
Visual C++
public:
NetSendResult SendMessage(
    NetOutgoingMessage^ msg,
    NetDeliveryMethod method,
    int sequenceChannel
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage
The message to send
method
Type: Lidgren.Network..::..NetDeliveryMethod
How to deliver the message
sequenceChannel
Type: System..::..Int32
Sequence channel within the delivery method

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetConnection.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetDeliveryMethod,System.Int32)"]

See Also

NetConnection Class


ToString Method

[image]

Lidgren Network Library documentation
NetConnection..::..ToString Method
NetConnection Class See Also Send Feedback
Returns a string that represents this object

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetConnection.ToString"]

See Also

NetConnection Class


NetConnection Properties

[image] [image]

Lidgren Network Library documentation
NetConnection Properties
NetConnection Class See Also Send Feedback

The NetConnection type exposes the following members.

Properties

 | Name | Description
Public property | AverageRoundtripTime | Gets the current average roundtrip time in seconds
Public property | LocalHailMessage | Gets the local hail message that was sent as part of the handshake
Public property | Peer | Gets the peer which holds this connection
Public property | RemoteEndpoint | Gets the remote endpoint for the connection
Public property | RemoteHailMessage | The message that the remote part specified via Connect() or Approve() - can be null.
Public property | RemoteTimeOffset | Time offset between this peer and the remote peer
Public property | RemoteUniqueIdentifier | Gets the unique identifier of the remote NetPeer for this connection
Public property | Statistics | Gets various statistics for this connection
Public property | Status | Gets the current status of the connection (synced to the last status message read)
Public property | Tag | Gets or sets the application defined object containing data about the connection

See Also

NetConnection Class


AverageRoundtripTime Property

[image]

Lidgren Network Library documentation
NetConnection..::..AverageRoundtripTime Property
NetConnection Class See Also Send Feedback
Gets the current average roundtrip time in seconds

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float AverageRoundtripTime { get; }
Visual Basic
Public ReadOnly Property AverageRoundtripTime As Single
    Get
Visual C++
public:
property float AverageRoundtripTime {
    float get ();
}

See Also

NetConnection Class


LocalHailMessage Property

[image]

Lidgren Network Library documentation
NetConnection..::..LocalHailMessage Property
NetConnection Class See Also Send Feedback
Gets the local hail message that was sent as part of the handshake

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetOutgoingMessage LocalHailMessage { get; }
Visual Basic
Public ReadOnly Property LocalHailMessage As NetOutgoingMessage
    Get
Visual C++
public:
property NetOutgoingMessage^ LocalHailMessage {
    NetOutgoingMessage^ get ();
}

See Also

NetConnection Class


Peer Property

[image]

Lidgren Network Library documentation
NetConnection..::..Peer Property
NetConnection Class See Also Send Feedback
Gets the peer which holds this connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetPeer Peer { get; }
Visual Basic
Public ReadOnly Property Peer As NetPeer
    Get
Visual C++
public:
property NetPeer^ Peer {
    NetPeer^ get ();
}

See Also

NetConnection Class


RemoteEndpoint Property

[image]

Lidgren Network Library documentation
NetConnection..::..RemoteEndpoint Property
NetConnection Class See Also Send Feedback
Gets the remote endpoint for the connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public IPEndPoint RemoteEndpoint { get; }
Visual Basic
Public ReadOnly Property RemoteEndpoint As IPEndPoint
    Get
Visual C++
public:
property IPEndPoint^ RemoteEndpoint {
    IPEndPoint^ get ();
}

See Also

NetConnection Class


RemoteHailMessage Property

[image]

Lidgren Network Library documentation
NetConnection..::..RemoteHailMessage Property
NetConnection Class See Also Send Feedback
The message that the remote part specified via Connect() or Approve() - can be null.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetIncomingMessage RemoteHailMessage { get; }
Visual Basic
Public ReadOnly Property RemoteHailMessage As NetIncomingMessage
    Get
Visual C++
public:
property NetIncomingMessage^ RemoteHailMessage {
    NetIncomingMessage^ get ();
}

See Also

NetConnection Class


RemoteTimeOffset Property

[image]

Lidgren Network Library documentation
NetConnection..::..RemoteTimeOffset Property
NetConnection Class See Also Send Feedback
Time offset between this peer and the remote peer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float RemoteTimeOffset { get; }
Visual Basic
Public ReadOnly Property RemoteTimeOffset As Single
    Get
Visual C++
public:
property float RemoteTimeOffset {
    float get ();
}

See Also

NetConnection Class


RemoteUniqueIdentifier Property

[image]

Lidgren Network Library documentation
NetConnection..::..RemoteUniqueIdentifier Property
NetConnection Class See Also Send Feedback
Gets the unique identifier of the remote NetPeer for this connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public long RemoteUniqueIdentifier { get; }
Visual Basic
Public ReadOnly Property RemoteUniqueIdentifier As Long
    Get
Visual C++
public:
property long long RemoteUniqueIdentifier {
    long long get ();
}

See Also

NetConnection Class


Statistics Property

[image]

Lidgren Network Library documentation
NetConnection..::..Statistics Property
NetConnection Class See Also Send Feedback
Gets various statistics for this connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetConnectionStatistics Statistics { get; }
Visual Basic
Public ReadOnly Property Statistics As NetConnectionStatistics
    Get
Visual C++
public:
property NetConnectionStatistics^ Statistics {
    NetConnectionStatistics^ get ();
}

See Also

NetConnection Class


Status Property

[image]

Lidgren Network Library documentation
NetConnection..::..Status Property
NetConnection Class See Also Send Feedback
Gets the current status of the connection (synced to the last status message read)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetConnectionStatus Status { get; }
Visual Basic
Public ReadOnly Property Status As NetConnectionStatus
    Get
Visual C++
public:
property NetConnectionStatus Status {
    NetConnectionStatus get ();
}

See Also

NetConnection Class


Tag Property

[image]

Lidgren Network Library documentation
NetConnection..::..Tag Property
NetConnection Class See Also Send Feedback
Gets or sets the application defined object containing data about the connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set
Visual C++
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

See Also

NetConnection Class


NetConnectionStatistics Class

[image]

Lidgren Network Library documentation
NetConnectionStatistics Class
Members See Also Send Feedback
Statistics for a NetConnection instance

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public sealed class NetConnectionStatistics
Visual Basic
Public NotInheritable Class NetConnectionStatistics
Visual C++
public ref class NetConnectionStatistics sealed

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetConnectionStatistics

See Also

NetConnectionStatistics Members


NetConnectionStatistics Members

[image] [image]

Lidgren Network Library documentation
NetConnectionStatistics Members
NetConnectionStatistics Class Methods Properties See Also Send Feedback

The NetConnectionStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ReceivedBytes | Gets the number of received bytes for this connection
Public property | ReceivedPackets | Gets the number of received packets for this connection
Public property | ResentMessages | Gets the number of resent reliable messages for this connection
Public property | SentBytes | Gets the number of sent bytes for this connection
Public property | SentPackets | Gets the number of sent packets for this connection

See Also

NetConnectionStatistics Class


NetConnectionStatistics Methods

[image] [image]

Lidgren Network Library documentation
NetConnectionStatistics Methods
NetConnectionStatistics Class See Also Send Feedback

The NetConnectionStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

See Also

NetConnectionStatistics Class


ToString Method

[image]

Lidgren Network Library documentation
NetConnectionStatistics..::..ToString Method
NetConnectionStatistics Class See Also Send Feedback
Returns a string that represents this object

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetConnectionStatistics.ToString"]

See Also

NetConnectionStatistics Class


NetConnectionStatistics Properties

[image] [image]

Lidgren Network Library documentation
NetConnectionStatistics Properties
NetConnectionStatistics Class See Also Send Feedback

The NetConnectionStatistics type exposes the following members.

Properties

 | Name | Description
Public property | ReceivedBytes | Gets the number of received bytes for this connection
Public property | ReceivedPackets | Gets the number of received packets for this connection
Public property | ResentMessages | Gets the number of resent reliable messages for this connection
Public property | SentBytes | Gets the number of sent bytes for this connection
Public property | SentPackets | Gets the number of sent packets for this connection

See Also

NetConnectionStatistics Class


ReceivedBytes Property

[image]

Lidgren Network Library documentation
NetConnectionStatistics..::..ReceivedBytes Property
NetConnectionStatistics Class See Also Send Feedback
Gets the number of received bytes for this connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReceivedBytes { get; }
Visual Basic
Public ReadOnly Property ReceivedBytes As Integer
    Get
Visual C++
public:
property int ReceivedBytes {
    int get ();
}

See Also

NetConnectionStatistics Class


ReceivedPackets Property

[image]

Lidgren Network Library documentation
NetConnectionStatistics..::..ReceivedPackets Property
NetConnectionStatistics Class See Also Send Feedback
Gets the number of received packets for this connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReceivedPackets { get; }
Visual Basic
Public ReadOnly Property ReceivedPackets As Integer
    Get
Visual C++
public:
property int ReceivedPackets {
    int get ();
}

See Also

NetConnectionStatistics Class


ResentMessages Property

[image]

Lidgren Network Library documentation
NetConnectionStatistics..::..ResentMessages Property
NetConnectionStatistics Class See Also Send Feedback
Gets the number of resent reliable messages for this connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ResentMessages { get; }
Visual Basic
Public ReadOnly Property ResentMessages As Integer
    Get
Visual C++
public:
property int ResentMessages {
    int get ();
}

See Also

NetConnectionStatistics Class


SentBytes Property

[image]

Lidgren Network Library documentation
NetConnectionStatistics..::..SentBytes Property
NetConnectionStatistics Class See Also Send Feedback
Gets the number of sent bytes for this connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int SentBytes { get; }
Visual Basic
Public ReadOnly Property SentBytes As Integer
    Get
Visual C++
public:
property int SentBytes {
    int get ();
}

See Also

NetConnectionStatistics Class


SentPackets Property

[image]

Lidgren Network Library documentation
NetConnectionStatistics..::..SentPackets Property
NetConnectionStatistics Class See Also Send Feedback
Gets the number of sent packets for this connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int SentPackets { get; }
Visual Basic
Public ReadOnly Property SentPackets As Integer
    Get
Visual C++
public:
property int SentPackets {
    int get ();
}

See Also

NetConnectionStatistics Class


NetConnectionStatus Enumeration

[image]

Lidgren Network Library documentation
NetConnectionStatus Enumeration
See Also Send Feedback
Status for a NetConnection instance

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public enum NetConnectionStatus
Visual Basic
Public Enumeration NetConnectionStatus
Visual C++
public enum class NetConnectionStatus

Members

Member name | Description
None |
InitiatedConnect |
RespondedConnect |
Connected |
Disconnecting |
Disconnected |

See Also

Lidgren.Network Namespace


NetDeliveryMethod Enumeration

[image]

Lidgren Network Library documentation
NetDeliveryMethod Enumeration
See Also Send Feedback
How the library deals with resends and handling of late messages

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public enum NetDeliveryMethod
Visual Basic
Public Enumeration NetDeliveryMethod
Visual C++
public enum class NetDeliveryMethod

Members

Member name | Description
Unknown |
Unreliable |
UnreliableSequenced |
ReliableUnordered |
ReliableSequenced |
ReliableOrdered |

See Also

Lidgren.Network Namespace


NetDESEncryption Class

[image]

Lidgren Network Library documentation
NetDESEncryption Class
Members See Also Send Feedback
DES encryption

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetDESEncryption : INetEncryption
Visual Basic
Public Class NetDESEncryption _
    Implements INetEncryption
Visual C++
public ref class NetDESEncryption : INetEncryption

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetDESEncryption

See Also

NetDESEncryption Members


NetDESEncryption Members

[image] [image]

Lidgren Network Library documentation
NetDESEncryption Members
NetDESEncryption Class Constructors Methods See Also Send Feedback

The NetDESEncryption type exposes the following members.

Constructors

 | Name | Description
Public method | NetDESEncryption(String) | NetDESEncryption constructor
Public method | NetDESEncryption(array<Byte>[]()[][], array<Byte>[]()[][]) | NetDESEncryption constructor
Public method | NetDESEncryption(String, Int32) | NetDESEncryption constructor

Methods

 | Name | Description
Public method | Decrypt | Decrypt incoming message
Public method | Encrypt | Encrypt outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetDESEncryption Class


NetDESEncryption Constructor

[image] [image]

Lidgren Network Library documentation
NetDESEncryption Constructor
NetDESEncryption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NetDESEncryption(String) | NetDESEncryption constructor
Public method | NetDESEncryption(array<Byte>[]()[][], array<Byte>[]()[][]) | NetDESEncryption constructor
Public method | NetDESEncryption(String, Int32) | NetDESEncryption constructor

See Also

NetDESEncryption Class
NetDESEncryption Members


NetDESEncryption Constructor (String)

[image]

Lidgren Network Library documentation
NetDESEncryption Constructor (String)
NetDESEncryption Class See Also Send Feedback
NetDESEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetDESEncryption(
    string key
)
Visual Basic
Public Sub New ( _
    key As String _
)
Visual C++
public:
NetDESEncryption(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetDESEncryption.#ctor(System.String)"]

See Also

NetDESEncryption Class
NetDESEncryption Overload


NetDESEncryption Constructor (Byte[], Byte[])

[image]

Lidgren Network Library documentation
NetDESEncryption Constructor (array<Byte>[]()[][], array<Byte>[]()[][])
NetDESEncryption Class See Also Send Feedback
NetDESEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetDESEncryption(
    byte[] key,
    byte[] iv
)
Visual Basic
Public Sub New ( _
    key As Byte(), _
    iv As Byte() _
)
Visual C++
public:
NetDESEncryption(
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)

Parameters

key
Type: array< System..::..Byte >[]()[][]

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetDESEncryption.#ctor(System.Byte[],System.Byte[])"]

iv
Type: array< System..::..Byte >[]()[][]

[Missing <param name="iv"/> documentation for "M:Lidgren.Network.NetDESEncryption.#ctor(System.Byte[],System.Byte[])"]

See Also

NetDESEncryption Class
NetDESEncryption Overload


NetDESEncryption Constructor (String, Int32)

[image]

Lidgren Network Library documentation
NetDESEncryption Constructor (String, Int32)
NetDESEncryption Class See Also Send Feedback
NetDESEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetDESEncryption(
    string key,
    int bitsize
)
Visual Basic
Public Sub New ( _
    key As String, _
    bitsize As Integer _
)
Visual C++
public:
NetDESEncryption(
    String^ key,
    int bitsize
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetDESEncryption.#ctor(System.String,System.Int32)"]

bitsize
Type: System..::..Int32

[Missing <param name="bitsize"/> documentation for "M:Lidgren.Network.NetDESEncryption.#ctor(System.String,System.Int32)"]

See Also

NetDESEncryption Class
NetDESEncryption Overload


NetDESEncryption Methods

[image] [image]

Lidgren Network Library documentation
NetDESEncryption Methods
NetDESEncryption Class See Also Send Feedback

The NetDESEncryption type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt incoming message
Public method | Encrypt | Encrypt outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetDESEncryption Class


Decrypt Method

[image]

Lidgren Network Library documentation
NetDESEncryption..::..Decrypt Method
NetDESEncryption Class See Also Send Feedback
Decrypt incoming message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Decrypt(
    NetIncomingMessage msg
)
Visual Basic
Public Function Decrypt ( _
    msg As NetIncomingMessage _
) As Boolean
Visual C++
public:
virtual bool Decrypt(
    NetIncomingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetIncomingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetDESEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetDESEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Implements

INetEncryption..::..Decrypt(NetIncomingMessage)

See Also

NetDESEncryption Class


Encrypt Method

[image]

Lidgren Network Library documentation
NetDESEncryption..::..Encrypt Method
NetDESEncryption Class See Also Send Feedback
Encrypt outgoing message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Encrypt(
    NetOutgoingMessage msg
)
Visual Basic
Public Function Encrypt ( _
    msg As NetOutgoingMessage _
) As Boolean
Visual C++
public:
virtual bool Encrypt(
    NetOutgoingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetDESEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetDESEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Implements

INetEncryption..::..Encrypt(NetOutgoingMessage)

See Also

NetDESEncryption Class


NetException Class

[image]

Lidgren Network Library documentation
NetException Class
Members See Also Send Feedback
Exception thrown in the Lidgren Network Library

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
[SerializableAttribute]
public sealed class NetException : Exception
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class NetException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class NetException sealed : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Lidgren.Network..::..NetException

See Also

NetException Members


NetException Members

[image] [image]

Lidgren Network Library documentation
NetException Members
NetException Class Constructors Methods Properties See Also Send Feedback

The NetException type exposes the following members.

Constructors

 | Name | Description
Public method | NetException()()()() | NetException constructor
Public method | NetException(String) | NetException constructor
Public method | NetException(String, Exception) | NetException constructor

Methods

 | Name | Description
 | Assert(Boolean) | Throws an exception, in DEBUG only, if first parameter is false
 | Assert(Boolean, String) | Throws an exception, in DEBUG only, if first parameter is false
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NetException Class


NetException Constructor

[image] [image]

Lidgren Network Library documentation
NetException Constructor
NetException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NetException()()()() | NetException constructor
Public method | NetException(String) | NetException constructor
Public method | NetException(String, Exception) | NetException constructor

See Also

NetException Class
NetException Members


NetException Constructor

[image]

Lidgren Network Library documentation
NetException Constructor
NetException Class See Also Send Feedback
NetException constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetException()
Visual Basic
Public Sub New
Visual C++
public:
NetException()

See Also

NetException Class
NetException Overload


NetException Constructor (String)

[image]

Lidgren Network Library documentation
NetException Constructor (String)
NetException Class See Also Send Feedback
NetException constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
NetException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lidgren.Network.NetException.#ctor(System.String)"]

See Also

NetException Class
NetException Overload


NetException Constructor (String, Exception)

[image]

Lidgren Network Library documentation
NetException Constructor (String, Exception)
NetException Class See Also Send Feedback
NetException constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
NetException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lidgren.Network.NetException.#ctor(System.String,System.Exception)"]

inner
Type: System..::..Exception

[Missing <param name="inner"/> documentation for "M:Lidgren.Network.NetException.#ctor(System.String,System.Exception)"]

See Also

NetException Class
NetException Overload


NetException Methods

[image] [image]

Lidgren Network Library documentation
NetException Methods
NetException Class See Also Send Feedback

The NetException type exposes the following members.

Methods

 | Name | Description
 | Assert(Boolean) | Throws an exception, in DEBUG only, if first parameter is false
 | Assert(Boolean, String) | Throws an exception, in DEBUG only, if first parameter is false
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NetException Class


Assert Method

[image] [image]

Lidgren Network Library documentation
NetException..::..Assert Method
NetException Class See Also Send Feedback

Overload List

Name | Description
Assert(Boolean) | Throws an exception, in DEBUG only, if first parameter is false
Assert(Boolean, String) | Throws an exception, in DEBUG only, if first parameter is false

See Also

NetException Class
NetException Members


Assert Method (Boolean)

[image]

Lidgren Network Library documentation
NetException..::..Assert Method (Boolean)
NetException Class See Also Send Feedback
Throws an exception, in DEBUG only, if first parameter is false

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static void Assert(
    bool isOk
)
Visual Basic
Public Shared Sub Assert ( _
    isOk As Boolean _
)
Visual C++
public:
static void Assert(
    bool isOk
)

Parameters

isOk
Type: System..::..Boolean

[Missing <param name="isOk"/> documentation for "M:Lidgren.Network.NetException.Assert(System.Boolean)"]

See Also

NetException Class
Assert Overload


Assert Method (Boolean, String)

[image]

Lidgren Network Library documentation
NetException..::..Assert Method (Boolean, String)
NetException Class See Also Send Feedback
Throws an exception, in DEBUG only, if first parameter is false

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static void Assert(
    bool isOk,
    string message
)
Visual Basic
Public Shared Sub Assert ( _
    isOk As Boolean, _
    message As String _
)
Visual C++
public:
static void Assert(
    bool isOk,
    String^ message
)

Parameters

isOk
Type: System..::..Boolean

[Missing <param name="isOk"/> documentation for "M:Lidgren.Network.NetException.Assert(System.Boolean,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:Lidgren.Network.NetException.Assert(System.Boolean,System.String)"]

See Also

NetException Class
Assert Overload


NetException Properties

[image] [image]

Lidgren Network Library documentation
NetException Properties
NetException Class See Also Send Feedback

The NetException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NetException Class


NetIncomingMessage Class

[image]

Lidgren Network Library documentation
NetIncomingMessage Class
Members See Also Send Feedback
Incoming message either sent from a remote peer or generated within the library

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetIncomingMessage
Visual Basic
Public Class NetIncomingMessage
Visual C++
public ref class NetIncomingMessage

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetIncomingMessage

See Also

NetIncomingMessage Members


NetIncomingMessage Members

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage Members
NetIncomingMessage Class Methods Properties See Also Send Feedback

The NetIncomingMessage type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt a message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekBoolean | Reads a 1-bit Boolean without advancing the read pointer
Public method | PeekByte()()()() | Reads a Byte without advancing the read pointer
Public method | PeekByte(Int32) | Reads the specified number of bits into a Byte without advancing the read pointer
Public method | PeekBytes(Int32) | Reads the specified number of bytes without advancing the read pointer
Public method | PeekBytes(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes without advancing the read pointer
Public method | PeekDataBuffer | Returns the internal data buffer, don't modify
Public method | PeekDouble | Reads a 64-bit Double without advancing the read pointer
Public method | PeekFloat | Reads a 32-bit Single without advancing the read pointer
Public method | PeekInt16 | Reads an Int16 without advancing the read pointer
Public method | PeekInt32()()()() | Reads an Int32 without advancing the read pointer
Public method | PeekInt32(Int32) | Reads the specified number of bits into an Int32 without advancing the read pointer
Public method | PeekInt64()()()() | Reads an Int64 without advancing the read pointer
Public method | PeekInt64(Int32) | Reads the specified number of bits into an Int64 without advancing the read pointer
Public method | PeekSByte | Reads an SByte without advancing the read pointer
Public method | PeekSingle | Reads a 32-bit Single without advancing the read pointer
Public method | PeekString | Reads a string without advancing the read pointer
Public method | PeekUInt16 | Reads a UInt16 without advancing the read pointer
Public method | PeekUInt32()()()() | Reads a UInt32 without advancing the read pointer
Public method | PeekUInt32(Int32) | Reads the specified number of bits into a UInt32 without advancing the read pointer
Public method | PeekUInt64()()()() | Reads a UInt64 without advancing the read pointer
Public method | PeekUInt64(Int32) | Reads the specified number of bits into an UInt64 without advancing the read pointer
Public method | ReadAllFields(Object) | Reads all public and private declared instance fields of the object in alphabetical order using reflection
Public method | ReadAllFields(Object, BindingFlags) | Reads all fields with the specified binding of the object in alphabetical order using reflection
Public method | ReadAllProperties(Object) | Reads all public and private declared instance fields of the object in alphabetical order using reflection
Public method | ReadAllProperties(Object, BindingFlags) | Reads all fields with the specified binding of the object in alphabetical order using reflection
Public method | ReadBits | Reads the specified number of bits into a preallocated array
Public method | ReadBoolean | Reads a boolean value (stored as a single bit) written using Write(bool)
Public method | ReadByte()()()() | Reads a byte
Public method | ReadByte(Int32) | Reads 1 to 8 bits into a byte
Public method | ReadBytes(Int32) | Reads the specified number of bytes
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes into a preallocated array
Public method | ReadDouble | Reads a 64 bit floating point value written using Write(Double)
Public method | ReadFloat | Reads a 32 bit floating point value written using Write(Single)
Public method | ReadInt16 | Reads a 16 bit signed integer written using Write(Int16)
Public method | ReadInt32()()()() | Reads a 32 bit signed integer written using Write(Int32)
Public method | ReadInt32(Int32) | Reads a signed integer stored in 1 to 32 bits, written using Write(Int32, Int32)
Public method | ReadInt64()()()() | Reads a 64 bit signed integer written using Write(Int64)
Public method | ReadInt64(Int32) | Reads a signed integer stored in 1 to 64 bits, written using Write(Int64, Int32)
Public method | ReadIPEndpoint | Reads a stored IPv4 endpoint description
Public method | ReadPadBits | Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.
Public method | ReadRangedInteger | Reads a 32 bit integer value written using WriteRangedInteger()
Public method | ReadRangedSingle | Reads a 32 bit floating point value written using WriteRangedSingle()
Public method | ReadSByte | Reads a signed byte
Public method | ReadSignedSingle | Reads a 32 bit floating point value written using WriteSignedSingle()
Public method | ReadSingle | Reads a 32 bit floating point value written using Write(Single)
Public method | ReadString | Reads a string written using Write(string)
Public method | ReadTime | Reads a value, in local time comparable to NetTime.Now, written using WriteTime() Must have a connected sender
Public method | ReadUInt16 | Reads a 16 bit unsigned integer written using Write(UInt16)
Public method | ReadUInt32()()()() | Reads an 32 bit unsigned integer written using Write(UInt32)
Public method | ReadUInt32(Int32) | Reads an unsigned integer stored in 1 to 32 bits, written using Write(UInt32, Int32)
Public method | ReadUInt64()()()() | Reads a 64 bit unsigned integer written using Write(UInt64)
Public method | ReadUInt64(Int32) | Reads an unsigned integer stored in 1 to 64 bits, written using Write(UInt64, Int32)
Public method | ReadUnitSingle | Reads a 32 bit floating point value written using WriteUnitSingle()
Public method | ReadVariableInt32 | Reads a variable sized Int32 written using WriteVariableInt32()
Public method | ReadVariableInt64 | Reads a variable sized Int64 written using WriteVariableInt64()
Public method | ReadVariableUInt32 | Reads a variable sized UInt32 written using WriteVariableUInt32()
Public method | ReadVariableUInt64 | Reads a variable sized UInt32 written using WriteVariableInt64()
Public method | SkipPadBits()()()() | Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.
Public method | SkipPadBits(Int32) | Pads data with the specified number of bits.
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DeliveryMethod | Gets the delivery method this message was sent with (if user data)
Public property | LengthBits | Gets the length of the message payload in bits
Public property | LengthBytes | Gets the length of the message payload in bytes
Public property | MessageType | Gets the type of this incoming message
Public property | Position | Gets or sets the read position in the buffer, in bits (not bytes)
Public property | PositionInBytes | Gets the position in the buffer in bytes; note that the bits of the first returned byte may already have been read - check the Position property to make sure.
Public property | ReceiveTime | What local time the message was received from the network
Public property | SenderConnection | NetConnection of sender, if any
Public property | SenderEndpoint | IPEndPoint of sender, if any
Public property | SequenceChannel | Gets the sequence channel this message was sent with (if user data)

See Also

NetIncomingMessage Class


NetIncomingMessage Methods

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage Methods
NetIncomingMessage Class See Also Send Feedback

The NetIncomingMessage type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt a message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekBoolean | Reads a 1-bit Boolean without advancing the read pointer
Public method | PeekByte()()()() | Reads a Byte without advancing the read pointer
Public method | PeekByte(Int32) | Reads the specified number of bits into a Byte without advancing the read pointer
Public method | PeekBytes(Int32) | Reads the specified number of bytes without advancing the read pointer
Public method | PeekBytes(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes without advancing the read pointer
Public method | PeekDataBuffer | Returns the internal data buffer, don't modify
Public method | PeekDouble | Reads a 64-bit Double without advancing the read pointer
Public method | PeekFloat | Reads a 32-bit Single without advancing the read pointer
Public method | PeekInt16 | Reads an Int16 without advancing the read pointer
Public method | PeekInt32()()()() | Reads an Int32 without advancing the read pointer
Public method | PeekInt32(Int32) | Reads the specified number of bits into an Int32 without advancing the read pointer
Public method | PeekInt64()()()() | Reads an Int64 without advancing the read pointer
Public method | PeekInt64(Int32) | Reads the specified number of bits into an Int64 without advancing the read pointer
Public method | PeekSByte | Reads an SByte without advancing the read pointer
Public method | PeekSingle | Reads a 32-bit Single without advancing the read pointer
Public method | PeekString | Reads a string without advancing the read pointer
Public method | PeekUInt16 | Reads a UInt16 without advancing the read pointer
Public method | PeekUInt32()()()() | Reads a UInt32 without advancing the read pointer
Public method | PeekUInt32(Int32) | Reads the specified number of bits into a UInt32 without advancing the read pointer
Public method | PeekUInt64()()()() | Reads a UInt64 without advancing the read pointer
Public method | PeekUInt64(Int32) | Reads the specified number of bits into an UInt64 without advancing the read pointer
Public method | ReadAllFields(Object) | Reads all public and private declared instance fields of the object in alphabetical order using reflection
Public method | ReadAllFields(Object, BindingFlags) | Reads all fields with the specified binding of the object in alphabetical order using reflection
Public method | ReadAllProperties(Object) | Reads all public and private declared instance fields of the object in alphabetical order using reflection
Public method | ReadAllProperties(Object, BindingFlags) | Reads all fields with the specified binding of the object in alphabetical order using reflection
Public method | ReadBits | Reads the specified number of bits into a preallocated array
Public method | ReadBoolean | Reads a boolean value (stored as a single bit) written using Write(bool)
Public method | ReadByte()()()() | Reads a byte
Public method | ReadByte(Int32) | Reads 1 to 8 bits into a byte
Public method | ReadBytes(Int32) | Reads the specified number of bytes
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes into a preallocated array
Public method | ReadDouble | Reads a 64 bit floating point value written using Write(Double)
Public method | ReadFloat | Reads a 32 bit floating point value written using Write(Single)
Public method | ReadInt16 | Reads a 16 bit signed integer written using Write(Int16)
Public method | ReadInt32()()()() | Reads a 32 bit signed integer written using Write(Int32)
Public method | ReadInt32(Int32) | Reads a signed integer stored in 1 to 32 bits, written using Write(Int32, Int32)
Public method | ReadInt64()()()() | Reads a 64 bit signed integer written using Write(Int64)
Public method | ReadInt64(Int32) | Reads a signed integer stored in 1 to 64 bits, written using Write(Int64, Int32)
Public method | ReadIPEndpoint | Reads a stored IPv4 endpoint description
Public method | ReadPadBits | Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.
Public method | ReadRangedInteger | Reads a 32 bit integer value written using WriteRangedInteger()
Public method | ReadRangedSingle | Reads a 32 bit floating point value written using WriteRangedSingle()
Public method | ReadSByte | Reads a signed byte
Public method | ReadSignedSingle | Reads a 32 bit floating point value written using WriteSignedSingle()
Public method | ReadSingle | Reads a 32 bit floating point value written using Write(Single)
Public method | ReadString | Reads a string written using Write(string)
Public method | ReadTime | Reads a value, in local time comparable to NetTime.Now, written using WriteTime() Must have a connected sender
Public method | ReadUInt16 | Reads a 16 bit unsigned integer written using Write(UInt16)
Public method | ReadUInt32()()()() | Reads an 32 bit unsigned integer written using Write(UInt32)
Public method | ReadUInt32(Int32) | Reads an unsigned integer stored in 1 to 32 bits, written using Write(UInt32, Int32)
Public method | ReadUInt64()()()() | Reads a 64 bit unsigned integer written using Write(UInt64)
Public method | ReadUInt64(Int32) | Reads an unsigned integer stored in 1 to 64 bits, written using Write(UInt64, Int32)
Public method | ReadUnitSingle | Reads a 32 bit floating point value written using WriteUnitSingle()
Public method | ReadVariableInt32 | Reads a variable sized Int32 written using WriteVariableInt32()
Public method | ReadVariableInt64 | Reads a variable sized Int64 written using WriteVariableInt64()
Public method | ReadVariableUInt32 | Reads a variable sized UInt32 written using WriteVariableUInt32()
Public method | ReadVariableUInt64 | Reads a variable sized UInt32 written using WriteVariableInt64()
Public method | SkipPadBits()()()() | Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.
Public method | SkipPadBits(Int32) | Pads data with the specified number of bits.
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

See Also

NetIncomingMessage Class


Decrypt Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..Decrypt Method
NetIncomingMessage Class See Also Send Feedback
Decrypt a message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Decrypt(
    INetEncryption encryption
)
Visual Basic
Public Function Decrypt ( _
    encryption As INetEncryption _
) As Boolean
Visual C++
public:
bool Decrypt(
    INetEncryption^ encryption
)

Parameters

encryption
Type: Lidgren.Network..::..INetEncryption
The encryption algorithm used to encrypt the message

Return Value

true on success

See Also

NetIncomingMessage Class


PeekBoolean Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekBoolean Method
NetIncomingMessage Class See Also Send Feedback
Reads a 1-bit Boolean without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool PeekBoolean()
Visual Basic
Public Function PeekBoolean As Boolean
Visual C++
public:
bool PeekBoolean()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekBoolean"]

See Also

NetIncomingMessage Class


PeekByte Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekByte Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PeekByte()()()() | Reads a Byte without advancing the read pointer
Public method | PeekByte(Int32) | Reads the specified number of bits into a Byte without advancing the read pointer

See Also

NetIncomingMessage Class
NetIncomingMessage Members


PeekByte Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekByte Method
NetIncomingMessage Class See Also Send Feedback
Reads a Byte without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public byte PeekByte()
Visual Basic
Public Function PeekByte As Byte
Visual C++
public:
unsigned char PeekByte()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekByte"]

See Also

NetIncomingMessage Class
PeekByte Overload


PeekByte Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekByte Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bits into a Byte without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public byte PeekByte(
    int numberOfBits
)
Visual Basic
Public Function PeekByte ( _
    numberOfBits As Integer _
) As Byte
Visual C++
public:
unsigned char PeekByte(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekByte(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekByte(System.Int32)"]

See Also

NetIncomingMessage Class
PeekByte Overload


PeekBytes Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekBytes Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PeekBytes(Int32) | Reads the specified number of bytes without advancing the read pointer
Public method | PeekBytes(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes without advancing the read pointer

See Also

NetIncomingMessage Class
NetIncomingMessage Members


PeekBytes Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekBytes Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bytes without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public byte[] PeekBytes(
    int numberOfBytes
)
Visual Basic
Public Function PeekBytes ( _
    numberOfBytes As Integer _
) As Byte()
Visual C++
public:
array<unsigned char>^ PeekBytes(
    int numberOfBytes
)

Parameters

numberOfBytes
Type: System..::..Int32

[Missing <param name="numberOfBytes"/> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekBytes(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekBytes(System.Int32)"]

See Also

NetIncomingMessage Class
PeekBytes Overload


PeekBytes Method (Byte[], Int32, Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekBytes Method (array<Byte>[]()[][], Int32, Int32)
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bytes without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void PeekBytes(
    byte[] into,
    int offset,
    int numberOfBytes
)
Visual Basic
Public Sub PeekBytes ( _
    into As Byte(), _
    offset As Integer, _
    numberOfBytes As Integer _
)
Visual C++
public:
void PeekBytes(
    array<unsigned char>^ into,
    int offset,
    int numberOfBytes
)

Parameters

into
Type: array< System..::..Byte >[]()[][]

[Missing <param name="into"/> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekBytes(System.Byte[],System.Int32,System.Int32)"]

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekBytes(System.Byte[],System.Int32,System.Int32)"]

numberOfBytes
Type: System..::..Int32

[Missing <param name="numberOfBytes"/> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekBytes(System.Byte[],System.Int32,System.Int32)"]

See Also

NetIncomingMessage Class
PeekBytes Overload


PeekDataBuffer Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekDataBuffer Method
NetIncomingMessage Class See Also Send Feedback
Returns the internal data buffer, don't modify

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public byte[] PeekDataBuffer()
Visual Basic
Public Function PeekDataBuffer As Byte()
Visual C++
public:
array<unsigned char>^ PeekDataBuffer()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekDataBuffer"]

See Also

NetIncomingMessage Class


PeekDouble Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekDouble Method
NetIncomingMessage Class See Also Send Feedback
Reads a 64-bit Double without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public double PeekDouble()
Visual Basic
Public Function PeekDouble As Double
Visual C++
public:
double PeekDouble()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekDouble"]

See Also

NetIncomingMessage Class


PeekFloat Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekFloat Method
NetIncomingMessage Class See Also Send Feedback
Reads a 32-bit Single without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float PeekFloat()
Visual Basic
Public Function PeekFloat As Single
Visual C++
public:
float PeekFloat()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekFloat"]

See Also

NetIncomingMessage Class


PeekInt16 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekInt16 Method
NetIncomingMessage Class See Also Send Feedback
Reads an Int16 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public short PeekInt16()
Visual Basic
Public Function PeekInt16 As Short
Visual C++
public:
short PeekInt16()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekInt16"]

See Also

NetIncomingMessage Class


PeekInt32 Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekInt32 Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PeekInt32()()()() | Reads an Int32 without advancing the read pointer
Public method | PeekInt32(Int32) | Reads the specified number of bits into an Int32 without advancing the read pointer

See Also

NetIncomingMessage Class
NetIncomingMessage Members


PeekInt32 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekInt32 Method
NetIncomingMessage Class See Also Send Feedback
Reads an Int32 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int PeekInt32()
Visual Basic
Public Function PeekInt32 As Integer
Visual C++
public:
int PeekInt32()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekInt32"]

See Also

NetIncomingMessage Class
PeekInt32 Overload


PeekInt32 Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekInt32 Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bits into an Int32 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int PeekInt32(
    int numberOfBits
)
Visual Basic
Public Function PeekInt32 ( _
    numberOfBits As Integer _
) As Integer
Visual C++
public:
int PeekInt32(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekInt32(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekInt32(System.Int32)"]

See Also

NetIncomingMessage Class
PeekInt32 Overload


PeekInt64 Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekInt64 Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PeekInt64()()()() | Reads an Int64 without advancing the read pointer
Public method | PeekInt64(Int32) | Reads the specified number of bits into an Int64 without advancing the read pointer

See Also

NetIncomingMessage Class
NetIncomingMessage Members


PeekInt64 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekInt64 Method
NetIncomingMessage Class See Also Send Feedback
Reads an Int64 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public long PeekInt64()
Visual Basic
Public Function PeekInt64 As Long
Visual C++
public:
long long PeekInt64()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekInt64"]

See Also

NetIncomingMessage Class
PeekInt64 Overload


PeekInt64 Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekInt64 Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bits into an Int64 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public long PeekInt64(
    int numberOfBits
)
Visual Basic
Public Function PeekInt64 ( _
    numberOfBits As Integer _
) As Long
Visual C++
public:
long long PeekInt64(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekInt64(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekInt64(System.Int32)"]

See Also

NetIncomingMessage Class
PeekInt64 Overload


PeekSByte Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekSByte Method
NetIncomingMessage Class See Also Send Feedback
Reads an SByte without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public sbyte PeekSByte()
Visual Basic
Public Function PeekSByte As SByte
Visual C++
public:
signed char PeekSByte()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekSByte"]

See Also

NetIncomingMessage Class


PeekSingle Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekSingle Method
NetIncomingMessage Class See Also Send Feedback
Reads a 32-bit Single without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float PeekSingle()
Visual Basic
Public Function PeekSingle As Single
Visual C++
public:
float PeekSingle()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekSingle"]

See Also

NetIncomingMessage Class


PeekString Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekString Method
NetIncomingMessage Class See Also Send Feedback
Reads a string without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public string PeekString()
Visual Basic
Public Function PeekString As String
Visual C++
public:
String^ PeekString()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekString"]

See Also

NetIncomingMessage Class


PeekUInt16 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekUInt16 Method
NetIncomingMessage Class See Also Send Feedback
Reads a UInt16 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public ushort PeekUInt16()
Visual Basic
Public Function PeekUInt16 As UShort
Visual C++
public:
unsigned short PeekUInt16()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekUInt16"]

See Also

NetIncomingMessage Class


PeekUInt32 Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekUInt32 Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PeekUInt32()()()() | Reads a UInt32 without advancing the read pointer
Public method | PeekUInt32(Int32) | Reads the specified number of bits into a UInt32 without advancing the read pointer

See Also

NetIncomingMessage Class
NetIncomingMessage Members


PeekUInt32 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekUInt32 Method
NetIncomingMessage Class See Also Send Feedback
Reads a UInt32 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public uint PeekUInt32()
Visual Basic
Public Function PeekUInt32 As UInteger
Visual C++
public:
unsigned int PeekUInt32()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekUInt32"]

See Also

NetIncomingMessage Class
PeekUInt32 Overload


PeekUInt32 Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekUInt32 Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bits into a UInt32 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public uint PeekUInt32(
    int numberOfBits
)
Visual Basic
Public Function PeekUInt32 ( _
    numberOfBits As Integer _
) As UInteger
Visual C++
public:
unsigned int PeekUInt32(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekUInt32(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekUInt32(System.Int32)"]

See Also

NetIncomingMessage Class
PeekUInt32 Overload


PeekUInt64 Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekUInt64 Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PeekUInt64()()()() | Reads a UInt64 without advancing the read pointer
Public method | PeekUInt64(Int32) | Reads the specified number of bits into an UInt64 without advancing the read pointer

See Also

NetIncomingMessage Class
NetIncomingMessage Members


PeekUInt64 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekUInt64 Method
NetIncomingMessage Class See Also Send Feedback
Reads a UInt64 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public ulong PeekUInt64()
Visual Basic
Public Function PeekUInt64 As ULong
Visual C++
public:
unsigned long long PeekUInt64()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekUInt64"]

See Also

NetIncomingMessage Class
PeekUInt64 Overload


PeekUInt64 Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PeekUInt64 Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bits into an UInt64 without advancing the read pointer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public ulong PeekUInt64(
    int numberOfBits
)
Visual Basic
Public Function PeekUInt64 ( _
    numberOfBits As Integer _
) As ULong
Visual C++
public:
unsigned long long PeekUInt64(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekUInt64(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.PeekUInt64(System.Int32)"]

See Also

NetIncomingMessage Class
PeekUInt64 Overload


ReadAllFields Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadAllFields Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadAllFields(Object) | Reads all public and private declared instance fields of the object in alphabetical order using reflection
Public method | ReadAllFields(Object, BindingFlags) | Reads all fields with the specified binding of the object in alphabetical order using reflection

See Also

NetIncomingMessage Class
NetIncomingMessage Members


ReadAllFields Method (Object)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadAllFields Method (Object)
NetIncomingMessage Class See Also Send Feedback
Reads all public and private declared instance fields of the object in alphabetical order using reflection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void ReadAllFields(
    Object target
)
Visual Basic
Public Sub ReadAllFields ( _
    target As Object _
)
Visual C++
public:
void ReadAllFields(
    Object^ target
)

Parameters

target
Type: System..::..Object

[Missing <param name="target"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadAllFields(System.Object)"]

See Also

NetIncomingMessage Class
ReadAllFields Overload


ReadAllFields Method (Object, BindingFlags)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadAllFields Method (Object, BindingFlags)
NetIncomingMessage Class See Also Send Feedback
Reads all fields with the specified binding of the object in alphabetical order using reflection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void ReadAllFields(
    Object target,
    BindingFlags flags
)
Visual Basic
Public Sub ReadAllFields ( _
    target As Object, _
    flags As BindingFlags _
)
Visual C++
public:
void ReadAllFields(
    Object^ target,
    BindingFlags flags
)

Parameters

target
Type: System..::..Object

[Missing <param name="target"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadAllFields(System.Object,System.Reflection.BindingFlags)"]

flags
Type: System.Reflection..::..BindingFlags

[Missing <param name="flags"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadAllFields(System.Object,System.Reflection.BindingFlags)"]

See Also

NetIncomingMessage Class
ReadAllFields Overload


ReadAllProperties Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadAllProperties Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadAllProperties(Object) | Reads all public and private declared instance fields of the object in alphabetical order using reflection
Public method | ReadAllProperties(Object, BindingFlags) | Reads all fields with the specified binding of the object in alphabetical order using reflection

See Also

NetIncomingMessage Class
NetIncomingMessage Members


ReadAllProperties Method (Object)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadAllProperties Method (Object)
NetIncomingMessage Class See Also Send Feedback
Reads all public and private declared instance fields of the object in alphabetical order using reflection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void ReadAllProperties(
    Object target
)
Visual Basic
Public Sub ReadAllProperties ( _
    target As Object _
)
Visual C++
public:
void ReadAllProperties(
    Object^ target
)

Parameters

target
Type: System..::..Object

[Missing <param name="target"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadAllProperties(System.Object)"]

See Also

NetIncomingMessage Class
ReadAllProperties Overload


ReadAllProperties Method (Object, BindingFlags)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadAllProperties Method (Object, BindingFlags)
NetIncomingMessage Class See Also Send Feedback
Reads all fields with the specified binding of the object in alphabetical order using reflection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void ReadAllProperties(
    Object target,
    BindingFlags flags
)
Visual Basic
Public Sub ReadAllProperties ( _
    target As Object, _
    flags As BindingFlags _
)
Visual C++
public:
void ReadAllProperties(
    Object^ target,
    BindingFlags flags
)

Parameters

target
Type: System..::..Object

[Missing <param name="target"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadAllProperties(System.Object,System.Reflection.BindingFlags)"]

flags
Type: System.Reflection..::..BindingFlags

[Missing <param name="flags"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadAllProperties(System.Object,System.Reflection.BindingFlags)"]

See Also

NetIncomingMessage Class
ReadAllProperties Overload


ReadBits Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadBits Method
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bits into a preallocated array

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void ReadBits(
    byte[] into,
    int offset,
    int numberOfBits
)
Visual Basic
Public Sub ReadBits ( _
    into As Byte(), _
    offset As Integer, _
    numberOfBits As Integer _
)
Visual C++
public:
void ReadBits(
    array<unsigned char>^ into,
    int offset,
    int numberOfBits
)

Parameters

into
Type: array< System..::..Byte >[]()[][]
The destination array
offset
Type: System..::..Int32
The offset where to start writing in the destination array
numberOfBits
Type: System..::..Int32
The number of bits to read

See Also

NetIncomingMessage Class


ReadBoolean Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadBoolean Method
NetIncomingMessage Class See Also Send Feedback
Reads a boolean value (stored as a single bit) written using Write(bool)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool ReadBoolean()
Visual Basic
Public Function ReadBoolean As Boolean
Visual C++
public:
bool ReadBoolean()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadBoolean"]

See Also

NetIncomingMessage Class


ReadByte Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadByte Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadByte()()()() | Reads a byte
Public method | ReadByte(Int32) | Reads 1 to 8 bits into a byte

See Also

NetIncomingMessage Class
NetIncomingMessage Members


ReadByte Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadByte Method
NetIncomingMessage Class See Also Send Feedback
Reads a byte

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public byte ReadByte()
Visual Basic
Public Function ReadByte As Byte
Visual C++
public:
unsigned char ReadByte()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadByte"]

See Also

NetIncomingMessage Class
ReadByte Overload


ReadByte Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadByte Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads 1 to 8 bits into a byte

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public byte ReadByte(
    int numberOfBits
)
Visual Basic
Public Function ReadByte ( _
    numberOfBits As Integer _
) As Byte
Visual C++
public:
unsigned char ReadByte(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadByte(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadByte(System.Int32)"]

See Also

NetIncomingMessage Class
ReadByte Overload


ReadBytes Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadBytes Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadBytes(Int32) | Reads the specified number of bytes
Public method | ReadBytes(array<Byte>[]()[][], Int32, Int32) | Reads the specified number of bytes into a preallocated array

See Also

NetIncomingMessage Class
NetIncomingMessage Members


ReadBytes Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadBytes Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bytes

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public byte[] ReadBytes(
    int numberOfBytes
)
Visual Basic
Public Function ReadBytes ( _
    numberOfBytes As Integer _
) As Byte()
Visual C++
public:
array<unsigned char>^ ReadBytes(
    int numberOfBytes
)

Parameters

numberOfBytes
Type: System..::..Int32

[Missing <param name="numberOfBytes"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadBytes(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadBytes(System.Int32)"]

See Also

NetIncomingMessage Class
ReadBytes Overload


ReadBytes Method (Byte[], Int32, Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadBytes Method (array<Byte>[]()[][], Int32, Int32)
NetIncomingMessage Class See Also Send Feedback
Reads the specified number of bytes into a preallocated array

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void ReadBytes(
    byte[] into,
    int offset,
    int numberOfBytes
)
Visual Basic
Public Sub ReadBytes ( _
    into As Byte(), _
    offset As Integer, _
    numberOfBytes As Integer _
)
Visual C++
public:
void ReadBytes(
    array<unsigned char>^ into,
    int offset,
    int numberOfBytes
)

Parameters

into
Type: array< System..::..Byte >[]()[][]
The destination array
offset
Type: System..::..Int32
The offset where to start writing in the destination array
numberOfBytes
Type: System..::..Int32
The number of bytes to read

See Also

NetIncomingMessage Class
ReadBytes Overload


ReadDouble Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadDouble Method
NetIncomingMessage Class See Also Send Feedback
Reads a 64 bit floating point value written using Write(Double)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public double ReadDouble()
Visual Basic
Public Function ReadDouble As Double
Visual C++
public:
double ReadDouble()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadDouble"]

See Also

NetIncomingMessage Class


ReadFloat Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadFloat Method
NetIncomingMessage Class See Also Send Feedback
Reads a 32 bit floating point value written using Write(Single)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float ReadFloat()
Visual Basic
Public Function ReadFloat As Single
Visual C++
public:
float ReadFloat()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadFloat"]

See Also

NetIncomingMessage Class


ReadInt16 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadInt16 Method
NetIncomingMessage Class See Also Send Feedback
Reads a 16 bit signed integer written using Write(Int16)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public short ReadInt16()
Visual Basic
Public Function ReadInt16 As Short
Visual C++
public:
short ReadInt16()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadInt16"]

See Also

NetIncomingMessage Class


ReadInt32 Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadInt32 Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadInt32()()()() | Reads a 32 bit signed integer written using Write(Int32)
Public method | ReadInt32(Int32) | Reads a signed integer stored in 1 to 32 bits, written using Write(Int32, Int32)

See Also

NetIncomingMessage Class
NetIncomingMessage Members


ReadInt32 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadInt32 Method
NetIncomingMessage Class See Also Send Feedback
Reads a 32 bit signed integer written using Write(Int32)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReadInt32()
Visual Basic
Public Function ReadInt32 As Integer
Visual C++
public:
int ReadInt32()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadInt32"]

See Also

NetIncomingMessage Class
ReadInt32 Overload


ReadInt32 Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadInt32 Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads a signed integer stored in 1 to 32 bits, written using Write(Int32, Int32)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReadInt32(
    int numberOfBits
)
Visual Basic
Public Function ReadInt32 ( _
    numberOfBits As Integer _
) As Integer
Visual C++
public:
int ReadInt32(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadInt32(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadInt32(System.Int32)"]

See Also

NetIncomingMessage Class
ReadInt32 Overload


ReadInt64 Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadInt64 Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadInt64()()()() | Reads a 64 bit signed integer written using Write(Int64)
Public method | ReadInt64(Int32) | Reads a signed integer stored in 1 to 64 bits, written using Write(Int64, Int32)

See Also

NetIncomingMessage Class
NetIncomingMessage Members


ReadInt64 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadInt64 Method
NetIncomingMessage Class See Also Send Feedback
Reads a 64 bit signed integer written using Write(Int64)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public long ReadInt64()
Visual Basic
Public Function ReadInt64 As Long
Visual C++
public:
long long ReadInt64()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadInt64"]

See Also

NetIncomingMessage Class
ReadInt64 Overload


ReadInt64 Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadInt64 Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads a signed integer stored in 1 to 64 bits, written using Write(Int64, Int32)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public long ReadInt64(
    int numberOfBits
)
Visual Basic
Public Function ReadInt64 ( _
    numberOfBits As Integer _
) As Long
Visual C++
public:
long long ReadInt64(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadInt64(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadInt64(System.Int32)"]

See Also

NetIncomingMessage Class
ReadInt64 Overload


ReadIPEndpoint Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadIPEndpoint Method
NetIncomingMessage Class See Also Send Feedback
Reads a stored IPv4 endpoint description

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public IPEndPoint ReadIPEndpoint()
Visual Basic
Public Function ReadIPEndpoint As IPEndPoint
Visual C++
public:
IPEndPoint^ ReadIPEndpoint()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadIPEndpoint"]

See Also

NetIncomingMessage Class


ReadPadBits Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadPadBits Method
NetIncomingMessage Class See Also Send Feedback
Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void ReadPadBits()
Visual Basic
Public Sub ReadPadBits
Visual C++
public:
void ReadPadBits()

See Also

NetIncomingMessage Class


ReadRangedInteger Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadRangedInteger Method
NetIncomingMessage Class See Also Send Feedback
Reads a 32 bit integer value written using WriteRangedInteger()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReadRangedInteger(
    int min,
    int max
)
Visual Basic
Public Function ReadRangedInteger ( _
    min As Integer, _
    max As Integer _
) As Integer
Visual C++
public:
int ReadRangedInteger(
    int min,
    int max
)

Parameters

min
Type: System..::..Int32
The minimum value used when writing the value
max
Type: System..::..Int32
The maximum value used when writing the value

Return Value

A signed integer value larger or equal to MIN and smaller or equal to MAX

See Also

NetIncomingMessage Class


ReadRangedSingle Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadRangedSingle Method
NetIncomingMessage Class See Also Send Feedback
Reads a 32 bit floating point value written using WriteRangedSingle()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float ReadRangedSingle(
    float min,
    float max,
    int numberOfBits
)
Visual Basic
Public Function ReadRangedSingle ( _
    min As Single, _
    max As Single, _
    numberOfBits As Integer _
) As Single
Visual C++
public:
float ReadRangedSingle(
    float min,
    float max,
    int numberOfBits
)

Parameters

min
Type: System..::..Single
The minimum value used when writing the value
max
Type: System..::..Single
The maximum value used when writing the value
numberOfBits
Type: System..::..Int32
The number of bits used when writing the value

Return Value

A floating point value larger or equal to MIN and smaller or equal to MAX

See Also

NetIncomingMessage Class


ReadSByte Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadSByte Method
NetIncomingMessage Class See Also Send Feedback
Reads a signed byte

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public sbyte ReadSByte()
Visual Basic
Public Function ReadSByte As SByte
Visual C++
public:
signed char ReadSByte()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadSByte"]

See Also

NetIncomingMessage Class


ReadSignedSingle Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadSignedSingle Method
NetIncomingMessage Class See Also Send Feedback
Reads a 32 bit floating point value written using WriteSignedSingle()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float ReadSignedSingle(
    int numberOfBits
)
Visual Basic
Public Function ReadSignedSingle ( _
    numberOfBits As Integer _
) As Single
Visual C++
public:
float ReadSignedSingle(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32
The number of bits used when writing the value

Return Value

A floating point value larger or equal to -1 and smaller or equal to 1

See Also

NetIncomingMessage Class


ReadSingle Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadSingle Method
NetIncomingMessage Class See Also Send Feedback
Reads a 32 bit floating point value written using Write(Single)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float ReadSingle()
Visual Basic
Public Function ReadSingle As Single
Visual C++
public:
float ReadSingle()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadSingle"]

See Also

NetIncomingMessage Class


ReadString Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadString Method
NetIncomingMessage Class See Also Send Feedback
Reads a string written using Write(string)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public string ReadString()
Visual Basic
Public Function ReadString As String
Visual C++
public:
String^ ReadString()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadString"]

See Also

NetIncomingMessage Class


ReadTime Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadTime Method
NetIncomingMessage Class See Also Send Feedback
Reads a value, in local time comparable to NetTime.Now, written using WriteTime() Must have a connected sender

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public double ReadTime(
    bool highPrecision
)
Visual Basic
Public Function ReadTime ( _
    highPrecision As Boolean _
) As Double
Visual C++
public:
double ReadTime(
    bool highPrecision
)

Parameters

highPrecision
Type: System..::..Boolean

[Missing <param name="highPrecision"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadTime(System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadTime(System.Boolean)"]

See Also

NetIncomingMessage Class


ReadUInt16 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadUInt16 Method
NetIncomingMessage Class See Also Send Feedback
Reads a 16 bit unsigned integer written using Write(UInt16)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public ushort ReadUInt16()
Visual Basic
Public Function ReadUInt16 As UShort
Visual C++
public:
unsigned short ReadUInt16()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadUInt16"]

See Also

NetIncomingMessage Class


ReadUInt32 Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadUInt32 Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadUInt32()()()() | Reads an 32 bit unsigned integer written using Write(UInt32)
Public method | ReadUInt32(Int32) | Reads an unsigned integer stored in 1 to 32 bits, written using Write(UInt32, Int32)

See Also

NetIncomingMessage Class
NetIncomingMessage Members


ReadUInt32 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadUInt32 Method
NetIncomingMessage Class See Also Send Feedback
Reads an 32 bit unsigned integer written using Write(UInt32)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public uint ReadUInt32()
Visual Basic
Public Function ReadUInt32 As UInteger
Visual C++
public:
unsigned int ReadUInt32()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadUInt32"]

See Also

NetIncomingMessage Class
ReadUInt32 Overload


ReadUInt32 Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadUInt32 Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads an unsigned integer stored in 1 to 32 bits, written using Write(UInt32, Int32)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public uint ReadUInt32(
    int numberOfBits
)
Visual Basic
Public Function ReadUInt32 ( _
    numberOfBits As Integer _
) As UInteger
Visual C++
public:
unsigned int ReadUInt32(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadUInt32(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadUInt32(System.Int32)"]

See Also

NetIncomingMessage Class
ReadUInt32 Overload


ReadUInt64 Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadUInt64 Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReadUInt64()()()() | Reads a 64 bit unsigned integer written using Write(UInt64)
Public method | ReadUInt64(Int32) | Reads an unsigned integer stored in 1 to 64 bits, written using Write(UInt64, Int32)

See Also

NetIncomingMessage Class
NetIncomingMessage Members


ReadUInt64 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadUInt64 Method
NetIncomingMessage Class See Also Send Feedback
Reads a 64 bit unsigned integer written using Write(UInt64)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public ulong ReadUInt64()
Visual Basic
Public Function ReadUInt64 As ULong
Visual C++
public:
unsigned long long ReadUInt64()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadUInt64"]

See Also

NetIncomingMessage Class
ReadUInt64 Overload


ReadUInt64 Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadUInt64 Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Reads an unsigned integer stored in 1 to 64 bits, written using Write(UInt64, Int32)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public ulong ReadUInt64(
    int numberOfBits
)
Visual Basic
Public Function ReadUInt64 ( _
    numberOfBits As Integer _
) As ULong
Visual C++
public:
unsigned long long ReadUInt64(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadUInt64(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadUInt64(System.Int32)"]

See Also

NetIncomingMessage Class
ReadUInt64 Overload


ReadUnitSingle Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadUnitSingle Method
NetIncomingMessage Class See Also Send Feedback
Reads a 32 bit floating point value written using WriteUnitSingle()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float ReadUnitSingle(
    int numberOfBits
)
Visual Basic
Public Function ReadUnitSingle ( _
    numberOfBits As Integer _
) As Single
Visual C++
public:
float ReadUnitSingle(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32
The number of bits used when writing the value

Return Value

A floating point value larger or equal to 0 and smaller or equal to 1

See Also

NetIncomingMessage Class


ReadVariableInt32 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadVariableInt32 Method
NetIncomingMessage Class See Also Send Feedback
Reads a variable sized Int32 written using WriteVariableInt32()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReadVariableInt32()
Visual Basic
Public Function ReadVariableInt32 As Integer
Visual C++
public:
int ReadVariableInt32()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadVariableInt32"]

See Also

NetIncomingMessage Class


ReadVariableInt64 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadVariableInt64 Method
NetIncomingMessage Class See Also Send Feedback
Reads a variable sized Int64 written using WriteVariableInt64()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public long ReadVariableInt64()
Visual Basic
Public Function ReadVariableInt64 As Long
Visual C++
public:
long long ReadVariableInt64()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadVariableInt64"]

See Also

NetIncomingMessage Class


ReadVariableUInt32 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadVariableUInt32 Method
NetIncomingMessage Class See Also Send Feedback
Reads a variable sized UInt32 written using WriteVariableUInt32()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public uint ReadVariableUInt32()
Visual Basic
Public Function ReadVariableUInt32 As UInteger
Visual C++
public:
unsigned int ReadVariableUInt32()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadVariableUInt32"]

See Also

NetIncomingMessage Class


ReadVariableUInt64 Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReadVariableUInt64 Method
NetIncomingMessage Class See Also Send Feedback
Reads a variable sized UInt32 written using WriteVariableInt64()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public ulong ReadVariableUInt64()
Visual Basic
Public Function ReadVariableUInt64 As ULong
Visual C++
public:
unsigned long long ReadVariableUInt64()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ReadVariableUInt64"]

See Also

NetIncomingMessage Class


SkipPadBits Method

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage..::..SkipPadBits Method
NetIncomingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SkipPadBits()()()() | Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.
Public method | SkipPadBits(Int32) | Pads data with the specified number of bits.

See Also

NetIncomingMessage Class
NetIncomingMessage Members


SkipPadBits Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..SkipPadBits Method
NetIncomingMessage Class See Also Send Feedback
Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SkipPadBits()
Visual Basic
Public Sub SkipPadBits
Visual C++
public:
void SkipPadBits()

See Also

NetIncomingMessage Class
SkipPadBits Overload


SkipPadBits Method (Int32)

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..SkipPadBits Method (Int32)
NetIncomingMessage Class See Also Send Feedback
Pads data with the specified number of bits.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SkipPadBits(
    int numberOfBits
)
Visual Basic
Public Sub SkipPadBits ( _
    numberOfBits As Integer _
)
Visual C++
public:
void SkipPadBits(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetIncomingMessage.SkipPadBits(System.Int32)"]

See Also

NetIncomingMessage Class
SkipPadBits Overload


ToString Method

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ToString Method
NetIncomingMessage Class See Also Send Feedback
Returns a string that represents this object

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetIncomingMessage.ToString"]

See Also

NetIncomingMessage Class


NetIncomingMessage Properties

[image] [image]

Lidgren Network Library documentation
NetIncomingMessage Properties
NetIncomingMessage Class See Also Send Feedback

The NetIncomingMessage type exposes the following members.

Properties

 | Name | Description
Public property | DeliveryMethod | Gets the delivery method this message was sent with (if user data)
Public property | LengthBits | Gets the length of the message payload in bits
Public property | LengthBytes | Gets the length of the message payload in bytes
Public property | MessageType | Gets the type of this incoming message
Public property | Position | Gets or sets the read position in the buffer, in bits (not bytes)
Public property | PositionInBytes | Gets the position in the buffer in bytes; note that the bits of the first returned byte may already have been read - check the Position property to make sure.
Public property | ReceiveTime | What local time the message was received from the network
Public property | SenderConnection | NetConnection of sender, if any
Public property | SenderEndpoint | IPEndPoint of sender, if any
Public property | SequenceChannel | Gets the sequence channel this message was sent with (if user data)

See Also

NetIncomingMessage Class


DeliveryMethod Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..DeliveryMethod Property
NetIncomingMessage Class See Also Send Feedback
Gets the delivery method this message was sent with (if user data)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetDeliveryMethod DeliveryMethod { get; }
Visual Basic
Public ReadOnly Property DeliveryMethod As NetDeliveryMethod
    Get
Visual C++
public:
property NetDeliveryMethod DeliveryMethod {
    NetDeliveryMethod get ();
}

See Also

NetIncomingMessage Class


LengthBits Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..LengthBits Property
NetIncomingMessage Class See Also Send Feedback
Gets the length of the message payload in bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int LengthBits { get; internal set; }
Visual Basic
Public Property LengthBits As Integer
    Get
    Friend Set
Visual C++
public:
property int LengthBits {
    int get ();
    internal: void set (int value);
}

See Also

NetIncomingMessage Class


LengthBytes Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..LengthBytes Property
NetIncomingMessage Class See Also Send Feedback
Gets the length of the message payload in bytes

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int LengthBytes { get; }
Visual Basic
Public ReadOnly Property LengthBytes As Integer
    Get
Visual C++
public:
property int LengthBytes {
    int get ();
}

See Also

NetIncomingMessage Class


MessageType Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..MessageType Property
NetIncomingMessage Class See Also Send Feedback
Gets the type of this incoming message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetIncomingMessageType MessageType { get; }
Visual Basic
Public ReadOnly Property MessageType As NetIncomingMessageType
    Get
Visual C++
public:
property NetIncomingMessageType MessageType {
    NetIncomingMessageType get ();
}

See Also

NetIncomingMessage Class


Position Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..Position Property
NetIncomingMessage Class See Also Send Feedback
Gets or sets the read position in the buffer, in bits (not bytes)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public long Position { get; set; }
Visual Basic
Public Property Position As Long
    Get
    Set
Visual C++
public:
property long long Position {
    long long get ();
    void set (long long value);
}

See Also

NetIncomingMessage Class


PositionInBytes Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..PositionInBytes Property
NetIncomingMessage Class See Also Send Feedback
Gets the position in the buffer in bytes; note that the bits of the first returned byte may already have been read - check the Position property to make sure.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int PositionInBytes { get; }
Visual Basic
Public ReadOnly Property PositionInBytes As Integer
    Get
Visual C++
public:
property int PositionInBytes {
    int get ();
}

See Also

NetIncomingMessage Class


ReceiveTime Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..ReceiveTime Property
NetIncomingMessage Class See Also Send Feedback
What local time the message was received from the network

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public double ReceiveTime { get; }
Visual Basic
Public ReadOnly Property ReceiveTime As Double
    Get
Visual C++
public:
property double ReceiveTime {
    double get ();
}

See Also

NetIncomingMessage Class


SenderConnection Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..SenderConnection Property
NetIncomingMessage Class See Also Send Feedback
NetConnection of sender, if any

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetConnection SenderConnection { get; }
Visual Basic
Public ReadOnly Property SenderConnection As NetConnection
    Get
Visual C++
public:
property NetConnection^ SenderConnection {
    NetConnection^ get ();
}

See Also

NetIncomingMessage Class


SenderEndpoint Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..SenderEndpoint Property
NetIncomingMessage Class See Also Send Feedback
IPEndPoint of sender, if any

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public IPEndPoint SenderEndpoint { get; }
Visual Basic
Public ReadOnly Property SenderEndpoint As IPEndPoint
    Get
Visual C++
public:
property IPEndPoint^ SenderEndpoint {
    IPEndPoint^ get ();
}

See Also

NetIncomingMessage Class


SequenceChannel Property

[image]

Lidgren Network Library documentation
NetIncomingMessage..::..SequenceChannel Property
NetIncomingMessage Class See Also Send Feedback
Gets the sequence channel this message was sent with (if user data)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int SequenceChannel { get; }
Visual Basic
Public ReadOnly Property SequenceChannel As Integer
    Get
Visual C++
public:
property int SequenceChannel {
    int get ();
}

See Also

NetIncomingMessage Class


NetIncomingMessageType Enumeration

[image]

Lidgren Network Library documentation
NetIncomingMessageType Enumeration
See Also Send Feedback
The type of a NetIncomingMessage

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public enum NetIncomingMessageType
Visual Basic
Public Enumeration NetIncomingMessageType
Visual C++
public enum class NetIncomingMessageType

Members

Member name | Description
Error |
StatusChanged |
UnconnectedData |
ConnectionApproval |
Data |
Receipt |
DiscoveryRequest |
DiscoveryResponse |
VerboseDebugMessage |
DebugMessage |
WarningMessage |
ErrorMessage |
NatIntroductionSuccess |
ConnectionLatencyUpdated |

See Also

Lidgren.Network Namespace


NetOutgoingMessage Class

[image]

Lidgren Network Library documentation
NetOutgoingMessage Class
Members See Also Send Feedback
Outgoing message used to send data to remote peer(s)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public sealed class NetOutgoingMessage
Visual Basic
Public NotInheritable Class NetOutgoingMessage
Visual C++
public ref class NetOutgoingMessage sealed

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetOutgoingMessage

See Also

NetOutgoingMessage Members


NetOutgoingMessage Members

[image] [image]

Lidgren Network Library documentation
NetOutgoingMessage Members
NetOutgoingMessage Class Methods Properties See Also Send Feedback

The NetOutgoingMessage type exposes the following members.

Methods

 | Name | Description
Public method | Encrypt | Encrypt this message using the provided algorithm; no more writing can be done before sending it or the message will be corrupt!
Public method | EnsureBufferSize | Ensures the buffer can hold this number of bits
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InternalEnsureBufferSize | Ensures the buffer can hold this number of bits
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekDataBuffer | Returns the internal data buffer, don't modify
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)
Public method | Write(Boolean) | Writes a boolean value using 1 bit
Public method | Write(Byte) | Write a byte
Public method | Write(array<Byte>[]()[][]) | Writes all bytes in an array
Public method | Write(Double) | Writes a 64 bit floating point value
Public method | Write(Int16) | Writes a signed 16 bit integer
Public method | Write(Int32) | Writes a 32 bit signed integer
Public method | Write(Int64) | Writes a 64 bit signed integer
Public method | Write(IPEndPoint) | Writes an endpoint description
Public method | Write(SByte) | Writes a signed byte
Public method | Write(Single) | Writes a 32 bit floating point value
Public method | Write(String) | Write a string
Public method | Write(UInt16) | Writes an unsigned 16 bit integer
Public method | Write(UInt32) | Writes a 32 bit unsigned integer
Public method | Write(UInt64) | Writes a 64 bit unsigned integer
Public method | Write(NetIncomingMessage) | Append all the bits of message to this message
Public method | Write(NetOutgoingMessage) | Append all the bits of message to this message
Public method | Write(Byte, Int32) | Writes 1 to 8 bits of a byte
Public method | Write(Int32, Int32) | Writes a signed integer using 1 to 32 bits
Public method | Write(Int64, Int32) | Writes a signed integer using 1 to 64 bits
Public method | Write(UInt16, Int32) | Writes an unsigned integer using 1 to 16 bits
Public method | Write(UInt32, Int32) | Writes a 32 bit signed integer
Public method | Write(UInt64, Int32) | Writes an unsigned integer using 1 to 64 bits
Public method | Write(array<Byte>[]()[][], Int32, Int32) | Writes the specified number of bytes from an array
Public method | WriteAllFields(Object) | Writes all public and private declared instance fields of the object in alphabetical order using reflection
Public method | WriteAllFields(Object, BindingFlags) | Writes all fields with specified binding in alphabetical order using reflection
Public method | WriteAllProperties(Object) | Writes all public and private declared instance properties of the object in alphabetical order using reflection
Public method | WriteAllProperties(Object, BindingFlags) | Writes all properties with specified binding in alphabetical order using reflection
Public method | WritePadBits()()()() | Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.
Public method | WritePadBits(Int32) | Pads data with the specified number of bits.
Public method | WriteRangedInteger | Writes an integer with the least amount of bits need for the specified range Returns number of bits written
Public method | WriteRangedSingle | Compress a float within a specified range using a certain number of bits
Public method | WriteSignedSingle | Compress (lossy) a float in the range -1..1 using numberOfBits bits
Public method | WriteTime | Writes the local time to a message; readable (and convertable to local time) by the remote host using ReadTime()
Public method | WriteUnitSingle | Compress (lossy) a float in the range 0..1 using numberOfBits bits
Public method | WriteVariableInt32 | Write Base128 encoded variable sized signed integer of up to 32 bits
Public method | WriteVariableInt64 | Write Base128 encoded variable sized signed integer of up to 64 bits
Public method | WriteVariableUInt32 | Write Base128 encoded variable sized unsigned integer of up to 32 bits
Public method | WriteVariableUInt64 | Write Base128 encoded variable sized unsigned integer of up to 64 bits

Properties

 | Name | Description
Public property | LengthBits | Gets or sets the length of the buffer in bits
Public property | LengthBytes | Gets or sets the length of the buffer in bytes

See Also

NetOutgoingMessage Class


NetOutgoingMessage Methods

[image] [image]

Lidgren Network Library documentation
NetOutgoingMessage Methods
NetOutgoingMessage Class See Also Send Feedback

The NetOutgoingMessage type exposes the following members.

Methods

 | Name | Description
Public method | Encrypt | Encrypt this message using the provided algorithm; no more writing can be done before sending it or the message will be corrupt!
Public method | EnsureBufferSize | Ensures the buffer can hold this number of bits
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InternalEnsureBufferSize | Ensures the buffer can hold this number of bits
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekDataBuffer | Returns the internal data buffer, don't modify
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)
Public method | Write(Boolean) | Writes a boolean value using 1 bit
Public method | Write(Byte) | Write a byte
Public method | Write(array<Byte>[]()[][]) | Writes all bytes in an array
Public method | Write(Double) | Writes a 64 bit floating point value
Public method | Write(Int16) | Writes a signed 16 bit integer
Public method | Write(Int32) | Writes a 32 bit signed integer
Public method | Write(Int64) | Writes a 64 bit signed integer
Public method | Write(IPEndPoint) | Writes an endpoint description
Public method | Write(SByte) | Writes a signed byte
Public method | Write(Single) | Writes a 32 bit floating point value
Public method | Write(String) | Write a string
Public method | Write(UInt16) | Writes an unsigned 16 bit integer
Public method | Write(UInt32) | Writes a 32 bit unsigned integer
Public method | Write(UInt64) | Writes a 64 bit unsigned integer
Public method | Write(NetIncomingMessage) | Append all the bits of message to this message
Public method | Write(NetOutgoingMessage) | Append all the bits of message to this message
Public method | Write(Byte, Int32) | Writes 1 to 8 bits of a byte
Public method | Write(Int32, Int32) | Writes a signed integer using 1 to 32 bits
Public method | Write(Int64, Int32) | Writes a signed integer using 1 to 64 bits
Public method | Write(UInt16, Int32) | Writes an unsigned integer using 1 to 16 bits
Public method | Write(UInt32, Int32) | Writes a 32 bit signed integer
Public method | Write(UInt64, Int32) | Writes an unsigned integer using 1 to 64 bits
Public method | Write(array<Byte>[]()[][], Int32, Int32) | Writes the specified number of bytes from an array
Public method | WriteAllFields(Object) | Writes all public and private declared instance fields of the object in alphabetical order using reflection
Public method | WriteAllFields(Object, BindingFlags) | Writes all fields with specified binding in alphabetical order using reflection
Public method | WriteAllProperties(Object) | Writes all public and private declared instance properties of the object in alphabetical order using reflection
Public method | WriteAllProperties(Object, BindingFlags) | Writes all properties with specified binding in alphabetical order using reflection
Public method | WritePadBits()()()() | Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.
Public method | WritePadBits(Int32) | Pads data with the specified number of bits.
Public method | WriteRangedInteger | Writes an integer with the least amount of bits need for the specified range Returns number of bits written
Public method | WriteRangedSingle | Compress a float within a specified range using a certain number of bits
Public method | WriteSignedSingle | Compress (lossy) a float in the range -1..1 using numberOfBits bits
Public method | WriteTime | Writes the local time to a message; readable (and convertable to local time) by the remote host using ReadTime()
Public method | WriteUnitSingle | Compress (lossy) a float in the range 0..1 using numberOfBits bits
Public method | WriteVariableInt32 | Write Base128 encoded variable sized signed integer of up to 32 bits
Public method | WriteVariableInt64 | Write Base128 encoded variable sized signed integer of up to 64 bits
Public method | WriteVariableUInt32 | Write Base128 encoded variable sized unsigned integer of up to 32 bits
Public method | WriteVariableUInt64 | Write Base128 encoded variable sized unsigned integer of up to 64 bits

See Also

NetOutgoingMessage Class


Encrypt Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Encrypt Method
NetOutgoingMessage Class See Also Send Feedback
Encrypt this message using the provided algorithm; no more writing can be done before sending it or the message will be corrupt!

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Encrypt(
    INetEncryption encryption
)
Visual Basic
Public Function Encrypt ( _
    encryption As INetEncryption _
) As Boolean
Visual C++
public:
bool Encrypt(
    INetEncryption^ encryption
)

Parameters

encryption
Type: Lidgren.Network..::..INetEncryption

[Missing <param name="encryption"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Encrypt(Lidgren.Network.INetEncryption)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetOutgoingMessage.Encrypt(Lidgren.Network.INetEncryption)"]

See Also

NetOutgoingMessage Class


EnsureBufferSize Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..EnsureBufferSize Method
NetOutgoingMessage Class See Also Send Feedback
Ensures the buffer can hold this number of bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void EnsureBufferSize(
    int numberOfBits
)
Visual Basic
Public Sub EnsureBufferSize ( _
    numberOfBits As Integer _
)
Visual C++
public:
void EnsureBufferSize(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.EnsureBufferSize(System.Int32)"]

See Also

NetOutgoingMessage Class


InternalEnsureBufferSize Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..InternalEnsureBufferSize Method
NetOutgoingMessage Class See Also Send Feedback
Ensures the buffer can hold this number of bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void InternalEnsureBufferSize(
    int numberOfBits
)
Visual Basic
Public Sub InternalEnsureBufferSize ( _
    numberOfBits As Integer _
)
Visual C++
public:
void InternalEnsureBufferSize(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.InternalEnsureBufferSize(System.Int32)"]

See Also

NetOutgoingMessage Class


PeekDataBuffer Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..PeekDataBuffer Method
NetOutgoingMessage Class See Also Send Feedback
Returns the internal data buffer, don't modify

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public byte[] PeekDataBuffer()
Visual Basic
Public Function PeekDataBuffer As Byte()
Visual C++
public:
array<unsigned char>^ PeekDataBuffer()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetOutgoingMessage.PeekDataBuffer"]

See Also

NetOutgoingMessage Class


ToString Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..ToString Method
NetOutgoingMessage Class See Also Send Feedback
Returns a string that represents this object

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetOutgoingMessage.ToString"]

See Also

NetOutgoingMessage Class


Write Method

[image] [image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method
NetOutgoingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Write(Boolean) | Writes a boolean value using 1 bit
Public method | Write(Byte) | Write a byte
Public method | Write(array<Byte>[]()[][]) | Writes all bytes in an array
Public method | Write(Double) | Writes a 64 bit floating point value
Public method | Write(Int16) | Writes a signed 16 bit integer
Public method | Write(Int32) | Writes a 32 bit signed integer
Public method | Write(Int64) | Writes a 64 bit signed integer
Public method | Write(IPEndPoint) | Writes an endpoint description
Public method | Write(SByte) | Writes a signed byte
Public method | Write(Single) | Writes a 32 bit floating point value
Public method | Write(String) | Write a string
Public method | Write(UInt16) | Writes an unsigned 16 bit integer
Public method | Write(UInt32) | Writes a 32 bit unsigned integer
Public method | Write(UInt64) | Writes a 64 bit unsigned integer
Public method | Write(NetIncomingMessage) | Append all the bits of message to this message
Public method | Write(NetOutgoingMessage) | Append all the bits of message to this message
Public method | Write(Byte, Int32) | Writes 1 to 8 bits of a byte
Public method | Write(Int32, Int32) | Writes a signed integer using 1 to 32 bits
Public method | Write(Int64, Int32) | Writes a signed integer using 1 to 64 bits
Public method | Write(UInt16, Int32) | Writes an unsigned integer using 1 to 16 bits
Public method | Write(UInt32, Int32) | Writes a 32 bit signed integer
Public method | Write(UInt64, Int32) | Writes an unsigned integer using 1 to 64 bits
Public method | Write(array<Byte>[]()[][], Int32, Int32) | Writes the specified number of bytes from an array

See Also

NetOutgoingMessage Class
NetOutgoingMessage Members


Write Method (Boolean)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Boolean)
NetOutgoingMessage Class See Also Send Feedback
Writes a boolean value using 1 bit

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    bool value
)
Visual Basic
Public Sub Write ( _
    value As Boolean _
)
Visual C++
public:
void Write(
    bool value
)

Parameters

value
Type: System..::..Boolean

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Boolean)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Byte)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Byte)
NetOutgoingMessage Class See Also Send Feedback
Write a byte

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    byte source
)
Visual Basic
Public Sub Write ( _
    source As Byte _
)
Visual C++
public:
void Write(
    unsigned char source
)

Parameters

source
Type: System..::..Byte

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Byte)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Byte[])

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (array<Byte>[]()[][])
NetOutgoingMessage Class See Also Send Feedback
Writes all bytes in an array

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    byte[] source
)
Visual Basic
Public Sub Write ( _
    source As Byte() _
)
Visual C++
public:
void Write(
    array<unsigned char>^ source
)

Parameters

source
Type: array< System..::..Byte >[]()[][]

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Byte[])"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Double)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Double)
NetOutgoingMessage Class See Also Send Feedback
Writes a 64 bit floating point value

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    double source
)
Visual Basic
Public Sub Write ( _
    source As Double _
)
Visual C++
public:
void Write(
    double source
)

Parameters

source
Type: System..::..Double

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Double)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Int16)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Int16)
NetOutgoingMessage Class See Also Send Feedback
Writes a signed 16 bit integer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    short source
)
Visual Basic
Public Sub Write ( _
    source As Short _
)
Visual C++
public:
void Write(
    short source
)

Parameters

source
Type: System..::..Int16

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Int16)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Int32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Int32)
NetOutgoingMessage Class See Also Send Feedback
Writes a 32 bit signed integer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    int source
)
Visual Basic
Public Sub Write ( _
    source As Integer _
)
Visual C++
public:
void Write(
    int source
)

Parameters

source
Type: System..::..Int32

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Int32)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Int64)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Int64)
NetOutgoingMessage Class See Also Send Feedback
Writes a 64 bit signed integer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    long source
)
Visual Basic
Public Sub Write ( _
    source As Long _
)
Visual C++
public:
void Write(
    long long source
)

Parameters

source
Type: System..::..Int64

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Int64)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (IPEndPoint)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (IPEndPoint)
NetOutgoingMessage Class See Also Send Feedback
Writes an endpoint description

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    IPEndPoint endPoint
)
Visual Basic
Public Sub Write ( _
    endPoint As IPEndPoint _
)
Visual C++
public:
void Write(
    IPEndPoint^ endPoint
)

Parameters

endPoint
Type: System.Net..::..IPEndPoint

[Missing <param name="endPoint"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Net.IPEndPoint)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (SByte)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (SByte)
NetOutgoingMessage Class See Also Send Feedback
Writes a signed byte

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    sbyte source
)
Visual Basic
Public Sub Write ( _
    source As SByte _
)
Visual C++
public:
void Write(
    signed char source
)

Parameters

source
Type: System..::..SByte

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.SByte)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Single)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Single)
NetOutgoingMessage Class See Also Send Feedback
Writes a 32 bit floating point value

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    float source
)
Visual Basic
Public Sub Write ( _
    source As Single _
)
Visual C++
public:
void Write(
    float source
)

Parameters

source
Type: System..::..Single

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Single)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (String)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (String)
NetOutgoingMessage Class See Also Send Feedback
Write a string

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    string source
)
Visual Basic
Public Sub Write ( _
    source As String _
)
Visual C++
public:
void Write(
    String^ source
)

Parameters

source
Type: System..::..String

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.String)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (UInt16)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (UInt16)
NetOutgoingMessage Class See Also Send Feedback
Writes an unsigned 16 bit integer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    ushort source
)
Visual Basic
Public Sub Write ( _
    source As UShort _
)
Visual C++
public:
void Write(
    unsigned short source
)

Parameters

source
Type: System..::..UInt16

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.UInt16)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (UInt32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (UInt32)
NetOutgoingMessage Class See Also Send Feedback
Writes a 32 bit unsigned integer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    uint source
)
Visual Basic
Public Sub Write ( _
    source As UInteger _
)
Visual C++
public:
void Write(
    unsigned int source
)

Parameters

source
Type: System..::..UInt32

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.UInt32)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (UInt64)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (UInt64)
NetOutgoingMessage Class See Also Send Feedback
Writes a 64 bit unsigned integer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    ulong source
)
Visual Basic
Public Sub Write ( _
    source As ULong _
)
Visual C++
public:
void Write(
    unsigned long long source
)

Parameters

source
Type: System..::..UInt64

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.UInt64)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (NetIncomingMessage)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (NetIncomingMessage)
NetOutgoingMessage Class See Also Send Feedback
Append all the bits of message to this message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    NetIncomingMessage message
)
Visual Basic
Public Sub Write ( _
    message As NetIncomingMessage _
)
Visual C++
public:
void Write(
    NetIncomingMessage^ message
)

Parameters

message
Type: Lidgren.Network..::..NetIncomingMessage

[Missing <param name="message"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(Lidgren.Network.NetIncomingMessage)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (NetOutgoingMessage)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (NetOutgoingMessage)
NetOutgoingMessage Class See Also Send Feedback
Append all the bits of message to this message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    NetOutgoingMessage message
)
Visual Basic
Public Sub Write ( _
    message As NetOutgoingMessage _
)
Visual C++
public:
void Write(
    NetOutgoingMessage^ message
)

Parameters

message
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="message"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(Lidgren.Network.NetOutgoingMessage)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Byte, Int32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Byte, Int32)
NetOutgoingMessage Class See Also Send Feedback
Writes 1 to 8 bits of a byte

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    byte source,
    int numberOfBits
)
Visual Basic
Public Sub Write ( _
    source As Byte, _
    numberOfBits As Integer _
)
Visual C++
public:
void Write(
    unsigned char source,
    int numberOfBits
)

Parameters

source
Type: System..::..Byte

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Byte,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Byte,System.Int32)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Int32, Int32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Int32, Int32)
NetOutgoingMessage Class See Also Send Feedback
Writes a signed integer using 1 to 32 bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    int source,
    int numberOfBits
)
Visual Basic
Public Sub Write ( _
    source As Integer, _
    numberOfBits As Integer _
)
Visual C++
public:
void Write(
    int source,
    int numberOfBits
)

Parameters

source
Type: System..::..Int32

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Int32,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Int32,System.Int32)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Int64, Int32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (Int64, Int32)
NetOutgoingMessage Class See Also Send Feedback
Writes a signed integer using 1 to 64 bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    long source,
    int numberOfBits
)
Visual Basic
Public Sub Write ( _
    source As Long, _
    numberOfBits As Integer _
)
Visual C++
public:
void Write(
    long long source,
    int numberOfBits
)

Parameters

source
Type: System..::..Int64

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Int64,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Int64,System.Int32)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (UInt16, Int32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (UInt16, Int32)
NetOutgoingMessage Class See Also Send Feedback
Writes an unsigned integer using 1 to 16 bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    ushort source,
    int numberOfBits
)
Visual Basic
Public Sub Write ( _
    source As UShort, _
    numberOfBits As Integer _
)
Visual C++
public:
void Write(
    unsigned short source,
    int numberOfBits
)

Parameters

source
Type: System..::..UInt16

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.UInt16,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.UInt16,System.Int32)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (UInt32, Int32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (UInt32, Int32)
NetOutgoingMessage Class See Also Send Feedback
Writes a 32 bit signed integer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    uint source,
    int numberOfBits
)
Visual Basic
Public Sub Write ( _
    source As UInteger, _
    numberOfBits As Integer _
)
Visual C++
public:
void Write(
    unsigned int source,
    int numberOfBits
)

Parameters

source
Type: System..::..UInt32

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.UInt32,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.UInt32,System.Int32)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (UInt64, Int32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (UInt64, Int32)
NetOutgoingMessage Class See Also Send Feedback
Writes an unsigned integer using 1 to 64 bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    ulong source,
    int numberOfBits
)
Visual Basic
Public Sub Write ( _
    source As ULong, _
    numberOfBits As Integer _
)
Visual C++
public:
void Write(
    unsigned long long source,
    int numberOfBits
)

Parameters

source
Type: System..::..UInt64

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.UInt64,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.UInt64,System.Int32)"]

See Also

NetOutgoingMessage Class
Write Overload


Write Method (Byte[], Int32, Int32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..Write Method (array<Byte>[]()[][], Int32, Int32)
NetOutgoingMessage Class See Also Send Feedback
Writes the specified number of bytes from an array

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Write(
    byte[] source,
    int offsetInBytes,
    int numberOfBytes
)
Visual Basic
Public Sub Write ( _
    source As Byte(), _
    offsetInBytes As Integer, _
    numberOfBytes As Integer _
)
Visual C++
public:
void Write(
    array<unsigned char>^ source,
    int offsetInBytes,
    int numberOfBytes
)

Parameters

source
Type: array< System..::..Byte >[]()[][]

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Byte[],System.Int32,System.Int32)"]

offsetInBytes
Type: System..::..Int32

[Missing <param name="offsetInBytes"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Byte[],System.Int32,System.Int32)"]

numberOfBytes
Type: System..::..Int32

[Missing <param name="numberOfBytes"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.Write(System.Byte[],System.Int32,System.Int32)"]

See Also

NetOutgoingMessage Class
Write Overload


WriteAllFields Method

[image] [image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteAllFields Method
NetOutgoingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteAllFields(Object) | Writes all public and private declared instance fields of the object in alphabetical order using reflection
Public method | WriteAllFields(Object, BindingFlags) | Writes all fields with specified binding in alphabetical order using reflection

See Also

NetOutgoingMessage Class
NetOutgoingMessage Members


WriteAllFields Method (Object)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteAllFields Method (Object)
NetOutgoingMessage Class See Also Send Feedback
Writes all public and private declared instance fields of the object in alphabetical order using reflection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WriteAllFields(
    Object ob
)
Visual Basic
Public Sub WriteAllFields ( _
    ob As Object _
)
Visual C++
public:
void WriteAllFields(
    Object^ ob
)

Parameters

ob
Type: System..::..Object

[Missing <param name="ob"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteAllFields(System.Object)"]

See Also

NetOutgoingMessage Class
WriteAllFields Overload


WriteAllFields Method (Object, BindingFlags)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteAllFields Method (Object, BindingFlags)
NetOutgoingMessage Class See Also Send Feedback
Writes all fields with specified binding in alphabetical order using reflection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WriteAllFields(
    Object ob,
    BindingFlags flags
)
Visual Basic
Public Sub WriteAllFields ( _
    ob As Object, _
    flags As BindingFlags _
)
Visual C++
public:
void WriteAllFields(
    Object^ ob,
    BindingFlags flags
)

Parameters

ob
Type: System..::..Object

[Missing <param name="ob"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteAllFields(System.Object,System.Reflection.BindingFlags)"]

flags
Type: System.Reflection..::..BindingFlags

[Missing <param name="flags"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteAllFields(System.Object,System.Reflection.BindingFlags)"]

See Also

NetOutgoingMessage Class
WriteAllFields Overload


WriteAllProperties Method

[image] [image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteAllProperties Method
NetOutgoingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteAllProperties(Object) | Writes all public and private declared instance properties of the object in alphabetical order using reflection
Public method | WriteAllProperties(Object, BindingFlags) | Writes all properties with specified binding in alphabetical order using reflection

See Also

NetOutgoingMessage Class
NetOutgoingMessage Members


WriteAllProperties Method (Object)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteAllProperties Method (Object)
NetOutgoingMessage Class See Also Send Feedback
Writes all public and private declared instance properties of the object in alphabetical order using reflection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WriteAllProperties(
    Object ob
)
Visual Basic
Public Sub WriteAllProperties ( _
    ob As Object _
)
Visual C++
public:
void WriteAllProperties(
    Object^ ob
)

Parameters

ob
Type: System..::..Object

[Missing <param name="ob"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteAllProperties(System.Object)"]

See Also

NetOutgoingMessage Class
WriteAllProperties Overload


WriteAllProperties Method (Object, BindingFlags)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteAllProperties Method (Object, BindingFlags)
NetOutgoingMessage Class See Also Send Feedback
Writes all properties with specified binding in alphabetical order using reflection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WriteAllProperties(
    Object ob,
    BindingFlags flags
)
Visual Basic
Public Sub WriteAllProperties ( _
    ob As Object, _
    flags As BindingFlags _
)
Visual C++
public:
void WriteAllProperties(
    Object^ ob,
    BindingFlags flags
)

Parameters

ob
Type: System..::..Object

[Missing <param name="ob"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteAllProperties(System.Object,System.Reflection.BindingFlags)"]

flags
Type: System.Reflection..::..BindingFlags

[Missing <param name="flags"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteAllProperties(System.Object,System.Reflection.BindingFlags)"]

See Also

NetOutgoingMessage Class
WriteAllProperties Overload


WritePadBits Method

[image] [image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WritePadBits Method
NetOutgoingMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WritePadBits()()()() | Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.
Public method | WritePadBits(Int32) | Pads data with the specified number of bits.

See Also

NetOutgoingMessage Class
NetOutgoingMessage Members


WritePadBits Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WritePadBits Method
NetOutgoingMessage Class See Also Send Feedback
Pads data with enough bits to reach a full byte. Decreases cpu usage for subsequent byte writes.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WritePadBits()
Visual Basic
Public Sub WritePadBits
Visual C++
public:
void WritePadBits()

See Also

NetOutgoingMessage Class
WritePadBits Overload


WritePadBits Method (Int32)

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WritePadBits Method (Int32)
NetOutgoingMessage Class See Also Send Feedback
Pads data with the specified number of bits.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WritePadBits(
    int numberOfBits
)
Visual Basic
Public Sub WritePadBits ( _
    numberOfBits As Integer _
)
Visual C++
public:
void WritePadBits(
    int numberOfBits
)

Parameters

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WritePadBits(System.Int32)"]

See Also

NetOutgoingMessage Class
WritePadBits Overload


WriteRangedInteger Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteRangedInteger Method
NetOutgoingMessage Class See Also Send Feedback
Writes an integer with the least amount of bits need for the specified range Returns number of bits written

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int WriteRangedInteger(
    int min,
    int max,
    int value
)
Visual Basic
Public Function WriteRangedInteger ( _
    min As Integer, _
    max As Integer, _
    value As Integer _
) As Integer
Visual C++
public:
int WriteRangedInteger(
    int min,
    int max,
    int value
)

Parameters

min
Type: System..::..Int32

[Missing <param name="min"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteRangedInteger(System.Int32,System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteRangedInteger(System.Int32,System.Int32,System.Int32)"]

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteRangedInteger(System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteRangedInteger(System.Int32,System.Int32,System.Int32)"]

See Also

NetOutgoingMessage Class


WriteRangedSingle Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteRangedSingle Method
NetOutgoingMessage Class See Also Send Feedback
Compress a float within a specified range using a certain number of bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WriteRangedSingle(
    float value,
    float min,
    float max,
    int numberOfBits
)
Visual Basic
Public Sub WriteRangedSingle ( _
    value As Single, _
    min As Single, _
    max As Single, _
    numberOfBits As Integer _
)
Visual C++
public:
void WriteRangedSingle(
    float value,
    float min,
    float max,
    int numberOfBits
)

Parameters

value
Type: System..::..Single

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteRangedSingle(System.Single,System.Single,System.Single,System.Int32)"]

min
Type: System..::..Single

[Missing <param name="min"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteRangedSingle(System.Single,System.Single,System.Single,System.Int32)"]

max
Type: System..::..Single

[Missing <param name="max"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteRangedSingle(System.Single,System.Single,System.Single,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteRangedSingle(System.Single,System.Single,System.Single,System.Int32)"]

See Also

NetOutgoingMessage Class


WriteSignedSingle Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteSignedSingle Method
NetOutgoingMessage Class See Also Send Feedback
Compress (lossy) a float in the range -1..1 using numberOfBits bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WriteSignedSingle(
    float value,
    int numberOfBits
)
Visual Basic
Public Sub WriteSignedSingle ( _
    value As Single, _
    numberOfBits As Integer _
)
Visual C++
public:
void WriteSignedSingle(
    float value,
    int numberOfBits
)

Parameters

value
Type: System..::..Single

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteSignedSingle(System.Single,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteSignedSingle(System.Single,System.Int32)"]

See Also

NetOutgoingMessage Class


WriteTime Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteTime Method
NetOutgoingMessage Class See Also Send Feedback
Writes the local time to a message; readable (and convertable to local time) by the remote host using ReadTime()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WriteTime(
    double localTime,
    bool highPrecision
)
Visual Basic
Public Sub WriteTime ( _
    localTime As Double, _
    highPrecision As Boolean _
)
Visual C++
public:
void WriteTime(
    double localTime,
    bool highPrecision
)

Parameters

localTime
Type: System..::..Double

[Missing <param name="localTime"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteTime(System.Double,System.Boolean)"]

highPrecision
Type: System..::..Boolean

[Missing <param name="highPrecision"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteTime(System.Double,System.Boolean)"]

See Also

NetOutgoingMessage Class


WriteUnitSingle Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteUnitSingle Method
NetOutgoingMessage Class See Also Send Feedback
Compress (lossy) a float in the range 0..1 using numberOfBits bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void WriteUnitSingle(
    float value,
    int numberOfBits
)
Visual Basic
Public Sub WriteUnitSingle ( _
    value As Single, _
    numberOfBits As Integer _
)
Visual C++
public:
void WriteUnitSingle(
    float value,
    int numberOfBits
)

Parameters

value
Type: System..::..Single

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteUnitSingle(System.Single,System.Int32)"]

numberOfBits
Type: System..::..Int32

[Missing <param name="numberOfBits"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteUnitSingle(System.Single,System.Int32)"]

See Also

NetOutgoingMessage Class


WriteVariableInt32 Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteVariableInt32 Method
NetOutgoingMessage Class See Also Send Feedback
Write Base128 encoded variable sized signed integer of up to 32 bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int WriteVariableInt32(
    int value
)
Visual Basic
Public Function WriteVariableInt32 ( _
    value As Integer _
) As Integer
Visual C++
public:
int WriteVariableInt32(
    int value
)

Parameters

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteVariableInt32(System.Int32)"]

Return Value

number of bytes written

See Also

NetOutgoingMessage Class


WriteVariableInt64 Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteVariableInt64 Method
NetOutgoingMessage Class See Also Send Feedback
Write Base128 encoded variable sized signed integer of up to 64 bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int WriteVariableInt64(
    long value
)
Visual Basic
Public Function WriteVariableInt64 ( _
    value As Long _
) As Integer
Visual C++
public:
int WriteVariableInt64(
    long long value
)

Parameters

value
Type: System..::..Int64

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteVariableInt64(System.Int64)"]

Return Value

number of bytes written

See Also

NetOutgoingMessage Class


WriteVariableUInt32 Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteVariableUInt32 Method
NetOutgoingMessage Class See Also Send Feedback
Write Base128 encoded variable sized unsigned integer of up to 32 bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int WriteVariableUInt32(
    uint value
)
Visual Basic
Public Function WriteVariableUInt32 ( _
    value As UInteger _
) As Integer
Visual C++
public:
int WriteVariableUInt32(
    unsigned int value
)

Parameters

value
Type: System..::..UInt32

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteVariableUInt32(System.UInt32)"]

Return Value

number of bytes written

See Also

NetOutgoingMessage Class


WriteVariableUInt64 Method

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..WriteVariableUInt64 Method
NetOutgoingMessage Class See Also Send Feedback
Write Base128 encoded variable sized unsigned integer of up to 64 bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int WriteVariableUInt64(
    ulong value
)
Visual Basic
Public Function WriteVariableUInt64 ( _
    value As ULong _
) As Integer
Visual C++
public:
int WriteVariableUInt64(
    unsigned long long value
)

Parameters

value
Type: System..::..UInt64

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetOutgoingMessage.WriteVariableUInt64(System.UInt64)"]

Return Value

number of bytes written

See Also

NetOutgoingMessage Class


NetOutgoingMessage Properties

[image] [image]

Lidgren Network Library documentation
NetOutgoingMessage Properties
NetOutgoingMessage Class See Also Send Feedback

The NetOutgoingMessage type exposes the following members.

Properties

 | Name | Description
Public property | LengthBits | Gets or sets the length of the buffer in bits
Public property | LengthBytes | Gets or sets the length of the buffer in bytes

See Also

NetOutgoingMessage Class


LengthBits Property

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..LengthBits Property
NetOutgoingMessage Class See Also Send Feedback
Gets or sets the length of the buffer in bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int LengthBits { get; set; }
Visual Basic
Public Property LengthBits As Integer
    Get
    Set
Visual C++
public:
property int LengthBits {
    int get ();
    void set (int value);
}

See Also

NetOutgoingMessage Class


LengthBytes Property

[image]

Lidgren Network Library documentation
NetOutgoingMessage..::..LengthBytes Property
NetOutgoingMessage Class See Also Send Feedback
Gets or sets the length of the buffer in bytes

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int LengthBytes { get; set; }
Visual Basic
Public Property LengthBytes As Integer
    Get
    Set
Visual C++
public:
property int LengthBytes {
    int get ();
    void set (int value);
}

See Also

NetOutgoingMessage Class


NetPeer Class

[image]

Lidgren Network Library documentation
NetPeer Class
Members See Also Send Feedback
Represents a local peer capable of holding zero, one or more connections to remote peers

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetPeer
Visual Basic
Public Class NetPeer
Visual C++
public ref class NetPeer

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetPeer
Lidgren.Network..::..NetClient
Lidgren.Network..::..NetServer

See Also

NetPeer Members


NetPeer Members

[image] [image]

Lidgren Network Library documentation
NetPeer Members
NetPeer Class Constructors Methods Properties See Also Send Feedback

The NetPeer type exposes the following members.

Constructors

 | Name | Description
Public method | NetPeer | NetPeer constructor

Methods

 | Name | Description
Public method | Connect(IPEndPoint) | Create a connection to a remote endpoint
Public method | Connect(IPEndPoint, NetOutgoingMessage) | Create a connection to a remote endpoint
Public method | Connect(String, Int32) | Create a connection to a remote endpoint
Public method | Connect(String, Int32, NetOutgoingMessage) | Create a connection to a remote endpoint
Public method | CreateMessage()()()() | Creates a new message for sending
Public method | CreateMessage(Int32) | Creates a new message for sending
Public method | CreateMessage(String) | Creates a new message for sending and writes the provided string to it
Public method | DiscoverKnownPeer(IPEndPoint) | Emit a discovery signal to a single known host
Public method | DiscoverKnownPeer(String, Int32) | Emit a discovery signal to a single known host
Public method | DiscoverLocalPeers | Emit a discovery signal to all hosts on your subnet
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConnection | Get the connection, if any, for a certain remote endpoint
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Introduce | Send NetIntroduction to hostExternal and clientExternal; introducing client to host
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadMessage | Read a pending message from any connection, if any
Public method | Recycle | Recycles a NetIncomingMessage instance for reuse; taking pressure off the garbage collector
Public method | SendDiscoveryResponse | Send a discovery response message
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod) | Send a message to a specific connection
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to a specific connection
Public method | SendMessage(NetOutgoingMessage, IList<(Of <<'(NetConnection>)>>), NetDeliveryMethod, Int32) | Send a message to a list of connections
Public method | SendUnconnectedMessage(NetOutgoingMessage, IList<(Of <<'(IPEndPoint>)>>)) | Send a message to an unconnected host
Public method | SendUnconnectedMessage(NetOutgoingMessage, IPEndPoint) | Send a message to an unconnected host
Public method | SendUnconnectedMessage(NetOutgoingMessage, String, Int32) | Send a message to an unconnected host
Public method | Shutdown | Disconnects all active connections and closes the socket
Public method | Start | Binds to socket and spawns the networking thread
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitMessage | Read a pending message from any connection, blocking up to maxMillis if needed

Properties

 | Name | Description
Public property | Configuration | Gets the configuration used to instanciate this NetPeer
Public property | Connections | Gets a copy of the list of connections
Public property | ConnectionsCount | Gets the number of active connections
Public property | MessageReceivedEvent | Signalling event which can be waited on to determine when a message is queued for reading. Note that there is no guarantee that after the event is signaled the blocked thread will find the message in the queue. Other user created threads could be preempted and dequeue the message before the waiting thread wakes up.
Public property | Port | Gets the port number this NetPeer is listening and sending on, if Start() has been called
Public property | Socket | Gets the socket, if Start() has been called
Public property | Statistics | Statistics on this NetPeer since it was initialized
Public property | Status | Gets the NetPeerStatus of the NetPeer
Public property | Tag | Gets or sets the application defined object containing data about the peer
Public property | UniqueIdentifier | Gets a unique identifier for this NetPeer based on Mac address and ip/port. Note! Not available until Start() has been called!
Public property | UPnP | Returns an UPnP object if enabled in the NetPeerConfiguration

See Also

NetPeer Class


NetPeer Constructor

[image]

Lidgren Network Library documentation
NetPeer Constructor
NetPeer Class See Also Send Feedback
NetPeer constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetPeer(
    NetPeerConfiguration config
)
Visual Basic
Public Sub New ( _
    config As NetPeerConfiguration _
)
Visual C++
public:
NetPeer(
    NetPeerConfiguration^ config
)

Parameters

config
Type: Lidgren.Network..::..NetPeerConfiguration

[Missing <param name="config"/> documentation for "M:Lidgren.Network.NetPeer.#ctor(Lidgren.Network.NetPeerConfiguration)"]

See Also

NetPeer Class


NetPeer Methods

[image] [image]

Lidgren Network Library documentation
NetPeer Methods
NetPeer Class See Also Send Feedback

The NetPeer type exposes the following members.

Methods

 | Name | Description
Public method | Connect(IPEndPoint) | Create a connection to a remote endpoint
Public method | Connect(IPEndPoint, NetOutgoingMessage) | Create a connection to a remote endpoint
Public method | Connect(String, Int32) | Create a connection to a remote endpoint
Public method | Connect(String, Int32, NetOutgoingMessage) | Create a connection to a remote endpoint
Public method | CreateMessage()()()() | Creates a new message for sending
Public method | CreateMessage(Int32) | Creates a new message for sending
Public method | CreateMessage(String) | Creates a new message for sending and writes the provided string to it
Public method | DiscoverKnownPeer(IPEndPoint) | Emit a discovery signal to a single known host
Public method | DiscoverKnownPeer(String, Int32) | Emit a discovery signal to a single known host
Public method | DiscoverLocalPeers | Emit a discovery signal to all hosts on your subnet
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConnection | Get the connection, if any, for a certain remote endpoint
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Introduce | Send NetIntroduction to hostExternal and clientExternal; introducing client to host
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadMessage | Read a pending message from any connection, if any
Public method | Recycle | Recycles a NetIncomingMessage instance for reuse; taking pressure off the garbage collector
Public method | SendDiscoveryResponse | Send a discovery response message
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod) | Send a message to a specific connection
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to a specific connection
Public method | SendMessage(NetOutgoingMessage, IList<(Of <<'(NetConnection>)>>), NetDeliveryMethod, Int32) | Send a message to a list of connections
Public method | SendUnconnectedMessage(NetOutgoingMessage, IList<(Of <<'(IPEndPoint>)>>)) | Send a message to an unconnected host
Public method | SendUnconnectedMessage(NetOutgoingMessage, IPEndPoint) | Send a message to an unconnected host
Public method | SendUnconnectedMessage(NetOutgoingMessage, String, Int32) | Send a message to an unconnected host
Public method | Shutdown | Disconnects all active connections and closes the socket
Public method | Start | Binds to socket and spawns the networking thread
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitMessage | Read a pending message from any connection, blocking up to maxMillis if needed

See Also

NetPeer Class


Connect Method

[image] [image]

Lidgren Network Library documentation
NetPeer..::..Connect Method
NetPeer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect(IPEndPoint) | Create a connection to a remote endpoint
Public method | Connect(IPEndPoint, NetOutgoingMessage) | Create a connection to a remote endpoint
Public method | Connect(String, Int32) | Create a connection to a remote endpoint
Public method | Connect(String, Int32, NetOutgoingMessage) | Create a connection to a remote endpoint

See Also

NetPeer Class
NetPeer Members


Connect Method (IPEndPoint)

[image]

Lidgren Network Library documentation
NetPeer..::..Connect Method (IPEndPoint)
NetPeer Class See Also Send Feedback
Create a connection to a remote endpoint

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetConnection Connect(
    IPEndPoint remoteEndpoint
)
Visual Basic
Public Function Connect ( _
    remoteEndpoint As IPEndPoint _
) As NetConnection
Visual C++
public:
NetConnection^ Connect(
    IPEndPoint^ remoteEndpoint
)

Parameters

remoteEndpoint
Type: System.Net..::..IPEndPoint

[Missing <param name="remoteEndpoint"/> documentation for "M:Lidgren.Network.NetPeer.Connect(System.Net.IPEndPoint)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.Connect(System.Net.IPEndPoint)"]

See Also

NetPeer Class
Connect Overload


Connect Method (IPEndPoint, NetOutgoingMessage)

[image]

Lidgren Network Library documentation
NetPeer..::..Connect Method (IPEndPoint, NetOutgoingMessage)
NetPeer Class See Also Send Feedback
Create a connection to a remote endpoint

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public virtual NetConnection Connect(
    IPEndPoint remoteEndpoint,
    NetOutgoingMessage hailMessage
)
Visual Basic
Public Overridable Function Connect ( _
    remoteEndpoint As IPEndPoint, _
    hailMessage As NetOutgoingMessage _
) As NetConnection
Visual C++
public:
virtual NetConnection^ Connect(
    IPEndPoint^ remoteEndpoint,
    NetOutgoingMessage^ hailMessage
)

Parameters

remoteEndpoint
Type: System.Net..::..IPEndPoint

[Missing <param name="remoteEndpoint"/> documentation for "M:Lidgren.Network.NetPeer.Connect(System.Net.IPEndPoint,Lidgren.Network.NetOutgoingMessage)"]

hailMessage
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="hailMessage"/> documentation for "M:Lidgren.Network.NetPeer.Connect(System.Net.IPEndPoint,Lidgren.Network.NetOutgoingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.Connect(System.Net.IPEndPoint,Lidgren.Network.NetOutgoingMessage)"]

See Also

NetPeer Class
Connect Overload


Connect Method (String, Int32)

[image]

Lidgren Network Library documentation
NetPeer..::..Connect Method (String, Int32)
NetPeer Class See Also Send Feedback
Create a connection to a remote endpoint

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetConnection Connect(
    string host,
    int port
)
Visual Basic
Public Function Connect ( _
    host As String, _
    port As Integer _
) As NetConnection
Visual C++
public:
NetConnection^ Connect(
    String^ host,
    int port
)

Parameters

host
Type: System..::..String

[Missing <param name="host"/> documentation for "M:Lidgren.Network.NetPeer.Connect(System.String,System.Int32)"]

port
Type: System..::..Int32

[Missing <param name="port"/> documentation for "M:Lidgren.Network.NetPeer.Connect(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.Connect(System.String,System.Int32)"]

See Also

NetPeer Class
Connect Overload


Connect Method (String, Int32, NetOutgoingMessage)

[image]

Lidgren Network Library documentation
NetPeer..::..Connect Method (String, Int32, NetOutgoingMessage)
NetPeer Class See Also Send Feedback
Create a connection to a remote endpoint

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetConnection Connect(
    string host,
    int port,
    NetOutgoingMessage hailMessage
)
Visual Basic
Public Function Connect ( _
    host As String, _
    port As Integer, _
    hailMessage As NetOutgoingMessage _
) As NetConnection
Visual C++
public:
NetConnection^ Connect(
    String^ host,
    int port,
    NetOutgoingMessage^ hailMessage
)

Parameters

host
Type: System..::..String

[Missing <param name="host"/> documentation for "M:Lidgren.Network.NetPeer.Connect(System.String,System.Int32,Lidgren.Network.NetOutgoingMessage)"]

port
Type: System..::..Int32

[Missing <param name="port"/> documentation for "M:Lidgren.Network.NetPeer.Connect(System.String,System.Int32,Lidgren.Network.NetOutgoingMessage)"]

hailMessage
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="hailMessage"/> documentation for "M:Lidgren.Network.NetPeer.Connect(System.String,System.Int32,Lidgren.Network.NetOutgoingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.Connect(System.String,System.Int32,Lidgren.Network.NetOutgoingMessage)"]

See Also

NetPeer Class
Connect Overload


CreateMessage Method

[image] [image]

Lidgren Network Library documentation
NetPeer..::..CreateMessage Method
NetPeer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateMessage()()()() | Creates a new message for sending
Public method | CreateMessage(Int32) | Creates a new message for sending
Public method | CreateMessage(String) | Creates a new message for sending and writes the provided string to it

See Also

NetPeer Class
NetPeer Members


CreateMessage Method

[image]

Lidgren Network Library documentation
NetPeer..::..CreateMessage Method
NetPeer Class See Also Send Feedback
Creates a new message for sending

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetOutgoingMessage CreateMessage()
Visual Basic
Public Function CreateMessage As NetOutgoingMessage
Visual C++
public:
NetOutgoingMessage^ CreateMessage()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.CreateMessage"]

See Also

NetPeer Class
CreateMessage Overload


CreateMessage Method (Int32)

[image]

Lidgren Network Library documentation
NetPeer..::..CreateMessage Method (Int32)
NetPeer Class See Also Send Feedback
Creates a new message for sending

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetOutgoingMessage CreateMessage(
    int initialCapacity
)
Visual Basic
Public Function CreateMessage ( _
    initialCapacity As Integer _
) As NetOutgoingMessage
Visual C++
public:
NetOutgoingMessage^ CreateMessage(
    int initialCapacity
)

Parameters

initialCapacity
Type: System..::..Int32
initial capacity in bytes

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.CreateMessage(System.Int32)"]

See Also

NetPeer Class
CreateMessage Overload


CreateMessage Method (String)

[image]

Lidgren Network Library documentation
NetPeer..::..CreateMessage Method (String)
NetPeer Class See Also Send Feedback
Creates a new message for sending and writes the provided string to it

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetOutgoingMessage CreateMessage(
    string content
)
Visual Basic
Public Function CreateMessage ( _
    content As String _
) As NetOutgoingMessage
Visual C++
public:
NetOutgoingMessage^ CreateMessage(
    String^ content
)

Parameters

content
Type: System..::..String

[Missing <param name="content"/> documentation for "M:Lidgren.Network.NetPeer.CreateMessage(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.CreateMessage(System.String)"]

See Also

NetPeer Class
CreateMessage Overload


DiscoverKnownPeer Method

[image] [image]

Lidgren Network Library documentation
NetPeer..::..DiscoverKnownPeer Method
NetPeer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DiscoverKnownPeer(IPEndPoint) | Emit a discovery signal to a single known host
Public method | DiscoverKnownPeer(String, Int32) | Emit a discovery signal to a single known host

See Also

NetPeer Class
NetPeer Members


DiscoverKnownPeer Method (IPEndPoint)

[image]

Lidgren Network Library documentation
NetPeer..::..DiscoverKnownPeer Method (IPEndPoint)
NetPeer Class See Also Send Feedback
Emit a discovery signal to a single known host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void DiscoverKnownPeer(
    IPEndPoint endpoint
)
Visual Basic
Public Sub DiscoverKnownPeer ( _
    endpoint As IPEndPoint _
)
Visual C++
public:
void DiscoverKnownPeer(
    IPEndPoint^ endpoint
)

Parameters

endpoint
Type: System.Net..::..IPEndPoint

[Missing <param name="endpoint"/> documentation for "M:Lidgren.Network.NetPeer.DiscoverKnownPeer(System.Net.IPEndPoint)"]

See Also

NetPeer Class
DiscoverKnownPeer Overload


DiscoverKnownPeer Method (String, Int32)

[image]

Lidgren Network Library documentation
NetPeer..::..DiscoverKnownPeer Method (String, Int32)
NetPeer Class See Also Send Feedback
Emit a discovery signal to a single known host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool DiscoverKnownPeer(
    string host,
    int serverPort
)
Visual Basic
Public Function DiscoverKnownPeer ( _
    host As String, _
    serverPort As Integer _
) As Boolean
Visual C++
public:
bool DiscoverKnownPeer(
    String^ host,
    int serverPort
)

Parameters

host
Type: System..::..String

[Missing <param name="host"/> documentation for "M:Lidgren.Network.NetPeer.DiscoverKnownPeer(System.String,System.Int32)"]

serverPort
Type: System..::..Int32

[Missing <param name="serverPort"/> documentation for "M:Lidgren.Network.NetPeer.DiscoverKnownPeer(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.DiscoverKnownPeer(System.String,System.Int32)"]

See Also

NetPeer Class
DiscoverKnownPeer Overload


DiscoverLocalPeers Method

[image]

Lidgren Network Library documentation
NetPeer..::..DiscoverLocalPeers Method
NetPeer Class See Also Send Feedback
Emit a discovery signal to all hosts on your subnet

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void DiscoverLocalPeers(
    int serverPort
)
Visual Basic
Public Sub DiscoverLocalPeers ( _
    serverPort As Integer _
)
Visual C++
public:
void DiscoverLocalPeers(
    int serverPort
)

Parameters

serverPort
Type: System..::..Int32

[Missing <param name="serverPort"/> documentation for "M:Lidgren.Network.NetPeer.DiscoverLocalPeers(System.Int32)"]

See Also

NetPeer Class


GetConnection Method

[image]

Lidgren Network Library documentation
NetPeer..::..GetConnection Method
NetPeer Class See Also Send Feedback
Get the connection, if any, for a certain remote endpoint

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetConnection GetConnection(
    IPEndPoint ep
)
Visual Basic
Public Function GetConnection ( _
    ep As IPEndPoint _
) As NetConnection
Visual C++
public:
NetConnection^ GetConnection(
    IPEndPoint^ ep
)

Parameters

ep
Type: System.Net..::..IPEndPoint

[Missing <param name="ep"/> documentation for "M:Lidgren.Network.NetPeer.GetConnection(System.Net.IPEndPoint)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.GetConnection(System.Net.IPEndPoint)"]

See Also

NetPeer Class


Introduce Method

[image]

Lidgren Network Library documentation
NetPeer..::..Introduce Method
NetPeer Class See Also Send Feedback
Send NetIntroduction to hostExternal and clientExternal; introducing client to host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Introduce(
    IPEndPoint hostInternal,
    IPEndPoint hostExternal,
    IPEndPoint clientInternal,
    IPEndPoint clientExternal,
    string token
)
Visual Basic
Public Sub Introduce ( _
    hostInternal As IPEndPoint, _
    hostExternal As IPEndPoint, _
    clientInternal As IPEndPoint, _
    clientExternal As IPEndPoint, _
    token As String _
)
Visual C++
public:
void Introduce(
    IPEndPoint^ hostInternal,
    IPEndPoint^ hostExternal,
    IPEndPoint^ clientInternal,
    IPEndPoint^ clientExternal,
    String^ token
)

Parameters

hostInternal
Type: System.Net..::..IPEndPoint

[Missing <param name="hostInternal"/> documentation for "M:Lidgren.Network.NetPeer.Introduce(System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.String)"]

hostExternal
Type: System.Net..::..IPEndPoint

[Missing <param name="hostExternal"/> documentation for "M:Lidgren.Network.NetPeer.Introduce(System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.String)"]

clientInternal
Type: System.Net..::..IPEndPoint

[Missing <param name="clientInternal"/> documentation for "M:Lidgren.Network.NetPeer.Introduce(System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.String)"]

clientExternal
Type: System.Net..::..IPEndPoint

[Missing <param name="clientExternal"/> documentation for "M:Lidgren.Network.NetPeer.Introduce(System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.String)"]

token
Type: System..::..String

[Missing <param name="token"/> documentation for "M:Lidgren.Network.NetPeer.Introduce(System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.Net.IPEndPoint,System.String)"]

See Also

NetPeer Class


ReadMessage Method

[image]

Lidgren Network Library documentation
NetPeer..::..ReadMessage Method
NetPeer Class See Also Send Feedback
Read a pending message from any connection, if any

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetIncomingMessage ReadMessage()
Visual Basic
Public Function ReadMessage As NetIncomingMessage
Visual C++
public:
NetIncomingMessage^ ReadMessage()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.ReadMessage"]

See Also

NetPeer Class


Recycle Method

[image]

Lidgren Network Library documentation
NetPeer..::..Recycle Method
NetPeer Class See Also Send Feedback
Recycles a NetIncomingMessage instance for reuse; taking pressure off the garbage collector

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Recycle(
    NetIncomingMessage msg
)
Visual Basic
Public Sub Recycle ( _
    msg As NetIncomingMessage _
)
Visual C++
public:
void Recycle(
    NetIncomingMessage^ msg
)

Parameters

msg
Type: Lidgren.Network..::..NetIncomingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetPeer.Recycle(Lidgren.Network.NetIncomingMessage)"]

See Also

NetPeer Class


SendDiscoveryResponse Method

[image]

Lidgren Network Library documentation
NetPeer..::..SendDiscoveryResponse Method
NetPeer Class See Also Send Feedback
Send a discovery response message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SendDiscoveryResponse(
    NetOutgoingMessage msg,
    IPEndPoint recipient
)
Visual Basic
Public Sub SendDiscoveryResponse ( _
    msg As NetOutgoingMessage, _
    recipient As IPEndPoint _
)
Visual C++
public:
void SendDiscoveryResponse(
    NetOutgoingMessage^ msg,
    IPEndPoint^ recipient
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetPeer.SendDiscoveryResponse(Lidgren.Network.NetOutgoingMessage,System.Net.IPEndPoint)"]

recipient
Type: System.Net..::..IPEndPoint

[Missing <param name="recipient"/> documentation for "M:Lidgren.Network.NetPeer.SendDiscoveryResponse(Lidgren.Network.NetOutgoingMessage,System.Net.IPEndPoint)"]

See Also

NetPeer Class


SendMessage Method

[image] [image]

Lidgren Network Library documentation
NetPeer..::..SendMessage Method
NetPeer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod) | Send a message to a specific connection
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to a specific connection
Public method | SendMessage(NetOutgoingMessage, IList<(Of <<'(NetConnection>)>>), NetDeliveryMethod, Int32) | Send a message to a list of connections

See Also

NetPeer Class
NetPeer Members


SendMessage Method (NetOutgoingMessage, NetConnection, NetDeliveryMethod)

[image]

Lidgren Network Library documentation
NetPeer..::..SendMessage Method (NetOutgoingMessage, NetConnection, NetDeliveryMethod)
NetPeer Class See Also Send Feedback
Send a message to a specific connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetSendResult SendMessage(
    NetOutgoingMessage msg,
    NetConnection recipient,
    NetDeliveryMethod method
)
Visual Basic
Public Function SendMessage ( _
    msg As NetOutgoingMessage, _
    recipient As NetConnection, _
    method As NetDeliveryMethod _
) As NetSendResult
Visual C++
public:
NetSendResult SendMessage(
    NetOutgoingMessage^ msg,
    NetConnection^ recipient,
    NetDeliveryMethod method
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage
The message to send
recipient
Type: Lidgren.Network..::..NetConnection
The recipient connection
method
Type: Lidgren.Network..::..NetDeliveryMethod
How to deliver the message

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetConnection,Lidgren.Network.NetDeliveryMethod)"]

See Also

NetPeer Class
SendMessage Overload


SendMessage Method (NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32)

[image]

Lidgren Network Library documentation
NetPeer..::..SendMessage Method (NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32)
NetPeer Class See Also Send Feedback
Send a message to a specific connection

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetSendResult SendMessage(
    NetOutgoingMessage msg,
    NetConnection recipient,
    NetDeliveryMethod method,
    int sequenceChannel
)
Visual Basic
Public Function SendMessage ( _
    msg As NetOutgoingMessage, _
    recipient As NetConnection, _
    method As NetDeliveryMethod, _
    sequenceChannel As Integer _
) As NetSendResult
Visual C++
public:
NetSendResult SendMessage(
    NetOutgoingMessage^ msg,
    NetConnection^ recipient,
    NetDeliveryMethod method,
    int sequenceChannel
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage
The message to send
recipient
Type: Lidgren.Network..::..NetConnection
The recipient connection
method
Type: Lidgren.Network..::..NetDeliveryMethod
How to deliver the message
sequenceChannel
Type: System..::..Int32
Sequence channel within the delivery method

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.SendMessage(Lidgren.Network.NetOutgoingMessage,Lidgren.Network.NetConnection,Lidgren.Network.NetDeliveryMethod,System.Int32)"]

See Also

NetPeer Class
SendMessage Overload


SendMessage Method (NetOutgoingMessage, IList(NetConnection), NetDeliveryMethod, Int32)

[image]

Lidgren Network Library documentation
NetPeer..::..SendMessage Method (NetOutgoingMessage, IList<(Of <(<'NetConnection>)>)>, NetDeliveryMethod, Int32)
NetPeer Class See Also Send Feedback
Send a message to a list of connections

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SendMessage(
    NetOutgoingMessage msg,
    IList<NetConnection> recipients,
    NetDeliveryMethod method,
    int sequenceChannel
)
Visual Basic
Public Sub SendMessage ( _
    msg As NetOutgoingMessage, _
    recipients As IList(Of NetConnection), _
    method As NetDeliveryMethod, _
    sequenceChannel As Integer _
)
Visual C++
public:
void SendMessage(
    NetOutgoingMessage^ msg,
    IList<NetConnection^>^ recipients,
    NetDeliveryMethod method,
    int sequenceChannel
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage
The message to send
recipients
Type: System.Collections.Generic..::..IList <(Of <(<' NetConnection >)>)>
The list of recipients to send to
method
Type: Lidgren.Network..::..NetDeliveryMethod
How to deliver the message
sequenceChannel
Type: System..::..Int32
Sequence channel within the delivery method

See Also

NetPeer Class
SendMessage Overload


SendUnconnectedMessage Method

[image] [image]

Lidgren Network Library documentation
NetPeer..::..SendUnconnectedMessage Method
NetPeer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendUnconnectedMessage(NetOutgoingMessage, IList<(Of <<'(IPEndPoint>)>>)) | Send a message to an unconnected host
Public method | SendUnconnectedMessage(NetOutgoingMessage, IPEndPoint) | Send a message to an unconnected host
Public method | SendUnconnectedMessage(NetOutgoingMessage, String, Int32) | Send a message to an unconnected host

See Also

NetPeer Class
NetPeer Members


SendUnconnectedMessage Method (NetOutgoingMessage, IList(IPEndPoint))

[image]

Lidgren Network Library documentation
NetPeer..::..SendUnconnectedMessage Method (NetOutgoingMessage, IList<(Of <(<'IPEndPoint>)>)>)
NetPeer Class See Also Send Feedback
Send a message to an unconnected host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SendUnconnectedMessage(
    NetOutgoingMessage msg,
    IList<IPEndPoint> recipients
)
Visual Basic
Public Sub SendUnconnectedMessage ( _
    msg As NetOutgoingMessage, _
    recipients As IList(Of IPEndPoint) _
)
Visual C++
public:
void SendUnconnectedMessage(
    NetOutgoingMessage^ msg,
    IList<IPEndPoint^>^ recipients
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetPeer.SendUnconnectedMessage(Lidgren.Network.NetOutgoingMessage,System.Collections.Generic.IList{System.Net.IPEndPoint})"]

recipients
Type: System.Collections.Generic..::..IList <(Of <(<' IPEndPoint >)>)>

[Missing <param name="recipients"/> documentation for "M:Lidgren.Network.NetPeer.SendUnconnectedMessage(Lidgren.Network.NetOutgoingMessage,System.Collections.Generic.IList{System.Net.IPEndPoint})"]

See Also

NetPeer Class
SendUnconnectedMessage Overload


SendUnconnectedMessage Method (NetOutgoingMessage, IPEndPoint)

[image]

Lidgren Network Library documentation
NetPeer..::..SendUnconnectedMessage Method (NetOutgoingMessage, IPEndPoint)
NetPeer Class See Also Send Feedback
Send a message to an unconnected host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SendUnconnectedMessage(
    NetOutgoingMessage msg,
    IPEndPoint recipient
)
Visual Basic
Public Sub SendUnconnectedMessage ( _
    msg As NetOutgoingMessage, _
    recipient As IPEndPoint _
)
Visual C++
public:
void SendUnconnectedMessage(
    NetOutgoingMessage^ msg,
    IPEndPoint^ recipient
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetPeer.SendUnconnectedMessage(Lidgren.Network.NetOutgoingMessage,System.Net.IPEndPoint)"]

recipient
Type: System.Net..::..IPEndPoint

[Missing <param name="recipient"/> documentation for "M:Lidgren.Network.NetPeer.SendUnconnectedMessage(Lidgren.Network.NetOutgoingMessage,System.Net.IPEndPoint)"]

See Also

NetPeer Class
SendUnconnectedMessage Overload


SendUnconnectedMessage Method (NetOutgoingMessage, String, Int32)

[image]

Lidgren Network Library documentation
NetPeer..::..SendUnconnectedMessage Method (NetOutgoingMessage, String, Int32)
NetPeer Class See Also Send Feedback
Send a message to an unconnected host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SendUnconnectedMessage(
    NetOutgoingMessage msg,
    string host,
    int port
)
Visual Basic
Public Sub SendUnconnectedMessage ( _
    msg As NetOutgoingMessage, _
    host As String, _
    port As Integer _
)
Visual C++
public:
void SendUnconnectedMessage(
    NetOutgoingMessage^ msg,
    String^ host,
    int port
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetPeer.SendUnconnectedMessage(Lidgren.Network.NetOutgoingMessage,System.String,System.Int32)"]

host
Type: System..::..String

[Missing <param name="host"/> documentation for "M:Lidgren.Network.NetPeer.SendUnconnectedMessage(Lidgren.Network.NetOutgoingMessage,System.String,System.Int32)"]

port
Type: System..::..Int32

[Missing <param name="port"/> documentation for "M:Lidgren.Network.NetPeer.SendUnconnectedMessage(Lidgren.Network.NetOutgoingMessage,System.String,System.Int32)"]

See Also

NetPeer Class
SendUnconnectedMessage Overload


Shutdown Method

[image]

Lidgren Network Library documentation
NetPeer..::..Shutdown Method
NetPeer Class See Also Send Feedback
Disconnects all active connections and closes the socket

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Shutdown(
    string bye
)
Visual Basic
Public Sub Shutdown ( _
    bye As String _
)
Visual C++
public:
void Shutdown(
    String^ bye
)

Parameters

bye
Type: System..::..String

[Missing <param name="bye"/> documentation for "M:Lidgren.Network.NetPeer.Shutdown(System.String)"]

See Also

NetPeer Class


Start Method

[image]

Lidgren Network Library documentation
NetPeer..::..Start Method
NetPeer Class See Also Send Feedback
Binds to socket and spawns the networking thread

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

See Also

NetPeer Class


WaitMessage Method

[image]

Lidgren Network Library documentation
NetPeer..::..WaitMessage Method
NetPeer Class See Also Send Feedback
Read a pending message from any connection, blocking up to maxMillis if needed

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetIncomingMessage WaitMessage(
    int maxMillis
)
Visual Basic
Public Function WaitMessage ( _
    maxMillis As Integer _
) As NetIncomingMessage
Visual C++
public:
NetIncomingMessage^ WaitMessage(
    int maxMillis
)

Parameters

maxMillis
Type: System..::..Int32

[Missing <param name="maxMillis"/> documentation for "M:Lidgren.Network.NetPeer.WaitMessage(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeer.WaitMessage(System.Int32)"]

See Also

NetPeer Class


NetPeer Properties

[image] [image]

Lidgren Network Library documentation
NetPeer Properties
NetPeer Class See Also Send Feedback

The NetPeer type exposes the following members.

Properties

 | Name | Description
Public property | Configuration | Gets the configuration used to instanciate this NetPeer
Public property | Connections | Gets a copy of the list of connections
Public property | ConnectionsCount | Gets the number of active connections
Public property | MessageReceivedEvent | Signalling event which can be waited on to determine when a message is queued for reading. Note that there is no guarantee that after the event is signaled the blocked thread will find the message in the queue. Other user created threads could be preempted and dequeue the message before the waiting thread wakes up.
Public property | Port | Gets the port number this NetPeer is listening and sending on, if Start() has been called
Public property | Socket | Gets the socket, if Start() has been called
Public property | Statistics | Statistics on this NetPeer since it was initialized
Public property | Status | Gets the NetPeerStatus of the NetPeer
Public property | Tag | Gets or sets the application defined object containing data about the peer
Public property | UniqueIdentifier | Gets a unique identifier for this NetPeer based on Mac address and ip/port. Note! Not available until Start() has been called!
Public property | UPnP | Returns an UPnP object if enabled in the NetPeerConfiguration

See Also

NetPeer Class


Configuration Property

[image]

Lidgren Network Library documentation
NetPeer..::..Configuration Property
NetPeer Class See Also Send Feedback
Gets the configuration used to instanciate this NetPeer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetPeerConfiguration Configuration { get; }
Visual Basic
Public ReadOnly Property Configuration As NetPeerConfiguration
    Get
Visual C++
public:
property NetPeerConfiguration^ Configuration {
    NetPeerConfiguration^ get ();
}

See Also

NetPeer Class


Connections Property

[image]

Lidgren Network Library documentation
NetPeer..::..Connections Property
NetPeer Class See Also Send Feedback
Gets a copy of the list of connections

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public List<NetConnection> Connections { get; }
Visual Basic
Public ReadOnly Property Connections As List(Of NetConnection)
    Get
Visual C++
public:
property List<NetConnection^>^ Connections {
    List<NetConnection^>^ get ();
}

See Also

NetPeer Class


ConnectionsCount Property

[image]

Lidgren Network Library documentation
NetPeer..::..ConnectionsCount Property
NetPeer Class See Also Send Feedback
Gets the number of active connections

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ConnectionsCount { get; }
Visual Basic
Public ReadOnly Property ConnectionsCount As Integer
    Get
Visual C++
public:
property int ConnectionsCount {
    int get ();
}

See Also

NetPeer Class


MessageReceivedEvent Property

[image]

Lidgren Network Library documentation
NetPeer..::..MessageReceivedEvent Property
NetPeer Class See Also Send Feedback
Signalling event which can be waited on to determine when a message is queued for reading. Note that there is no guarantee that after the event is signaled the blocked thread will find the message in the queue. Other user created threads could be preempted and dequeue the message before the waiting thread wakes up.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public AutoResetEvent MessageReceivedEvent { get; }
Visual Basic
Public ReadOnly Property MessageReceivedEvent As AutoResetEvent
    Get
Visual C++
public:
property AutoResetEvent^ MessageReceivedEvent {
    AutoResetEvent^ get ();
}

See Also

NetPeer Class


Port Property

[image]

Lidgren Network Library documentation
NetPeer..::..Port Property
NetPeer Class See Also Send Feedback
Gets the port number this NetPeer is listening and sending on, if Start() has been called

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int Port { get; }
Visual Basic
Public ReadOnly Property Port As Integer
    Get
Visual C++
public:
property int Port {
    int get ();
}

See Also

NetPeer Class


Socket Property

[image]

Lidgren Network Library documentation
NetPeer..::..Socket Property
NetPeer Class See Also Send Feedback
Gets the socket, if Start() has been called

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public Socket Socket { get; }
Visual Basic
Public ReadOnly Property Socket As Socket
    Get
Visual C++
public:
property Socket^ Socket {
    Socket^ get ();
}

See Also

NetPeer Class


Statistics Property

[image]

Lidgren Network Library documentation
NetPeer..::..Statistics Property
NetPeer Class See Also Send Feedback
Statistics on this NetPeer since it was initialized

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetPeerStatistics Statistics { get; }
Visual Basic
Public ReadOnly Property Statistics As NetPeerStatistics
    Get
Visual C++
public:
property NetPeerStatistics^ Statistics {
    NetPeerStatistics^ get ();
}

See Also

NetPeer Class


Status Property

[image]

Lidgren Network Library documentation
NetPeer..::..Status Property
NetPeer Class See Also Send Feedback
Gets the NetPeerStatus of the NetPeer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetPeerStatus Status { get; }
Visual Basic
Public ReadOnly Property Status As NetPeerStatus
    Get
Visual C++
public:
property NetPeerStatus Status {
    NetPeerStatus get ();
}

See Also

NetPeer Class


Tag Property

[image]

Lidgren Network Library documentation
NetPeer..::..Tag Property
NetPeer Class See Also Send Feedback
Gets or sets the application defined object containing data about the peer

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set
Visual C++
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

See Also

NetPeer Class


UniqueIdentifier Property

[image]

Lidgren Network Library documentation
NetPeer..::..UniqueIdentifier Property
NetPeer Class See Also Send Feedback
Gets a unique identifier for this NetPeer based on Mac address and ip/port. Note! Not available until Start() has been called!

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public long UniqueIdentifier { get; }
Visual Basic
Public ReadOnly Property UniqueIdentifier As Long
    Get
Visual C++
public:
property long long UniqueIdentifier {
    long long get ();
}

See Also

NetPeer Class


UPnP Property

[image]

Lidgren Network Library documentation
NetPeer..::..UPnP Property
NetPeer Class See Also Send Feedback
Returns an UPnP object if enabled in the NetPeerConfiguration

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetUPnP UPnP { get; }
Visual Basic
Public ReadOnly Property UPnP As NetUPnP
    Get
Visual C++
public:
property NetUPnP^ UPnP {
    NetUPnP^ get ();
}

See Also

NetPeer Class


NetPeerConfiguration Class

[image]

Lidgren Network Library documentation
NetPeerConfiguration Class
Members See Also Send Feedback
Partly immutable after NetPeer has been initialized

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public sealed class NetPeerConfiguration
Visual Basic
Public NotInheritable Class NetPeerConfiguration
Visual C++
public ref class NetPeerConfiguration sealed

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetPeerConfiguration

See Also

NetPeerConfiguration Members


NetPeerConfiguration Members

[image] [image]

Lidgren Network Library documentation
NetPeerConfiguration Members
NetPeerConfiguration Class Constructors Methods Properties See Also Send Feedback

The NetPeerConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | NetPeerConfiguration | NetPeerConfiguration constructor

Methods

 | Name | Description
Public method | Clone | Creates a memberwise shallow clone of this configuration
Public method | DisableMessageType | Disables receiving of the specified type of message
Public method | EnableMessageType | Enables receiving of the specified type of message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMessageTypeEnabled | Gets if receiving of the specified type of message is enabled
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMessageTypeEnabled | Enables or disables receiving of the specified type of message
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AcceptIncomingConnections | Gets or sets if the NetPeer should accept incoming connections. This is automatically set to true in NetServer and false in NetClient.
Public property | AppIdentifier | Gets the identifier of this application; the library can only connect to matching app identifier peers
Public property | AutoExpandMTU | Gets or sets if the NetPeer should send large messages to try to expand the maximum transmission unit size
Public property | ConnectionTimeout | Gets or sets the number of seconds timeout will be postponed on a successful ping/pong
Public property | DefaultOutgoingMessageCapacity | Gets or sets the default capacity in bytes when NetPeer.CreateMessage() is called without argument
Public property | EnableUPnP | Enables UPnP support; enabling port forwarding and getting external ip
Public property | ExpandMTUFailAttempts | Gets or sets the number of failed expand mtu attempts to perform before setting final MTU
Public property | ExpandMTUFrequency | Gets or sets how often to send large messages to expand MTU if AutoExpandMTU is enabled
Public property | LocalAddress | Gets or sets the local ip address to bind to. Defaults to IPAddress.Any. Cannot be changed once NetPeer is initialized.
Public property | MaximumConnections | Gets or sets the maximum amount of connections this peer can hold. Cannot be changed once NetPeer is initialized.
Public property | MaximumHandshakeAttempts | Gets or sets the maximum number of handshake attempts before failing to connect
Public property | MaximumTransmissionUnit | Gets or sets the maximum amount of bytes to send in a single packet, excluding ip, udp and lidgren headers
Public property | NetworkThreadName | Gets or sets the name of the library network thread. Cannot be changed once NetPeer is initialized.
Public property | PingInterval | Gets or sets the time between latency calculating pings
Public property | Port | Gets or sets the local port to bind to. Defaults to 0. Cannot be changed once NetPeer is initialized.
Public property | ReceiveBufferSize | Gets or sets the size in bytes of the receiving buffer. Defaults to 131071 bytes. Cannot be changed once NetPeer is initialized.
Public property | ResendHandshakeInterval | Gets or sets the number of seconds between handshake attempts
Public property | SendBufferSize | Gets or sets the size in bytes of the sending buffer. Defaults to 131071 bytes. Cannot be changed once NetPeer is initialized.
Public property | UseMessageRecycling | Gets or sets if the library should recycling messages to avoid excessive garbage collection. Cannot be changed once NetPeer is initialized.

See Also

NetPeerConfiguration Class


NetPeerConfiguration Constructor

[image]

Lidgren Network Library documentation
NetPeerConfiguration Constructor
NetPeerConfiguration Class See Also Send Feedback
NetPeerConfiguration constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetPeerConfiguration(
    string appIdentifier
)
Visual Basic
Public Sub New ( _
    appIdentifier As String _
)
Visual C++
public:
NetPeerConfiguration(
    String^ appIdentifier
)

Parameters

appIdentifier
Type: System..::..String

[Missing <param name="appIdentifier"/> documentation for "M:Lidgren.Network.NetPeerConfiguration.#ctor(System.String)"]

See Also

NetPeerConfiguration Class


NetPeerConfiguration Methods

[image] [image]

Lidgren Network Library documentation
NetPeerConfiguration Methods
NetPeerConfiguration Class See Also Send Feedback

The NetPeerConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a memberwise shallow clone of this configuration
Public method | DisableMessageType | Disables receiving of the specified type of message
Public method | EnableMessageType | Enables receiving of the specified type of message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMessageTypeEnabled | Gets if receiving of the specified type of message is enabled
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetMessageTypeEnabled | Enables or disables receiving of the specified type of message
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetPeerConfiguration Class


Clone Method

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..Clone Method
NetPeerConfiguration Class See Also Send Feedback
Creates a memberwise shallow clone of this configuration

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetPeerConfiguration Clone()
Visual Basic
Public Function Clone As NetPeerConfiguration
Visual C++
public:
NetPeerConfiguration^ Clone()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeerConfiguration.Clone"]

See Also

NetPeerConfiguration Class


DisableMessageType Method

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..DisableMessageType Method
NetPeerConfiguration Class See Also Send Feedback
Disables receiving of the specified type of message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void DisableMessageType(
    NetIncomingMessageType type
)
Visual Basic
Public Sub DisableMessageType ( _
    type As NetIncomingMessageType _
)
Visual C++
public:
void DisableMessageType(
    NetIncomingMessageType type
)

Parameters

type
Type: Lidgren.Network..::..NetIncomingMessageType

[Missing <param name="type"/> documentation for "M:Lidgren.Network.NetPeerConfiguration.DisableMessageType(Lidgren.Network.NetIncomingMessageType)"]

See Also

NetPeerConfiguration Class


EnableMessageType Method

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..EnableMessageType Method
NetPeerConfiguration Class See Also Send Feedback
Enables receiving of the specified type of message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void EnableMessageType(
    NetIncomingMessageType type
)
Visual Basic
Public Sub EnableMessageType ( _
    type As NetIncomingMessageType _
)
Visual C++
public:
void EnableMessageType(
    NetIncomingMessageType type
)

Parameters

type
Type: Lidgren.Network..::..NetIncomingMessageType

[Missing <param name="type"/> documentation for "M:Lidgren.Network.NetPeerConfiguration.EnableMessageType(Lidgren.Network.NetIncomingMessageType)"]

See Also

NetPeerConfiguration Class


IsMessageTypeEnabled Method

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..IsMessageTypeEnabled Method
NetPeerConfiguration Class See Also Send Feedback
Gets if receiving of the specified type of message is enabled

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool IsMessageTypeEnabled(
    NetIncomingMessageType type
)
Visual Basic
Public Function IsMessageTypeEnabled ( _
    type As NetIncomingMessageType _
) As Boolean
Visual C++
public:
bool IsMessageTypeEnabled(
    NetIncomingMessageType type
)

Parameters

type
Type: Lidgren.Network..::..NetIncomingMessageType

[Missing <param name="type"/> documentation for "M:Lidgren.Network.NetPeerConfiguration.IsMessageTypeEnabled(Lidgren.Network.NetIncomingMessageType)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeerConfiguration.IsMessageTypeEnabled(Lidgren.Network.NetIncomingMessageType)"]

See Also

NetPeerConfiguration Class


SetMessageTypeEnabled Method

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..SetMessageTypeEnabled Method
NetPeerConfiguration Class See Also Send Feedback
Enables or disables receiving of the specified type of message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SetMessageTypeEnabled(
    NetIncomingMessageType type,
    bool enabled
)
Visual Basic
Public Sub SetMessageTypeEnabled ( _
    type As NetIncomingMessageType, _
    enabled As Boolean _
)
Visual C++
public:
void SetMessageTypeEnabled(
    NetIncomingMessageType type,
    bool enabled
)

Parameters

type
Type: Lidgren.Network..::..NetIncomingMessageType

[Missing <param name="type"/> documentation for "M:Lidgren.Network.NetPeerConfiguration.SetMessageTypeEnabled(Lidgren.Network.NetIncomingMessageType,System.Boolean)"]

enabled
Type: System..::..Boolean

[Missing <param name="enabled"/> documentation for "M:Lidgren.Network.NetPeerConfiguration.SetMessageTypeEnabled(Lidgren.Network.NetIncomingMessageType,System.Boolean)"]

See Also

NetPeerConfiguration Class


NetPeerConfiguration Properties

[image] [image]

Lidgren Network Library documentation
NetPeerConfiguration Properties
NetPeerConfiguration Class See Also Send Feedback

The NetPeerConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AcceptIncomingConnections | Gets or sets if the NetPeer should accept incoming connections. This is automatically set to true in NetServer and false in NetClient.
Public property | AppIdentifier | Gets the identifier of this application; the library can only connect to matching app identifier peers
Public property | AutoExpandMTU | Gets or sets if the NetPeer should send large messages to try to expand the maximum transmission unit size
Public property | ConnectionTimeout | Gets or sets the number of seconds timeout will be postponed on a successful ping/pong
Public property | DefaultOutgoingMessageCapacity | Gets or sets the default capacity in bytes when NetPeer.CreateMessage() is called without argument
Public property | EnableUPnP | Enables UPnP support; enabling port forwarding and getting external ip
Public property | ExpandMTUFailAttempts | Gets or sets the number of failed expand mtu attempts to perform before setting final MTU
Public property | ExpandMTUFrequency | Gets or sets how often to send large messages to expand MTU if AutoExpandMTU is enabled
Public property | LocalAddress | Gets or sets the local ip address to bind to. Defaults to IPAddress.Any. Cannot be changed once NetPeer is initialized.
Public property | MaximumConnections | Gets or sets the maximum amount of connections this peer can hold. Cannot be changed once NetPeer is initialized.
Public property | MaximumHandshakeAttempts | Gets or sets the maximum number of handshake attempts before failing to connect
Public property | MaximumTransmissionUnit | Gets or sets the maximum amount of bytes to send in a single packet, excluding ip, udp and lidgren headers
Public property | NetworkThreadName | Gets or sets the name of the library network thread. Cannot be changed once NetPeer is initialized.
Public property | PingInterval | Gets or sets the time between latency calculating pings
Public property | Port | Gets or sets the local port to bind to. Defaults to 0. Cannot be changed once NetPeer is initialized.
Public property | ReceiveBufferSize | Gets or sets the size in bytes of the receiving buffer. Defaults to 131071 bytes. Cannot be changed once NetPeer is initialized.
Public property | ResendHandshakeInterval | Gets or sets the number of seconds between handshake attempts
Public property | SendBufferSize | Gets or sets the size in bytes of the sending buffer. Defaults to 131071 bytes. Cannot be changed once NetPeer is initialized.
Public property | UseMessageRecycling | Gets or sets if the library should recycling messages to avoid excessive garbage collection. Cannot be changed once NetPeer is initialized.

See Also

NetPeerConfiguration Class


AcceptIncomingConnections Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..AcceptIncomingConnections Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets if the NetPeer should accept incoming connections. This is automatically set to true in NetServer and false in NetClient.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool AcceptIncomingConnections { get; set; }
Visual Basic
Public Property AcceptIncomingConnections As Boolean
    Get
    Set
Visual C++
public:
property bool AcceptIncomingConnections {
    bool get ();
    void set (bool value);
}

See Also

NetPeerConfiguration Class


AppIdentifier Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..AppIdentifier Property
NetPeerConfiguration Class See Also Send Feedback
Gets the identifier of this application; the library can only connect to matching app identifier peers

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public string AppIdentifier { get; }
Visual Basic
Public ReadOnly Property AppIdentifier As String
    Get
Visual C++
public:
property String^ AppIdentifier {
    String^ get ();
}

See Also

NetPeerConfiguration Class


AutoExpandMTU Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..AutoExpandMTU Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets if the NetPeer should send large messages to try to expand the maximum transmission unit size

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool AutoExpandMTU { get; set; }
Visual Basic
Public Property AutoExpandMTU As Boolean
    Get
    Set
Visual C++
public:
property bool AutoExpandMTU {
    bool get ();
    void set (bool value);
}

See Also

NetPeerConfiguration Class


ConnectionTimeout Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..ConnectionTimeout Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the number of seconds timeout will be postponed on a successful ping/pong

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float ConnectionTimeout { get; set; }
Visual Basic
Public Property ConnectionTimeout As Single
    Get
    Set
Visual C++
public:
property float ConnectionTimeout {
    float get ();
    void set (float value);
}

See Also

NetPeerConfiguration Class


DefaultOutgoingMessageCapacity Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..DefaultOutgoingMessageCapacity Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the default capacity in bytes when NetPeer.CreateMessage() is called without argument

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int DefaultOutgoingMessageCapacity { get; set; }
Visual Basic
Public Property DefaultOutgoingMessageCapacity As Integer
    Get
    Set
Visual C++
public:
property int DefaultOutgoingMessageCapacity {
    int get ();
    void set (int value);
}

See Also

NetPeerConfiguration Class


EnableUPnP Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..EnableUPnP Property
NetPeerConfiguration Class See Also Send Feedback
Enables UPnP support; enabling port forwarding and getting external ip

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool EnableUPnP { get; set; }
Visual Basic
Public Property EnableUPnP As Boolean
    Get
    Set
Visual C++
public:
property bool EnableUPnP {
    bool get ();
    void set (bool value);
}

See Also

NetPeerConfiguration Class


ExpandMTUFailAttempts Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..ExpandMTUFailAttempts Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the number of failed expand mtu attempts to perform before setting final MTU

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ExpandMTUFailAttempts { get; set; }
Visual Basic
Public Property ExpandMTUFailAttempts As Integer
    Get
    Set
Visual C++
public:
property int ExpandMTUFailAttempts {
    int get ();
    void set (int value);
}

See Also

NetPeerConfiguration Class


ExpandMTUFrequency Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..ExpandMTUFrequency Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets how often to send large messages to expand MTU if AutoExpandMTU is enabled

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float ExpandMTUFrequency { get; set; }
Visual Basic
Public Property ExpandMTUFrequency As Single
    Get
    Set
Visual C++
public:
property float ExpandMTUFrequency {
    float get ();
    void set (float value);
}

See Also

NetPeerConfiguration Class


LocalAddress Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..LocalAddress Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the local ip address to bind to. Defaults to IPAddress.Any. Cannot be changed once NetPeer is initialized.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public IPAddress LocalAddress { get; set; }
Visual Basic
Public Property LocalAddress As IPAddress
    Get
    Set
Visual C++
public:
property IPAddress^ LocalAddress {
    IPAddress^ get ();
    void set (IPAddress^ value);
}

See Also

NetPeerConfiguration Class


MaximumConnections Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..MaximumConnections Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the maximum amount of connections this peer can hold. Cannot be changed once NetPeer is initialized.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int MaximumConnections { get; set; }
Visual Basic
Public Property MaximumConnections As Integer
    Get
    Set
Visual C++
public:
property int MaximumConnections {
    int get ();
    void set (int value);
}

See Also

NetPeerConfiguration Class


MaximumHandshakeAttempts Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..MaximumHandshakeAttempts Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the maximum number of handshake attempts before failing to connect

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int MaximumHandshakeAttempts { get; set; }
Visual Basic
Public Property MaximumHandshakeAttempts As Integer
    Get
    Set
Visual C++
public:
property int MaximumHandshakeAttempts {
    int get ();
    void set (int value);
}

See Also

NetPeerConfiguration Class


MaximumTransmissionUnit Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..MaximumTransmissionUnit Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the maximum amount of bytes to send in a single packet, excluding ip, udp and lidgren headers

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int MaximumTransmissionUnit { get; set; }
Visual Basic
Public Property MaximumTransmissionUnit As Integer
    Get
    Set
Visual C++
public:
property int MaximumTransmissionUnit {
    int get ();
    void set (int value);
}

See Also

NetPeerConfiguration Class


NetworkThreadName Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..NetworkThreadName Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the name of the library network thread. Cannot be changed once NetPeer is initialized.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public string NetworkThreadName { get; set; }
Visual Basic
Public Property NetworkThreadName As String
    Get
    Set
Visual C++
public:
property String^ NetworkThreadName {
    String^ get ();
    void set (String^ value);
}

See Also

NetPeerConfiguration Class


PingInterval Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..PingInterval Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the time between latency calculating pings

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float PingInterval { get; set; }
Visual Basic
Public Property PingInterval As Single
    Get
    Set
Visual C++
public:
property float PingInterval {
    float get ();
    void set (float value);
}

See Also

NetPeerConfiguration Class


Port Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..Port Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the local port to bind to. Defaults to 0. Cannot be changed once NetPeer is initialized.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int Port { get; set; }
Visual Basic
Public Property Port As Integer
    Get
    Set
Visual C++
public:
property int Port {
    int get ();
    void set (int value);
}

See Also

NetPeerConfiguration Class


ReceiveBufferSize Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..ReceiveBufferSize Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the size in bytes of the receiving buffer. Defaults to 131071 bytes. Cannot be changed once NetPeer is initialized.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReceiveBufferSize { get; set; }
Visual Basic
Public Property ReceiveBufferSize As Integer
    Get
    Set
Visual C++
public:
property int ReceiveBufferSize {
    int get ();
    void set (int value);
}

See Also

NetPeerConfiguration Class


ResendHandshakeInterval Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..ResendHandshakeInterval Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the number of seconds between handshake attempts

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float ResendHandshakeInterval { get; set; }
Visual Basic
Public Property ResendHandshakeInterval As Single
    Get
    Set
Visual C++
public:
property float ResendHandshakeInterval {
    float get ();
    void set (float value);
}

See Also

NetPeerConfiguration Class


SendBufferSize Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..SendBufferSize Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets the size in bytes of the sending buffer. Defaults to 131071 bytes. Cannot be changed once NetPeer is initialized.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int SendBufferSize { get; set; }
Visual Basic
Public Property SendBufferSize As Integer
    Get
    Set
Visual C++
public:
property int SendBufferSize {
    int get ();
    void set (int value);
}

See Also

NetPeerConfiguration Class


UseMessageRecycling Property

[image]

Lidgren Network Library documentation
NetPeerConfiguration..::..UseMessageRecycling Property
NetPeerConfiguration Class See Also Send Feedback
Gets or sets if the library should recycling messages to avoid excessive garbage collection. Cannot be changed once NetPeer is initialized.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool UseMessageRecycling { get; set; }
Visual Basic
Public Property UseMessageRecycling As Boolean
    Get
    Set
Visual C++
public:
property bool UseMessageRecycling {
    bool get ();
    void set (bool value);
}

See Also

NetPeerConfiguration Class


NetPeerStatistics Class

[image]

Lidgren Network Library documentation
NetPeerStatistics Class
Members See Also Send Feedback
Statistics for a NetPeer instance

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public sealed class NetPeerStatistics
Visual Basic
Public NotInheritable Class NetPeerStatistics
Visual C++
public ref class NetPeerStatistics sealed

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetPeerStatistics

See Also

NetPeerStatistics Members


NetPeerStatistics Members

[image] [image]

Lidgren Network Library documentation
NetPeerStatistics Members
NetPeerStatistics Class Methods Properties See Also Send Feedback

The NetPeerStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | BytesInRecyclePool | Gets the number of bytes in the recycled pool
Public property | ReceivedBytes | Gets the number of received bytes since the NetPeer was initialized
Public property | ReceivedMessages | Gets the number of received messages since the NetPeer was initialized
Public property | ReceivedPackets | Gets the number of received packets since the NetPeer was initialized
Public property | SentBytes | Gets the number of sent bytes since the NetPeer was initialized
Public property | SentMessages | Gets the number of sent messages since the NetPeer was initialized
Public property | SentPackets | Gets the number of sent packets since the NetPeer was initialized
Public property | StorageBytesAllocated | Gets the number of bytes allocated (and possibly garbage collected) for message storage

See Also

NetPeerStatistics Class


NetPeerStatistics Methods

[image] [image]

Lidgren Network Library documentation
NetPeerStatistics Methods
NetPeerStatistics Class See Also Send Feedback

The NetPeerStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)

See Also

NetPeerStatistics Class


ToString Method

[image]

Lidgren Network Library documentation
NetPeerStatistics..::..ToString Method
NetPeerStatistics Class See Also Send Feedback
Returns a string that represents this object

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetPeerStatistics.ToString"]

See Also

NetPeerStatistics Class


NetPeerStatistics Properties

[image] [image]

Lidgren Network Library documentation
NetPeerStatistics Properties
NetPeerStatistics Class See Also Send Feedback

The NetPeerStatistics type exposes the following members.

Properties

 | Name | Description
Public property | BytesInRecyclePool | Gets the number of bytes in the recycled pool
Public property | ReceivedBytes | Gets the number of received bytes since the NetPeer was initialized
Public property | ReceivedMessages | Gets the number of received messages since the NetPeer was initialized
Public property | ReceivedPackets | Gets the number of received packets since the NetPeer was initialized
Public property | SentBytes | Gets the number of sent bytes since the NetPeer was initialized
Public property | SentMessages | Gets the number of sent messages since the NetPeer was initialized
Public property | SentPackets | Gets the number of sent packets since the NetPeer was initialized
Public property | StorageBytesAllocated | Gets the number of bytes allocated (and possibly garbage collected) for message storage

See Also

NetPeerStatistics Class


BytesInRecyclePool Property

[image]

Lidgren Network Library documentation
NetPeerStatistics..::..BytesInRecyclePool Property
NetPeerStatistics Class See Also Send Feedback
Gets the number of bytes in the recycled pool

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int BytesInRecyclePool { get; }
Visual Basic
Public ReadOnly Property BytesInRecyclePool As Integer
    Get
Visual C++
public:
property int BytesInRecyclePool {
    int get ();
}

See Also

NetPeerStatistics Class


ReceivedBytes Property

[image]

Lidgren Network Library documentation
NetPeerStatistics..::..ReceivedBytes Property
NetPeerStatistics Class See Also Send Feedback
Gets the number of received bytes since the NetPeer was initialized

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReceivedBytes { get; }
Visual Basic
Public ReadOnly Property ReceivedBytes As Integer
    Get
Visual C++
public:
property int ReceivedBytes {
    int get ();
}

See Also

NetPeerStatistics Class


ReceivedMessages Property

[image]

Lidgren Network Library documentation
NetPeerStatistics..::..ReceivedMessages Property
NetPeerStatistics Class See Also Send Feedback
Gets the number of received messages since the NetPeer was initialized

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReceivedMessages { get; }
Visual Basic
Public ReadOnly Property ReceivedMessages As Integer
    Get
Visual C++
public:
property int ReceivedMessages {
    int get ();
}

See Also

NetPeerStatistics Class


ReceivedPackets Property

[image]

Lidgren Network Library documentation
NetPeerStatistics..::..ReceivedPackets Property
NetPeerStatistics Class See Also Send Feedback
Gets the number of received packets since the NetPeer was initialized

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int ReceivedPackets { get; }
Visual Basic
Public ReadOnly Property ReceivedPackets As Integer
    Get
Visual C++
public:
property int ReceivedPackets {
    int get ();
}

See Also

NetPeerStatistics Class


SentBytes Property

[image]

Lidgren Network Library documentation
NetPeerStatistics..::..SentBytes Property
NetPeerStatistics Class See Also Send Feedback
Gets the number of sent bytes since the NetPeer was initialized

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int SentBytes { get; }
Visual Basic
Public ReadOnly Property SentBytes As Integer
    Get
Visual C++
public:
property int SentBytes {
    int get ();
}

See Also

NetPeerStatistics Class


SentMessages Property

[image]

Lidgren Network Library documentation
NetPeerStatistics..::..SentMessages Property
NetPeerStatistics Class See Also Send Feedback
Gets the number of sent messages since the NetPeer was initialized

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int SentMessages { get; }
Visual Basic
Public ReadOnly Property SentMessages As Integer
    Get
Visual C++
public:
property int SentMessages {
    int get ();
}

See Also

NetPeerStatistics Class


SentPackets Property

[image]

Lidgren Network Library documentation
NetPeerStatistics..::..SentPackets Property
NetPeerStatistics Class See Also Send Feedback
Gets the number of sent packets since the NetPeer was initialized

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int SentPackets { get; }
Visual Basic
Public ReadOnly Property SentPackets As Integer
    Get
Visual C++
public:
property int SentPackets {
    int get ();
}

See Also

NetPeerStatistics Class


StorageBytesAllocated Property

[image]

Lidgren Network Library documentation
NetPeerStatistics..::..StorageBytesAllocated Property
NetPeerStatistics Class See Also Send Feedback
Gets the number of bytes allocated (and possibly garbage collected) for message storage

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public long StorageBytesAllocated { get; }
Visual Basic
Public ReadOnly Property StorageBytesAllocated As Long
    Get
Visual C++
public:
property long long StorageBytesAllocated {
    long long get ();
}

See Also

NetPeerStatistics Class


NetPeerStatus Enumeration

[image]

Lidgren Network Library documentation
NetPeerStatus Enumeration
See Also Send Feedback
Status for a NetPeer instance

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public enum NetPeerStatus
Visual Basic
Public Enumeration NetPeerStatus
Visual C++
public enum class NetPeerStatus

Members

Member name | Description
NotRunning |
Starting |
Running |
ShutdownRequested |

See Also

Lidgren.Network Namespace


NetQueue(T) Class

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Thread safe (blocking) expanding queue with TryDequeue() and EnqueueFirst()

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public sealed class NetQueue<T>
Visual Basic
Public NotInheritable Class NetQueue(Of T)
Visual C++
generic<typename T>
public ref class NetQueue sealed

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Lidgren.Network.NetQueue`1"]

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetQueue<(Of <(<'T>)>)>

See Also

NetQueue<(Of <(<'T>)>)> Members


NetQueue(T) Members

[image] [image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)> Members
NetQueue<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The NetQueue<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | NetQueue<(Of <(<'T>)>)> | NetQueue constructor

Methods

 | Name | Description
Public method | Clear | Removes all objects from the queue
Public method | Contains | Determines whether an item is in the queue
Public method | Enqueue | Adds an item last/tail of the queue
Public method | EnqueueFirst | Places an item first, at the head of the queue
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Copies the queue items to a new array
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryDequeue | Gets an item from the head of the queue, or returns default(T) if empty
Public method | TryPeek | Returns default(T) if queue is empty

Properties

 | Name | Description
Public property | Capacity | Gets the current capacity for the queue
Public property | Count | Gets the number of items in the queue

See Also

NetQueue<(Of <(<'T>)>)> Class


NetQueue(T) Constructor

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)> Constructor
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
NetQueue constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetQueue(
    int initialCapacity
)
Visual Basic
Public Sub New ( _
    initialCapacity As Integer _
)
Visual C++
public:
NetQueue(
    int initialCapacity
)

Parameters

initialCapacity
Type: System..::..Int32

[Missing <param name="initialCapacity"/> documentation for "M:Lidgren.Network.NetQueue`1.#ctor(System.Int32)"]

See Also

NetQueue<(Of <(<'T>)>)> Class


NetQueue(T) Methods

[image] [image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)> Methods
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback

The NetQueue<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes all objects from the queue
Public method | Contains | Determines whether an item is in the queue
Public method | Enqueue | Adds an item last/tail of the queue
Public method | EnqueueFirst | Places an item first, at the head of the queue
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToArray | Copies the queue items to a new array
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryDequeue | Gets an item from the head of the queue, or returns default(T) if empty
Public method | TryPeek | Returns default(T) if queue is empty

See Also

NetQueue<(Of <(<'T>)>)> Class


Clear Method

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)>..::..Clear Method
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
Removes all objects from the queue

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

NetQueue<(Of <(<'T>)>)> Class


Contains Method

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)>..::..Contains Method
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
Determines whether an item is in the queue

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Contains(
    T item
)
Visual Basic
Public Function Contains ( _
    item As T _
) As Boolean
Visual C++
public:
bool Contains(
    T item
)

Parameters

item
Type: T

[Missing <param name="item"/> documentation for "M:Lidgren.Network.NetQueue`1.Contains(`0)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetQueue`1.Contains(`0)"]

See Also

NetQueue<(Of <(<'T>)>)> Class


Enqueue Method

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)>..::..Enqueue Method
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
Adds an item last/tail of the queue

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Enqueue(
    T item
)
Visual Basic
Public Sub Enqueue ( _
    item As T _
)
Visual C++
public:
void Enqueue(
    T item
)

Parameters

item
Type: T

[Missing <param name="item"/> documentation for "M:Lidgren.Network.NetQueue`1.Enqueue(`0)"]

See Also

NetQueue<(Of <(<'T>)>)> Class


EnqueueFirst Method

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)>..::..EnqueueFirst Method
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
Places an item first, at the head of the queue

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void EnqueueFirst(
    T item
)
Visual Basic
Public Sub EnqueueFirst ( _
    item As T _
)
Visual C++
public:
void EnqueueFirst(
    T item
)

Parameters

item
Type: T

[Missing <param name="item"/> documentation for "M:Lidgren.Network.NetQueue`1.EnqueueFirst(`0)"]

See Also

NetQueue<(Of <(<'T>)>)> Class


ToArray Method

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)>..::..ToArray Method
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
Copies the queue items to a new array

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public T[] ToArray()
Visual Basic
Public Function ToArray As T()
Visual C++
public:
array<T>^ ToArray()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetQueue`1.ToArray"]

See Also

NetQueue<(Of <(<'T>)>)> Class


TryDequeue Method

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)>..::..TryDequeue Method
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
Gets an item from the head of the queue, or returns default(T) if empty

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool TryDequeue(
    out T item
)
Visual Basic
Public Function TryDequeue ( _
    <OutAttribute> ByRef item As T _
) As Boolean
Visual C++
public:
bool TryDequeue(
    [OutAttribute] T% item
)

Parameters

item
Type: T %

[Missing <param name="item"/> documentation for "M:Lidgren.Network.NetQueue`1.TryDequeue(`0@)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetQueue`1.TryDequeue(`0@)"]

See Also

NetQueue<(Of <(<'T>)>)> Class


TryPeek Method

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)>..::..TryPeek Method
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
Returns default(T) if queue is empty

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public T TryPeek(
    int offset
)
Visual Basic
Public Function TryPeek ( _
    offset As Integer _
) As T
Visual C++
public:
T TryPeek(
    int offset
)

Parameters

offset
Type: System..::..Int32

[Missing <param name="offset"/> documentation for "M:Lidgren.Network.NetQueue`1.TryPeek(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetQueue`1.TryPeek(System.Int32)"]

See Also

NetQueue<(Of <(<'T>)>)> Class


NetQueue(T) Properties

[image] [image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)> Properties
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback

The NetQueue<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets the current capacity for the queue
Public property | Count | Gets the number of items in the queue

See Also

NetQueue<(Of <(<'T>)>)> Class


Capacity Property

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)>..::..Capacity Property
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the current capacity for the queue

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int Capacity { get; }
Visual Basic
Public ReadOnly Property Capacity As Integer
    Get
Visual C++
public:
property int Capacity {
    int get ();
}

See Also

NetQueue<(Of <(<'T>)>)> Class


Count Property

[image]

Lidgren Network Library documentation
NetQueue<(Of <(<'T>)>)>..::..Count Property
NetQueue<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the number of items in the queue

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

NetQueue<(Of <(<'T>)>)> Class


NetRandom Class

[image]

Lidgren Network Library documentation
NetRandom Class
Members See Also Send Feedback
A fast random number generator for .NET Colin Green, January 2005

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetRandom
Visual Basic
Public Class NetRandom
Visual C++
public ref class NetRandom

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetRandom

See Also

NetRandom Members


NetRandom Members

[image] [image]

Lidgren Network Library documentation
NetRandom Members
NetRandom Class Constructors Methods Fields See Also Send Feedback

The NetRandom type exposes the following members.

Constructors

 | Name | Description
Public method | NetRandom()()()() | Initialises a new instance using time dependent seed.
Public method | NetRandom(Int32) | Initialises a new instance using an int value as seed. This constructor signature is provided to maintain compatibility with System.Random

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeed | Create a semi-random seed based on an object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next()()()() | Generates a random int over the range 0 to int.MaxValue-1. MaxValue is not generated in order to remain functionally equivalent to System.Random.Next(). This does slightly eat into some of the performance gain over System.Random, but not much. For better performance see: Call NextInt() for an int over the range 0 to int.MaxValue. Call NextUInt() and cast the result to an int to generate an int over the full Int32 value range including negative values.
Public method | Next(Int32) | Generates a random int over the range 0 to upperBound-1, and not including upperBound.
Public method | Next(Int32, Int32) | Generates a random int over the range lowerBound to upperBound-1, and not including upperBound. upperBound must be >= lowerBound. lowerBound may be negative.
Public method | NextBool | Generates a single random bit. This method's performance is improved by generating 32 bits in one operation and storing them ready for future calls.
Public method | NextBytes | Fills the provided byte array with random bytes. This method is functionally equivalent to System.Random.NextBytes().
Public method | NextDouble | Generates a random double. Values returned are from 0.0 up to but not including 1.0.
Public method | NextInt | Generates a random int over the range 0 to int.MaxValue, inclusive. This method differs from Next() only in that the range is 0 to int.MaxValue and not 0 to int.MaxValue-1. The slight difference in range means this method is slightly faster than Next() but is not functionally equivalent to System.Random.Next().
Public method | NextSingle | Generates a random single. Values returned are from 0.0 up to but not including 1.0.
Public method | NextUInt | Generates a uint. Values returned are over the full range of a uint, uint.MinValue to uint.MaxValue, inclusive. This is the fastest method for generating a single random number because the underlying random number generator algorithm generates 32 random bits that can be cast directly to a uint.
Public method | Reinitialise | Reinitialises using an int value as a seed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Instance | Gets a global NetRandom instance

See Also

NetRandom Class


NetRandom Constructor

[image] [image]

Lidgren Network Library documentation
NetRandom Constructor
NetRandom Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NetRandom()()()() | Initialises a new instance using time dependent seed.
Public method | NetRandom(Int32) | Initialises a new instance using an int value as seed. This constructor signature is provided to maintain compatibility with System.Random

See Also

NetRandom Class
NetRandom Members


NetRandom Constructor

[image]

Lidgren Network Library documentation
NetRandom Constructor
NetRandom Class See Also Send Feedback
Initialises a new instance using time dependent seed.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetRandom()
Visual Basic
Public Sub New
Visual C++
public:
NetRandom()

See Also

NetRandom Class
NetRandom Overload


NetRandom Constructor (Int32)

[image]

Lidgren Network Library documentation
NetRandom Constructor (Int32)
NetRandom Class See Also Send Feedback
Initialises a new instance using an int value as seed. This constructor signature is provided to maintain compatibility with System.Random

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetRandom(
    int seed
)
Visual Basic
Public Sub New ( _
    seed As Integer _
)
Visual C++
public:
NetRandom(
    int seed
)

Parameters

seed
Type: System..::..Int32

[Missing <param name="seed"/> documentation for "M:Lidgren.Network.NetRandom.#ctor(System.Int32)"]

See Also

NetRandom Class
NetRandom Overload


NetRandom Fields

[image] [image]

Lidgren Network Library documentation
NetRandom Fields
NetRandom Class See Also Send Feedback

The NetRandom type exposes the following members.

Fields

Name | Description
Instance | Gets a global NetRandom instance

See Also

NetRandom Class


Instance Field

[image]

Lidgren Network Library documentation
NetRandom..::..Instance Field
NetRandom Class See Also Send Feedback
Gets a global NetRandom instance

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static readonly NetRandom Instance
Visual Basic
Public Shared ReadOnly Instance As NetRandom
Visual C++
public:
static initonly NetRandom^ Instance

See Also

NetRandom Class


NetRandom Methods

[image] [image]

Lidgren Network Library documentation
NetRandom Methods
NetRandom Class See Also Send Feedback

The NetRandom type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeed | Create a semi-random seed based on an object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next()()()() | Generates a random int over the range 0 to int.MaxValue-1. MaxValue is not generated in order to remain functionally equivalent to System.Random.Next(). This does slightly eat into some of the performance gain over System.Random, but not much. For better performance see: Call NextInt() for an int over the range 0 to int.MaxValue. Call NextUInt() and cast the result to an int to generate an int over the full Int32 value range including negative values.
Public method | Next(Int32) | Generates a random int over the range 0 to upperBound-1, and not including upperBound.
Public method | Next(Int32, Int32) | Generates a random int over the range lowerBound to upperBound-1, and not including upperBound. upperBound must be >= lowerBound. lowerBound may be negative.
Public method | NextBool | Generates a single random bit. This method's performance is improved by generating 32 bits in one operation and storing them ready for future calls.
Public method | NextBytes | Fills the provided byte array with random bytes. This method is functionally equivalent to System.Random.NextBytes().
Public method | NextDouble | Generates a random double. Values returned are from 0.0 up to but not including 1.0.
Public method | NextInt | Generates a random int over the range 0 to int.MaxValue, inclusive. This method differs from Next() only in that the range is 0 to int.MaxValue and not 0 to int.MaxValue-1. The slight difference in range means this method is slightly faster than Next() but is not functionally equivalent to System.Random.Next().
Public method | NextSingle | Generates a random single. Values returned are from 0.0 up to but not including 1.0.
Public method | NextUInt | Generates a uint. Values returned are over the full range of a uint, uint.MinValue to uint.MaxValue, inclusive. This is the fastest method for generating a single random number because the underlying random number generator algorithm generates 32 random bits that can be cast directly to a uint.
Public method | Reinitialise | Reinitialises using an int value as a seed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetRandom Class


GetSeed Method

[image]

Lidgren Network Library documentation
NetRandom..::..GetSeed Method
NetRandom Class See Also Send Feedback
Create a semi-random seed based on an object

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int GetSeed(
    Object forObject
)
Visual Basic
Public Function GetSeed ( _
    forObject As Object _
) As Integer
Visual C++
public:
int GetSeed(
    Object^ forObject
)

Parameters

forObject
Type: System..::..Object

[Missing <param name="forObject"/> documentation for "M:Lidgren.Network.NetRandom.GetSeed(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRandom.GetSeed(System.Object)"]

See Also

NetRandom Class


Next Method

[image] [image]

Lidgren Network Library documentation
NetRandom..::..Next Method
NetRandom Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Next()()()() | Generates a random int over the range 0 to int.MaxValue-1. MaxValue is not generated in order to remain functionally equivalent to System.Random.Next(). This does slightly eat into some of the performance gain over System.Random, but not much. For better performance see: Call NextInt() for an int over the range 0 to int.MaxValue. Call NextUInt() and cast the result to an int to generate an int over the full Int32 value range including negative values.
Public method | Next(Int32) | Generates a random int over the range 0 to upperBound-1, and not including upperBound.
Public method | Next(Int32, Int32) | Generates a random int over the range lowerBound to upperBound-1, and not including upperBound. upperBound must be >= lowerBound. lowerBound may be negative.

See Also

NetRandom Class
NetRandom Members


Next Method

[image]

Lidgren Network Library documentation
NetRandom..::..Next Method
NetRandom Class See Also Send Feedback
Generates a random int over the range 0 to int.MaxValue-1. MaxValue is not generated in order to remain functionally equivalent to System.Random.Next(). This does slightly eat into some of the performance gain over System.Random, but not much. For better performance see: Call NextInt() for an int over the range 0 to int.MaxValue. Call NextUInt() and cast the result to an int to generate an int over the full Int32 value range including negative values.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int Next()
Visual Basic
Public Function Next As Integer
Visual C++
public:
int Next()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRandom.Next"]

See Also

NetRandom Class
Next Overload


Next Method (Int32)

[image]

Lidgren Network Library documentation
NetRandom..::..Next Method (Int32)
NetRandom Class See Also Send Feedback
Generates a random int over the range 0 to upperBound-1, and not including upperBound.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int Next(
    int upperBound
)
Visual Basic
Public Function Next ( _
    upperBound As Integer _
) As Integer
Visual C++
public:
int Next(
    int upperBound
)

Parameters

upperBound
Type: System..::..Int32

[Missing <param name="upperBound"/> documentation for "M:Lidgren.Network.NetRandom.Next(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRandom.Next(System.Int32)"]

See Also

NetRandom Class
Next Overload


Next Method (Int32, Int32)

[image]

Lidgren Network Library documentation
NetRandom..::..Next Method (Int32, Int32)
NetRandom Class See Also Send Feedback
Generates a random int over the range lowerBound to upperBound-1, and not including upperBound. upperBound must be >= lowerBound. lowerBound may be negative.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int Next(
    int lowerBound,
    int upperBound
)
Visual Basic
Public Function Next ( _
    lowerBound As Integer, _
    upperBound As Integer _
) As Integer
Visual C++
public:
int Next(
    int lowerBound,
    int upperBound
)

Parameters

lowerBound
Type: System..::..Int32

[Missing <param name="lowerBound"/> documentation for "M:Lidgren.Network.NetRandom.Next(System.Int32,System.Int32)"]

upperBound
Type: System..::..Int32

[Missing <param name="upperBound"/> documentation for "M:Lidgren.Network.NetRandom.Next(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRandom.Next(System.Int32,System.Int32)"]

See Also

NetRandom Class
Next Overload


NextBool Method

[image]

Lidgren Network Library documentation
NetRandom..::..NextBool Method
NetRandom Class See Also Send Feedback
Generates a single random bit. This method's performance is improved by generating 32 bits in one operation and storing them ready for future calls.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool NextBool()
Visual Basic
Public Function NextBool As Boolean
Visual C++
public:
bool NextBool()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRandom.NextBool"]

See Also

NetRandom Class


NextBytes Method

[image]

Lidgren Network Library documentation
NetRandom..::..NextBytes Method
NetRandom Class See Also Send Feedback
Fills the provided byte array with random bytes. This method is functionally equivalent to System.Random.NextBytes().

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void NextBytes(
    byte[] buffer
)
Visual Basic
Public Sub NextBytes ( _
    buffer As Byte() _
)
Visual C++
public:
void NextBytes(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: array< System..::..Byte >[]()[][]

[Missing <param name="buffer"/> documentation for "M:Lidgren.Network.NetRandom.NextBytes(System.Byte[])"]

See Also

NetRandom Class


NextDouble Method

[image]

Lidgren Network Library documentation
NetRandom..::..NextDouble Method
NetRandom Class See Also Send Feedback
Generates a random double. Values returned are from 0.0 up to but not including 1.0.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public double NextDouble()
Visual Basic
Public Function NextDouble As Double
Visual C++
public:
double NextDouble()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRandom.NextDouble"]

See Also

NetRandom Class


NextInt Method

[image]

Lidgren Network Library documentation
NetRandom..::..NextInt Method
NetRandom Class See Also Send Feedback
Generates a random int over the range 0 to int.MaxValue, inclusive. This method differs from Next() only in that the range is 0 to int.MaxValue and not 0 to int.MaxValue-1. The slight difference in range means this method is slightly faster than Next() but is not functionally equivalent to System.Random.Next().

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public int NextInt()
Visual Basic
Public Function NextInt As Integer
Visual C++
public:
int NextInt()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRandom.NextInt"]

See Also

NetRandom Class


NextSingle Method

[image]

Lidgren Network Library documentation
NetRandom..::..NextSingle Method
NetRandom Class See Also Send Feedback
Generates a random single. Values returned are from 0.0 up to but not including 1.0.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public float NextSingle()
Visual Basic
Public Function NextSingle As Single
Visual C++
public:
float NextSingle()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRandom.NextSingle"]

See Also

NetRandom Class


NextUInt Method

[image]

Lidgren Network Library documentation
NetRandom..::..NextUInt Method
NetRandom Class See Also Send Feedback
Generates a uint. Values returned are over the full range of a uint, uint.MinValue to uint.MaxValue, inclusive. This is the fastest method for generating a single random number because the underlying random number generator algorithm generates 32 random bits that can be cast directly to a uint.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public uint NextUInt()
Visual Basic
Public Function NextUInt As UInteger
Visual C++
public:
unsigned int NextUInt()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRandom.NextUInt"]

See Also

NetRandom Class


Reinitialise Method

[image]

Lidgren Network Library documentation
NetRandom..::..Reinitialise Method
NetRandom Class See Also Send Feedback
Reinitialises using an int value as a seed.

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void Reinitialise(
    int seed
)
Visual Basic
Public Sub Reinitialise ( _
    seed As Integer _
)
Visual C++
public:
void Reinitialise(
    int seed
)

Parameters

seed
Type: System..::..Int32

[Missing <param name="seed"/> documentation for "M:Lidgren.Network.NetRandom.Reinitialise(System.Int32)"]

See Also

NetRandom Class


NetRC2Encryption Class

[image]

Lidgren Network Library documentation
NetRC2Encryption Class
Members See Also Send Feedback
RC2 encryption

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetRC2Encryption : INetEncryption
Visual Basic
Public Class NetRC2Encryption _
    Implements INetEncryption
Visual C++
public ref class NetRC2Encryption : INetEncryption

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetRC2Encryption

See Also

NetRC2Encryption Members


NetRC2Encryption Members

[image] [image]

Lidgren Network Library documentation
NetRC2Encryption Members
NetRC2Encryption Class Constructors Methods See Also Send Feedback

The NetRC2Encryption type exposes the following members.

Constructors

 | Name | Description
Public method | NetRC2Encryption(String) | NetRC2Encryption constructor
Public method | NetRC2Encryption(array<Byte>[]()[][], array<Byte>[]()[][]) | NetRC2Encryption constructor
Public method | NetRC2Encryption(String, Int32) | NetRC2Encryption constructor

Methods

 | Name | Description
Public method | Decrypt | Decrypt incoming message
Public method | Encrypt | Encrypt outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetRC2Encryption Class


NetRC2Encryption Constructor

[image] [image]

Lidgren Network Library documentation
NetRC2Encryption Constructor
NetRC2Encryption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NetRC2Encryption(String) | NetRC2Encryption constructor
Public method | NetRC2Encryption(array<Byte>[]()[][], array<Byte>[]()[][]) | NetRC2Encryption constructor
Public method | NetRC2Encryption(String, Int32) | NetRC2Encryption constructor

See Also

NetRC2Encryption Class
NetRC2Encryption Members


NetRC2Encryption Constructor (String)

[image]

Lidgren Network Library documentation
NetRC2Encryption Constructor (String)
NetRC2Encryption Class See Also Send Feedback
NetRC2Encryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetRC2Encryption(
    string key
)
Visual Basic
Public Sub New ( _
    key As String _
)
Visual C++
public:
NetRC2Encryption(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetRC2Encryption.#ctor(System.String)"]

See Also

NetRC2Encryption Class
NetRC2Encryption Overload


NetRC2Encryption Constructor (Byte[], Byte[])

[image]

Lidgren Network Library documentation
NetRC2Encryption Constructor (array<Byte>[]()[][], array<Byte>[]()[][])
NetRC2Encryption Class See Also Send Feedback
NetRC2Encryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetRC2Encryption(
    byte[] key,
    byte[] iv
)
Visual Basic
Public Sub New ( _
    key As Byte(), _
    iv As Byte() _
)
Visual C++
public:
NetRC2Encryption(
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)

Parameters

key
Type: array< System..::..Byte >[]()[][]

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetRC2Encryption.#ctor(System.Byte[],System.Byte[])"]

iv
Type: array< System..::..Byte >[]()[][]

[Missing <param name="iv"/> documentation for "M:Lidgren.Network.NetRC2Encryption.#ctor(System.Byte[],System.Byte[])"]

See Also

NetRC2Encryption Class
NetRC2Encryption Overload


NetRC2Encryption Constructor (String, Int32)

[image]

Lidgren Network Library documentation
NetRC2Encryption Constructor (String, Int32)
NetRC2Encryption Class See Also Send Feedback
NetRC2Encryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetRC2Encryption(
    string key,
    int bitsize
)
Visual Basic
Public Sub New ( _
    key As String, _
    bitsize As Integer _
)
Visual C++
public:
NetRC2Encryption(
    String^ key,
    int bitsize
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetRC2Encryption.#ctor(System.String,System.Int32)"]

bitsize
Type: System..::..Int32

[Missing <param name="bitsize"/> documentation for "M:Lidgren.Network.NetRC2Encryption.#ctor(System.String,System.Int32)"]

See Also

NetRC2Encryption Class
NetRC2Encryption Overload


NetRC2Encryption Methods

[image] [image]

Lidgren Network Library documentation
NetRC2Encryption Methods
NetRC2Encryption Class See Also Send Feedback

The NetRC2Encryption type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt incoming message
Public method | Encrypt | Encrypt outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetRC2Encryption Class


Decrypt Method

[image]

Lidgren Network Library documentation
NetRC2Encryption..::..Decrypt Method
NetRC2Encryption Class See Also Send Feedback
Decrypt incoming message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Decrypt(
    NetIncomingMessage msg
)
Visual Basic
Public Function Decrypt ( _
    msg As NetIncomingMessage _
) As Boolean
Visual C++
public:
virtual bool Decrypt(
    NetIncomingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetIncomingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetRC2Encryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRC2Encryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Implements

INetEncryption..::..Decrypt(NetIncomingMessage)

See Also

NetRC2Encryption Class


Encrypt Method

[image]

Lidgren Network Library documentation
NetRC2Encryption..::..Encrypt Method
NetRC2Encryption Class See Also Send Feedback
Encrypt outgoing message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Encrypt(
    NetOutgoingMessage msg
)
Visual Basic
Public Function Encrypt ( _
    msg As NetOutgoingMessage _
) As Boolean
Visual C++
public:
virtual bool Encrypt(
    NetOutgoingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetRC2Encryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetRC2Encryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Implements

INetEncryption..::..Encrypt(NetOutgoingMessage)

See Also

NetRC2Encryption Class


NetSendResult Enumeration

[image]

Lidgren Network Library documentation
NetSendResult Enumeration
See Also Send Feedback
Result of a SendMessage call

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public enum NetSendResult
Visual Basic
Public Enumeration NetSendResult
Visual C++
public enum class NetSendResult

Members

Member name | Description
Failed |
Sent |
Queued |
Dropped |

See Also

Lidgren.Network Namespace


NetServer Class

[image]

Lidgren Network Library documentation
NetServer Class
Members See Also Send Feedback
Specialized version of NetPeer used for "server" peers

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetServer : NetPeer
Visual Basic
Public Class NetServer _
    Inherits NetPeer
Visual C++
public ref class NetServer : public NetPeer

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetPeer
Lidgren.Network..::..NetServer

See Also

NetServer Members


NetServer Members

[image] [image]

Lidgren Network Library documentation
NetServer Members
NetServer Class Constructors Methods Properties See Also Send Feedback

The NetServer type exposes the following members.

Constructors

 | Name | Description
Public method | NetServer | NetServer constructor

Methods

 | Name | Description
Public method | Connect(IPEndPoint) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(IPEndPoint, NetOutgoingMessage) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(String, Int32) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(String, Int32, NetOutgoingMessage) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | CreateMessage()()()() | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(Int32) | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(String) | Creates a new message for sending and writes the provided string to it (Inherited from NetPeer.)
Public method | DiscoverKnownPeer(IPEndPoint) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverKnownPeer(String, Int32) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverLocalPeers | Emit a discovery signal to all hosts on your subnet (Inherited from NetPeer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConnection | Get the connection, if any, for a certain remote endpoint (Inherited from NetPeer.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Introduce | Send NetIntroduction to hostExternal and clientExternal; introducing client to host (Inherited from NetPeer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadMessage | Read a pending message from any connection, if any (Inherited from NetPeer.)
Public method | Recycle | Recycles a NetIncomingMessage instance for reuse; taking pressure off the garbage collector (Inherited from NetPeer.)
Public method | SendDiscoveryResponse | Send a discovery response message (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, IList<(Of <<'(NetConnection>)>>), NetDeliveryMethod, Int32) | Send a message to a list of connections (Inherited from NetPeer.)
Public method | SendToAll(NetOutgoingMessage, NetDeliveryMethod) | Send a message to all connections
Public method | SendToAll(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to all connections except one
Public method | SendUnconnectedMessage(NetOutgoingMessage, IList<(Of <<'(IPEndPoint>)>>)) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, IPEndPoint) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, String, Int32) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | Shutdown | Disconnects all active connections and closes the socket (Inherited from NetPeer.)
Public method | Start | Binds to socket and spawns the networking thread (Inherited from NetPeer.)
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)
Public method | WaitMessage | Read a pending message from any connection, blocking up to maxMillis if needed (Inherited from NetPeer.)

Properties

 | Name | Description
Public property | Configuration | Gets the configuration used to instanciate this NetPeer (Inherited from NetPeer.)
Public property | Connections | Gets a copy of the list of connections (Inherited from NetPeer.)
Public property | ConnectionsCount | Gets the number of active connections (Inherited from NetPeer.)
Public property | MessageReceivedEvent | Signalling event which can be waited on to determine when a message is queued for reading. Note that there is no guarantee that after the event is signaled the blocked thread will find the message in the queue. Other user created threads could be preempted and dequeue the message before the waiting thread wakes up. (Inherited from NetPeer.)
Public property | Port | Gets the port number this NetPeer is listening and sending on, if Start() has been called (Inherited from NetPeer.)
Public property | Socket | Gets the socket, if Start() has been called (Inherited from NetPeer.)
Public property | Statistics | Statistics on this NetPeer since it was initialized (Inherited from NetPeer.)
Public property | Status | Gets the NetPeerStatus of the NetPeer (Inherited from NetPeer.)
Public property | Tag | Gets or sets the application defined object containing data about the peer (Inherited from NetPeer.)
Public property | UniqueIdentifier | Gets a unique identifier for this NetPeer based on Mac address and ip/port. Note! Not available until Start() has been called! (Inherited from NetPeer.)
Public property | UPnP | Returns an UPnP object if enabled in the NetPeerConfiguration (Inherited from NetPeer.)

See Also

NetServer Class


NetServer Constructor

[image]

Lidgren Network Library documentation
NetServer Constructor
NetServer Class See Also Send Feedback
NetServer constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetServer(
    NetPeerConfiguration config
)
Visual Basic
Public Sub New ( _
    config As NetPeerConfiguration _
)
Visual C++
public:
NetServer(
    NetPeerConfiguration^ config
)

Parameters

config
Type: Lidgren.Network..::..NetPeerConfiguration

[Missing <param name="config"/> documentation for "M:Lidgren.Network.NetServer.#ctor(Lidgren.Network.NetPeerConfiguration)"]

See Also

NetServer Class


NetServer Methods

[image] [image]

Lidgren Network Library documentation
NetServer Methods
NetServer Class See Also Send Feedback

The NetServer type exposes the following members.

Methods

 | Name | Description
Public method | Connect(IPEndPoint) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(IPEndPoint, NetOutgoingMessage) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(String, Int32) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(String, Int32, NetOutgoingMessage) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | CreateMessage()()()() | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(Int32) | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(String) | Creates a new message for sending and writes the provided string to it (Inherited from NetPeer.)
Public method | DiscoverKnownPeer(IPEndPoint) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverKnownPeer(String, Int32) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverLocalPeers | Emit a discovery signal to all hosts on your subnet (Inherited from NetPeer.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConnection | Get the connection, if any, for a certain remote endpoint (Inherited from NetPeer.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Introduce | Send NetIntroduction to hostExternal and clientExternal; introducing client to host (Inherited from NetPeer.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadMessage | Read a pending message from any connection, if any (Inherited from NetPeer.)
Public method | Recycle | Recycles a NetIncomingMessage instance for reuse; taking pressure off the garbage collector (Inherited from NetPeer.)
Public method | SendDiscoveryResponse | Send a discovery response message (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, IList<(Of <<'(NetConnection>)>>), NetDeliveryMethod, Int32) | Send a message to a list of connections (Inherited from NetPeer.)
Public method | SendToAll(NetOutgoingMessage, NetDeliveryMethod) | Send a message to all connections
Public method | SendToAll(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to all connections except one
Public method | SendUnconnectedMessage(NetOutgoingMessage, IList<(Of <<'(IPEndPoint>)>>)) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, IPEndPoint) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, String, Int32) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | Shutdown | Disconnects all active connections and closes the socket (Inherited from NetPeer.)
Public method | Start | Binds to socket and spawns the networking thread (Inherited from NetPeer.)
Public method | ToString | Returns a string that represents this object (Overrides Object..::..ToString()()()().)
Public method | WaitMessage | Read a pending message from any connection, blocking up to maxMillis if needed (Inherited from NetPeer.)

See Also

NetServer Class


Connect Method

[image] [image]

Lidgren Network Library documentation
NetServer..::..Connect Method
NetServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect(IPEndPoint) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(IPEndPoint, NetOutgoingMessage) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(String, Int32) | Create a connection to a remote endpoint (Inherited from NetPeer.)
Public method | Connect(String, Int32, NetOutgoingMessage) | Create a connection to a remote endpoint (Inherited from NetPeer.)

See Also

NetServer Class
NetServer Members


CreateMessage Method

[image] [image]

Lidgren Network Library documentation
NetServer..::..CreateMessage Method
NetServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateMessage()()()() | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(Int32) | Creates a new message for sending (Inherited from NetPeer.)
Public method | CreateMessage(String) | Creates a new message for sending and writes the provided string to it (Inherited from NetPeer.)

See Also

NetServer Class
NetServer Members


DiscoverKnownPeer Method

[image] [image]

Lidgren Network Library documentation
NetServer..::..DiscoverKnownPeer Method
NetServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DiscoverKnownPeer(IPEndPoint) | Emit a discovery signal to a single known host (Inherited from NetPeer.)
Public method | DiscoverKnownPeer(String, Int32) | Emit a discovery signal to a single known host (Inherited from NetPeer.)

See Also

NetServer Class
NetServer Members


SendMessage Method

[image] [image]

Lidgren Network Library documentation
NetServer..::..SendMessage Method
NetServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to a specific connection (Inherited from NetPeer.)
Public method | SendMessage(NetOutgoingMessage, IList<(Of <<'(NetConnection>)>>), NetDeliveryMethod, Int32) | Send a message to a list of connections (Inherited from NetPeer.)

See Also

NetServer Class
NetServer Members


SendToAll Method

[image] [image]

Lidgren Network Library documentation
NetServer..::..SendToAll Method
NetServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendToAll(NetOutgoingMessage, NetDeliveryMethod) | Send a message to all connections
Public method | SendToAll(NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32) | Send a message to all connections except one

See Also

NetServer Class
NetServer Members


SendToAll Method (NetOutgoingMessage, NetDeliveryMethod)

[image]

Lidgren Network Library documentation
NetServer..::..SendToAll Method (NetOutgoingMessage, NetDeliveryMethod)
NetServer Class See Also Send Feedback
Send a message to all connections

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SendToAll(
    NetOutgoingMessage msg,
    NetDeliveryMethod method
)
Visual Basic
Public Sub SendToAll ( _
    msg As NetOutgoingMessage, _
    method As NetDeliveryMethod _
)
Visual C++
public:
void SendToAll(
    NetOutgoingMessage^ msg,
    NetDeliveryMethod method
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage
The message to send
method
Type: Lidgren.Network..::..NetDeliveryMethod
How to deliver the message

See Also

NetServer Class
SendToAll Overload


SendToAll Method (NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32)

[image]

Lidgren Network Library documentation
NetServer..::..SendToAll Method (NetOutgoingMessage, NetConnection, NetDeliveryMethod, Int32)
NetServer Class See Also Send Feedback
Send a message to all connections except one

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public void SendToAll(
    NetOutgoingMessage msg,
    NetConnection except,
    NetDeliveryMethod method,
    int sequenceChannel
)
Visual Basic
Public Sub SendToAll ( _
    msg As NetOutgoingMessage, _
    except As NetConnection, _
    method As NetDeliveryMethod, _
    sequenceChannel As Integer _
)
Visual C++
public:
void SendToAll(
    NetOutgoingMessage^ msg,
    NetConnection^ except,
    NetDeliveryMethod method,
    int sequenceChannel
)

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage
The message to send
except
Type: Lidgren.Network..::..NetConnection
Don't send to this particular connection
method
Type: Lidgren.Network..::..NetDeliveryMethod
How to deliver the message
sequenceChannel
Type: System..::..Int32
Which sequence channel to use for the message

See Also

NetServer Class
SendToAll Overload


SendUnconnectedMessage Method

[image] [image]

Lidgren Network Library documentation
NetServer..::..SendUnconnectedMessage Method
NetServer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SendUnconnectedMessage(NetOutgoingMessage, IList<(Of <<'(IPEndPoint>)>>)) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, IPEndPoint) | Send a message to an unconnected host (Inherited from NetPeer.)
Public method | SendUnconnectedMessage(NetOutgoingMessage, String, Int32) | Send a message to an unconnected host (Inherited from NetPeer.)

See Also

NetServer Class
NetServer Members


ToString Method

[image]

Lidgren Network Library documentation
NetServer..::..ToString Method
NetServer Class See Also Send Feedback
Returns a string that represents this object

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetServer.ToString"]

See Also

NetServer Class


NetServer Properties

[image] [image]

Lidgren Network Library documentation
NetServer Properties
NetServer Class See Also Send Feedback

The NetServer type exposes the following members.

Properties

 | Name | Description
Public property | Configuration | Gets the configuration used to instanciate this NetPeer (Inherited from NetPeer.)
Public property | Connections | Gets a copy of the list of connections (Inherited from NetPeer.)
Public property | ConnectionsCount | Gets the number of active connections (Inherited from NetPeer.)
Public property | MessageReceivedEvent | Signalling event which can be waited on to determine when a message is queued for reading. Note that there is no guarantee that after the event is signaled the blocked thread will find the message in the queue. Other user created threads could be preempted and dequeue the message before the waiting thread wakes up. (Inherited from NetPeer.)
Public property | Port | Gets the port number this NetPeer is listening and sending on, if Start() has been called (Inherited from NetPeer.)
Public property | Socket | Gets the socket, if Start() has been called (Inherited from NetPeer.)
Public property | Statistics | Statistics on this NetPeer since it was initialized (Inherited from NetPeer.)
Public property | Status | Gets the NetPeerStatus of the NetPeer (Inherited from NetPeer.)
Public property | Tag | Gets or sets the application defined object containing data about the peer (Inherited from NetPeer.)
Public property | UniqueIdentifier | Gets a unique identifier for this NetPeer based on Mac address and ip/port. Note! Not available until Start() has been called! (Inherited from NetPeer.)
Public property | UPnP | Returns an UPnP object if enabled in the NetPeerConfiguration (Inherited from NetPeer.)

See Also

NetServer Class


NetSRP Class

[image]

Lidgren Network Library documentation
NetSRP Class
Members See Also Send Feedback
Helper methods for implementing SRP authentication

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static class NetSRP
Visual Basic
Public NotInheritable Class NetSRP
Visual C++
public ref class NetSRP abstract sealed

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetSRP

See Also

NetSRP Members


NetSRP Members

[image] [image]

Lidgren Network Library documentation
NetSRP Members
NetSRP Class Methods See Also Send Feedback

The NetSRP type exposes the following members.

Methods

Name | Description
ComputeClientEphemeral | Compute client public ephemeral value (A)
ComputeClientSessionValue | Computes the client session value
ComputePrivateKey | Computer private key
ComputeServerEphemeral | Compute server ephemeral value (B)
ComputeServerSessionValue | Computes the server session value
ComputeServerVerifier | Creates a verifier that the server can later use to authenticate users later on (v)
ComputeU | Compute intermediate value U
CreateEncryption | Create XTEA symmetrical encryption object from sessionValue
CreateRandomEphemeral | Create 32 bytes of random ephemeral value
CreateRandomSalt | Create 16 bytes of random salt

See Also

NetSRP Class


NetSRP Methods

[image] [image]

Lidgren Network Library documentation
NetSRP Methods
NetSRP Class See Also Send Feedback

The NetSRP type exposes the following members.

Methods

Name | Description
ComputeClientEphemeral | Compute client public ephemeral value (A)
ComputeClientSessionValue | Computes the client session value
ComputePrivateKey | Computer private key
ComputeServerEphemeral | Compute server ephemeral value (B)
ComputeServerSessionValue | Computes the server session value
ComputeServerVerifier | Creates a verifier that the server can later use to authenticate users later on (v)
ComputeU | Compute intermediate value U
CreateEncryption | Create XTEA symmetrical encryption object from sessionValue
CreateRandomEphemeral | Create 32 bytes of random ephemeral value
CreateRandomSalt | Create 16 bytes of random salt

See Also

NetSRP Class


ComputeClientEphemeral Method

[image]

Lidgren Network Library documentation
NetSRP..::..ComputeClientEphemeral Method
NetSRP Class See Also Send Feedback
Compute client public ephemeral value (A)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] ComputeClientEphemeral(
    byte[] clientPrivateEphemeral
)
Visual Basic
Public Shared Function ComputeClientEphemeral ( _
    clientPrivateEphemeral As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ComputeClientEphemeral(
    array<unsigned char>^ clientPrivateEphemeral
)

Parameters

clientPrivateEphemeral
Type: array< System..::..Byte >[]()[][]

[Missing <param name="clientPrivateEphemeral"/> documentation for "M:Lidgren.Network.NetSRP.ComputeClientEphemeral(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.ComputeClientEphemeral(System.Byte[])"]

See Also

NetSRP Class


ComputeClientSessionValue Method

[image]

Lidgren Network Library documentation
NetSRP..::..ComputeClientSessionValue Method
NetSRP Class See Also Send Feedback
Computes the client session value

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] ComputeClientSessionValue(
    byte[] serverPublicEphemeral,
    byte[] xdata,
    byte[] udata,
    byte[] clientPrivateEphemeral
)
Visual Basic
Public Shared Function ComputeClientSessionValue ( _
    serverPublicEphemeral As Byte(), _
    xdata As Byte(), _
    udata As Byte(), _
    clientPrivateEphemeral As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ComputeClientSessionValue(
    array<unsigned char>^ serverPublicEphemeral,
    array<unsigned char>^ xdata,
    array<unsigned char>^ udata,
    array<unsigned char>^ clientPrivateEphemeral
)

Parameters

serverPublicEphemeral
Type: array< System..::..Byte >[]()[][]

[Missing <param name="serverPublicEphemeral"/> documentation for "M:Lidgren.Network.NetSRP.ComputeClientSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

xdata
Type: array< System..::..Byte >[]()[][]

[Missing <param name="xdata"/> documentation for "M:Lidgren.Network.NetSRP.ComputeClientSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

udata
Type: array< System..::..Byte >[]()[][]

[Missing <param name="udata"/> documentation for "M:Lidgren.Network.NetSRP.ComputeClientSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

clientPrivateEphemeral
Type: array< System..::..Byte >[]()[][]

[Missing <param name="clientPrivateEphemeral"/> documentation for "M:Lidgren.Network.NetSRP.ComputeClientSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.ComputeClientSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

See Also

NetSRP Class


ComputePrivateKey Method

[image]

Lidgren Network Library documentation
NetSRP..::..ComputePrivateKey Method
NetSRP Class See Also Send Feedback
Computer private key

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] ComputePrivateKey(
    string username,
    string password,
    byte[] salt
)
Visual Basic
Public Shared Function ComputePrivateKey ( _
    username As String, _
    password As String, _
    salt As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ComputePrivateKey(
    String^ username,
    String^ password,
    array<unsigned char>^ salt
)

Parameters

username
Type: System..::..String

[Missing <param name="username"/> documentation for "M:Lidgren.Network.NetSRP.ComputePrivateKey(System.String,System.String,System.Byte[])"]

password
Type: System..::..String

[Missing <param name="password"/> documentation for "M:Lidgren.Network.NetSRP.ComputePrivateKey(System.String,System.String,System.Byte[])"]

salt
Type: array< System..::..Byte >[]()[][]

[Missing <param name="salt"/> documentation for "M:Lidgren.Network.NetSRP.ComputePrivateKey(System.String,System.String,System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.ComputePrivateKey(System.String,System.String,System.Byte[])"]

See Also

NetSRP Class


ComputeServerEphemeral Method

[image]

Lidgren Network Library documentation
NetSRP..::..ComputeServerEphemeral Method
NetSRP Class See Also Send Feedback
Compute server ephemeral value (B)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] ComputeServerEphemeral(
    byte[] serverPrivateEphemeral,
    byte[] verifier
)
Visual Basic
Public Shared Function ComputeServerEphemeral ( _
    serverPrivateEphemeral As Byte(), _
    verifier As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ComputeServerEphemeral(
    array<unsigned char>^ serverPrivateEphemeral,
    array<unsigned char>^ verifier
)

Parameters

serverPrivateEphemeral
Type: array< System..::..Byte >[]()[][]

[Missing <param name="serverPrivateEphemeral"/> documentation for "M:Lidgren.Network.NetSRP.ComputeServerEphemeral(System.Byte[],System.Byte[])"]

verifier
Type: array< System..::..Byte >[]()[][]

[Missing <param name="verifier"/> documentation for "M:Lidgren.Network.NetSRP.ComputeServerEphemeral(System.Byte[],System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.ComputeServerEphemeral(System.Byte[],System.Byte[])"]

See Also

NetSRP Class


ComputeServerSessionValue Method

[image]

Lidgren Network Library documentation
NetSRP..::..ComputeServerSessionValue Method
NetSRP Class See Also Send Feedback
Computes the server session value

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] ComputeServerSessionValue(
    byte[] clientPublicEphemeral,
    byte[] verifier,
    byte[] udata,
    byte[] serverPrivateEphemeral
)
Visual Basic
Public Shared Function ComputeServerSessionValue ( _
    clientPublicEphemeral As Byte(), _
    verifier As Byte(), _
    udata As Byte(), _
    serverPrivateEphemeral As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ComputeServerSessionValue(
    array<unsigned char>^ clientPublicEphemeral,
    array<unsigned char>^ verifier,
    array<unsigned char>^ udata,
    array<unsigned char>^ serverPrivateEphemeral
)

Parameters

clientPublicEphemeral
Type: array< System..::..Byte >[]()[][]

[Missing <param name="clientPublicEphemeral"/> documentation for "M:Lidgren.Network.NetSRP.ComputeServerSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

verifier
Type: array< System..::..Byte >[]()[][]

[Missing <param name="verifier"/> documentation for "M:Lidgren.Network.NetSRP.ComputeServerSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

udata
Type: array< System..::..Byte >[]()[][]

[Missing <param name="udata"/> documentation for "M:Lidgren.Network.NetSRP.ComputeServerSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

serverPrivateEphemeral
Type: array< System..::..Byte >[]()[][]

[Missing <param name="serverPrivateEphemeral"/> documentation for "M:Lidgren.Network.NetSRP.ComputeServerSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.ComputeServerSessionValue(System.Byte[],System.Byte[],System.Byte[],System.Byte[])"]

See Also

NetSRP Class


ComputeServerVerifier Method

[image]

Lidgren Network Library documentation
NetSRP..::..ComputeServerVerifier Method
NetSRP Class See Also Send Feedback
Creates a verifier that the server can later use to authenticate users later on (v)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] ComputeServerVerifier(
    byte[] privateKey
)
Visual Basic
Public Shared Function ComputeServerVerifier ( _
    privateKey As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ComputeServerVerifier(
    array<unsigned char>^ privateKey
)

Parameters

privateKey
Type: array< System..::..Byte >[]()[][]

[Missing <param name="privateKey"/> documentation for "M:Lidgren.Network.NetSRP.ComputeServerVerifier(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.ComputeServerVerifier(System.Byte[])"]

See Also

NetSRP Class


ComputeU Method

[image]

Lidgren Network Library documentation
NetSRP..::..ComputeU Method
NetSRP Class See Also Send Feedback
Compute intermediate value U

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] ComputeU(
    byte[] clientPublicEphemeral,
    byte[] serverPublicEphemeral
)
Visual Basic
Public Shared Function ComputeU ( _
    clientPublicEphemeral As Byte(), _
    serverPublicEphemeral As Byte() _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ComputeU(
    array<unsigned char>^ clientPublicEphemeral,
    array<unsigned char>^ serverPublicEphemeral
)

Parameters

clientPublicEphemeral
Type: array< System..::..Byte >[]()[][]

[Missing <param name="clientPublicEphemeral"/> documentation for "M:Lidgren.Network.NetSRP.ComputeU(System.Byte[],System.Byte[])"]

serverPublicEphemeral
Type: array< System..::..Byte >[]()[][]

[Missing <param name="serverPublicEphemeral"/> documentation for "M:Lidgren.Network.NetSRP.ComputeU(System.Byte[],System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.ComputeU(System.Byte[],System.Byte[])"]

See Also

NetSRP Class


CreateEncryption Method

[image]

Lidgren Network Library documentation
NetSRP..::..CreateEncryption Method
NetSRP Class See Also Send Feedback
Create XTEA symmetrical encryption object from sessionValue

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static NetXtea CreateEncryption(
    byte[] sessionValue
)
Visual Basic
Public Shared Function CreateEncryption ( _
    sessionValue As Byte() _
) As NetXtea
Visual C++
public:
static NetXtea^ CreateEncryption(
    array<unsigned char>^ sessionValue
)

Parameters

sessionValue
Type: array< System..::..Byte >[]()[][]

[Missing <param name="sessionValue"/> documentation for "M:Lidgren.Network.NetSRP.CreateEncryption(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.CreateEncryption(System.Byte[])"]

See Also

NetSRP Class


CreateRandomEphemeral Method

[image]

Lidgren Network Library documentation
NetSRP..::..CreateRandomEphemeral Method
NetSRP Class See Also Send Feedback
Create 32 bytes of random ephemeral value

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] CreateRandomEphemeral()
Visual Basic
Public Shared Function CreateRandomEphemeral As Byte()
Visual C++
public:
static array<unsigned char>^ CreateRandomEphemeral()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.CreateRandomEphemeral"]

See Also

NetSRP Class


CreateRandomSalt Method

[image]

Lidgren Network Library documentation
NetSRP..::..CreateRandomSalt Method
NetSRP Class See Also Send Feedback
Create 16 bytes of random salt

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] CreateRandomSalt()
Visual Basic
Public Shared Function CreateRandomSalt As Byte()
Visual C++
public:
static array<unsigned char>^ CreateRandomSalt()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetSRP.CreateRandomSalt"]

See Also

NetSRP Class


NetTime Class

[image]

Lidgren Network Library documentation
NetTime Class
Members See Also Send Feedback
Time service

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static class NetTime
Visual Basic
Public NotInheritable Class NetTime
Visual C++
public ref class NetTime abstract sealed

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetTime

See Also

NetTime Members


NetTime Members

[image] [image]

Lidgren Network Library documentation
NetTime Members
NetTime Class Methods Properties See Also Send Feedback

The NetTime type exposes the following members.

Methods

Name | Description
ToReadable | Given seconds it will output a human friendly readable string (milliseconds if less than 60 seconds)

Properties

Name | Description
Now | Get number of seconds since the application started

See Also

NetTime Class


NetTime Methods

[image] [image]

Lidgren Network Library documentation
NetTime Methods
NetTime Class See Also Send Feedback

The NetTime type exposes the following members.

Methods

Name | Description
ToReadable | Given seconds it will output a human friendly readable string (milliseconds if less than 60 seconds)

See Also

NetTime Class


ToReadable Method

[image]

Lidgren Network Library documentation
NetTime..::..ToReadable Method
NetTime Class See Also Send Feedback
Given seconds it will output a human friendly readable string (milliseconds if less than 60 seconds)

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static string ToReadable(
    double seconds
)
Visual Basic
Public Shared Function ToReadable ( _
    seconds As Double _
) As String
Visual C++
public:
static String^ ToReadable(
    double seconds
)

Parameters

seconds
Type: System..::..Double

[Missing <param name="seconds"/> documentation for "M:Lidgren.Network.NetTime.ToReadable(System.Double)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetTime.ToReadable(System.Double)"]

See Also

NetTime Class


NetTime Properties

[image] [image]

Lidgren Network Library documentation
NetTime Properties
NetTime Class See Also Send Feedback

The NetTime type exposes the following members.

Properties

Name | Description
Now | Get number of seconds since the application started

See Also

NetTime Class


Now Property

[image]

Lidgren Network Library documentation
NetTime..::..Now Property
NetTime Class See Also Send Feedback
Get number of seconds since the application started

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static double Now { get; }
Visual Basic
Public Shared ReadOnly Property Now As Double
    Get
Visual C++
public:
static property double Now {
    double get ();
}

See Also

NetTime Class


NetTripleDESEncryption Class

[image]

Lidgren Network Library documentation
NetTripleDESEncryption Class
Members See Also Send Feedback
Triple DES encryption

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetTripleDESEncryption : INetEncryption
Visual Basic
Public Class NetTripleDESEncryption _
    Implements INetEncryption
Visual C++
public ref class NetTripleDESEncryption : INetEncryption

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetTripleDESEncryption

See Also

NetTripleDESEncryption Members


NetTripleDESEncryption Members

[image] [image]

Lidgren Network Library documentation
NetTripleDESEncryption Members
NetTripleDESEncryption Class Constructors Methods See Also Send Feedback

The NetTripleDESEncryption type exposes the following members.

Constructors

 | Name | Description
Public method | NetTripleDESEncryption(String) | NetTriplsDESEncryption constructor
Public method | NetTripleDESEncryption(array<Byte>[]()[][], array<Byte>[]()[][]) | NetTriplsDESEncryption constructor
Public method | NetTripleDESEncryption(String, Int32) | NetTriplsDESEncryption constructor

Methods

 | Name | Description
Public method | Decrypt | Decrypt incoming message
Public method | Encrypt | Encrypt outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetTripleDESEncryption Class


NetTripleDESEncryption Constructor

[image] [image]

Lidgren Network Library documentation
NetTripleDESEncryption Constructor
NetTripleDESEncryption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NetTripleDESEncryption(String) | NetTriplsDESEncryption constructor
Public method | NetTripleDESEncryption(array<Byte>[]()[][], array<Byte>[]()[][]) | NetTriplsDESEncryption constructor
Public method | NetTripleDESEncryption(String, Int32) | NetTriplsDESEncryption constructor

See Also

NetTripleDESEncryption Class
NetTripleDESEncryption Members


NetTripleDESEncryption Constructor (String)

[image]

Lidgren Network Library documentation
NetTripleDESEncryption Constructor (String)
NetTripleDESEncryption Class See Also Send Feedback
NetTriplsDESEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetTripleDESEncryption(
    string key
)
Visual Basic
Public Sub New ( _
    key As String _
)
Visual C++
public:
NetTripleDESEncryption(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetTripleDESEncryption.#ctor(System.String)"]

See Also

NetTripleDESEncryption Class
NetTripleDESEncryption Overload


NetTripleDESEncryption Constructor (Byte[], Byte[])

[image]

Lidgren Network Library documentation
NetTripleDESEncryption Constructor (array<Byte>[]()[][], array<Byte>[]()[][])
NetTripleDESEncryption Class See Also Send Feedback
NetTriplsDESEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetTripleDESEncryption(
    byte[] key,
    byte[] iv
)
Visual Basic
Public Sub New ( _
    key As Byte(), _
    iv As Byte() _
)
Visual C++
public:
NetTripleDESEncryption(
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)

Parameters

key
Type: array< System..::..Byte >[]()[][]

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetTripleDESEncryption.#ctor(System.Byte[],System.Byte[])"]

iv
Type: array< System..::..Byte >[]()[][]

[Missing <param name="iv"/> documentation for "M:Lidgren.Network.NetTripleDESEncryption.#ctor(System.Byte[],System.Byte[])"]

See Also

NetTripleDESEncryption Class
NetTripleDESEncryption Overload


NetTripleDESEncryption Constructor (String, Int32)

[image]

Lidgren Network Library documentation
NetTripleDESEncryption Constructor (String, Int32)
NetTripleDESEncryption Class See Also Send Feedback
NetTriplsDESEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetTripleDESEncryption(
    string key,
    int bitsize
)
Visual Basic
Public Sub New ( _
    key As String, _
    bitsize As Integer _
)
Visual C++
public:
NetTripleDESEncryption(
    String^ key,
    int bitsize
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetTripleDESEncryption.#ctor(System.String,System.Int32)"]

bitsize
Type: System..::..Int32

[Missing <param name="bitsize"/> documentation for "M:Lidgren.Network.NetTripleDESEncryption.#ctor(System.String,System.Int32)"]

See Also

NetTripleDESEncryption Class
NetTripleDESEncryption Overload


NetTripleDESEncryption Methods

[image] [image]

Lidgren Network Library documentation
NetTripleDESEncryption Methods
NetTripleDESEncryption Class See Also Send Feedback

The NetTripleDESEncryption type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt incoming message
Public method | Encrypt | Encrypt outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetTripleDESEncryption Class


Decrypt Method

[image]

Lidgren Network Library documentation
NetTripleDESEncryption..::..Decrypt Method
NetTripleDESEncryption Class See Also Send Feedback
Decrypt incoming message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Decrypt(
    NetIncomingMessage msg
)
Visual Basic
Public Function Decrypt ( _
    msg As NetIncomingMessage _
) As Boolean
Visual C++
public:
virtual bool Decrypt(
    NetIncomingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetIncomingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetTripleDESEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetTripleDESEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Implements

INetEncryption..::..Decrypt(NetIncomingMessage)

See Also

NetTripleDESEncryption Class


Encrypt Method

[image]

Lidgren Network Library documentation
NetTripleDESEncryption..::..Encrypt Method
NetTripleDESEncryption Class See Also Send Feedback
Encrypt outgoing message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Encrypt(
    NetOutgoingMessage msg
)
Visual Basic
Public Function Encrypt ( _
    msg As NetOutgoingMessage _
) As Boolean
Visual C++
public:
virtual bool Encrypt(
    NetOutgoingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetTripleDESEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetTripleDESEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Implements

INetEncryption..::..Encrypt(NetOutgoingMessage)

See Also

NetTripleDESEncryption Class


NetUPnP Class

[image]

Lidgren Network Library documentation
NetUPnP Class
Members See Also Send Feedback
UPnP support class

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetUPnP
Visual Basic
Public Class NetUPnP
Visual C++
public ref class NetUPnP

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetUPnP

See Also

NetUPnP Members


NetUPnP Members

[image] [image]

Lidgren Network Library documentation
NetUPnP Members
NetUPnP Class Constructors Methods See Also Send Feedback

The NetUPnP type exposes the following members.

Constructors

 | Name | Description
Public method | NetUPnP | Initializes a new instance of the NetUPnP class

Methods

 | Name | Description
Public method | DeleteForwardingRule | Delete a forwarding rule from the router using UPnP
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForwardPort | Add a forwarding rule to the router using UPnP
Public method | GetExternalIP | Retrieve the extern ip using UPnP
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetUPnP Class


NetUPnP Constructor

[image]

Lidgren Network Library documentation
NetUPnP Constructor
NetUPnP Class See Also Send Feedback
Initializes a new instance of the NetUPnP class

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetUPnP(
    NetPeer peer
)
Visual Basic
Public Sub New ( _
    peer As NetPeer _
)
Visual C++
public:
NetUPnP(
    NetPeer^ peer
)

Parameters

peer
Type: Lidgren.Network..::..NetPeer

[Missing <param name="peer"/> documentation for "M:Lidgren.Network.NetUPnP.#ctor(Lidgren.Network.NetPeer)"]

See Also

NetUPnP Class


NetUPnP Methods

[image] [image]

Lidgren Network Library documentation
NetUPnP Methods
NetUPnP Class See Also Send Feedback

The NetUPnP type exposes the following members.

Methods

 | Name | Description
Public method | DeleteForwardingRule | Delete a forwarding rule from the router using UPnP
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForwardPort | Add a forwarding rule to the router using UPnP
Public method | GetExternalIP | Retrieve the extern ip using UPnP
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetUPnP Class


DeleteForwardingRule Method

[image]

Lidgren Network Library documentation
NetUPnP..::..DeleteForwardingRule Method
NetUPnP Class See Also Send Feedback
Delete a forwarding rule from the router using UPnP

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool DeleteForwardingRule(
    int port
)
Visual Basic
Public Function DeleteForwardingRule ( _
    port As Integer _
) As Boolean
Visual C++
public:
bool DeleteForwardingRule(
    int port
)

Parameters

port
Type: System..::..Int32

[Missing <param name="port"/> documentation for "M:Lidgren.Network.NetUPnP.DeleteForwardingRule(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUPnP.DeleteForwardingRule(System.Int32)"]

See Also

NetUPnP Class


ForwardPort Method

[image]

Lidgren Network Library documentation
NetUPnP..::..ForwardPort Method
NetUPnP Class See Also Send Feedback
Add a forwarding rule to the router using UPnP

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool ForwardPort(
    int port,
    string description
)
Visual Basic
Public Function ForwardPort ( _
    port As Integer, _
    description As String _
) As Boolean
Visual C++
public:
bool ForwardPort(
    int port,
    String^ description
)

Parameters

port
Type: System..::..Int32

[Missing <param name="port"/> documentation for "M:Lidgren.Network.NetUPnP.ForwardPort(System.Int32,System.String)"]

description
Type: System..::..String

[Missing <param name="description"/> documentation for "M:Lidgren.Network.NetUPnP.ForwardPort(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUPnP.ForwardPort(System.Int32,System.String)"]

See Also

NetUPnP Class


GetExternalIP Method

[image]

Lidgren Network Library documentation
NetUPnP..::..GetExternalIP Method
NetUPnP Class See Also Send Feedback
Retrieve the extern ip using UPnP

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public IPAddress GetExternalIP()
Visual Basic
Public Function GetExternalIP As IPAddress
Visual C++
public:
IPAddress^ GetExternalIP()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUPnP.GetExternalIP"]

See Also

NetUPnP Class


NetUtility Class

[image]

Lidgren Network Library documentation
NetUtility Class
Members See Also Send Feedback
Utility methods

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static class NetUtility
Visual Basic
Public NotInheritable Class NetUtility
Visual C++
public ref class NetUtility abstract sealed

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetUtility

See Also

NetUtility Members


NetUtility Members

[image] [image]

Lidgren Network Library documentation
NetUtility Members
NetUtility Class Methods See Also Send Feedback

The NetUtility type exposes the following members.

Methods

Name | Description
BitsToHoldUInt | Returns how many bits are necessary to hold a certain number
BytesToHoldBits | Returns how many bytes are required to hold a certain number of bits
GetMacAddress | Returns the physical (MAC) address for the first usable network interface
GetMyAddress | Gets my local IP address (not necessarily external) and subnet mask
GetWindowSize | Gets the window size used internally in the library for a certain delivery method
IsLocal(IPAddress) | Returns true if the IPAddress supplied is on the same subnet as this host
IsLocal(IPEndPoint) | Returns true if the IPEndPoint supplied is on the same subnet as this host
Resolve(String) | Get IPv4 address from notation (xxx.xxx.xxx.xxx) or hostname
Resolve(String, Int32) | Get IPv4 endpoint from notation (xxx.xxx.xxx.xxx) or hostname and port number
ToByteArray | Convert a hexadecimal string to a byte array
ToHexString(array<Byte>[]()[][]) | Create a hex string from an array of bytes
ToHexString(Int64) | Create a hex string from an Int64 value
ToHumanReadable | Converts a number of bytes to a shorter, more readable string representation

See Also

NetUtility Class


NetUtility Methods

[image] [image]

Lidgren Network Library documentation
NetUtility Methods
NetUtility Class See Also Send Feedback

The NetUtility type exposes the following members.

Methods

Name | Description
BitsToHoldUInt | Returns how many bits are necessary to hold a certain number
BytesToHoldBits | Returns how many bytes are required to hold a certain number of bits
GetMacAddress | Returns the physical (MAC) address for the first usable network interface
GetMyAddress | Gets my local IP address (not necessarily external) and subnet mask
GetWindowSize | Gets the window size used internally in the library for a certain delivery method
IsLocal(IPAddress) | Returns true if the IPAddress supplied is on the same subnet as this host
IsLocal(IPEndPoint) | Returns true if the IPEndPoint supplied is on the same subnet as this host
Resolve(String) | Get IPv4 address from notation (xxx.xxx.xxx.xxx) or hostname
Resolve(String, Int32) | Get IPv4 endpoint from notation (xxx.xxx.xxx.xxx) or hostname and port number
ToByteArray | Convert a hexadecimal string to a byte array
ToHexString(array<Byte>[]()[][]) | Create a hex string from an array of bytes
ToHexString(Int64) | Create a hex string from an Int64 value
ToHumanReadable | Converts a number of bytes to a shorter, more readable string representation

See Also

NetUtility Class


BitsToHoldUInt Method

[image]

Lidgren Network Library documentation
NetUtility..::..BitsToHoldUInt Method
NetUtility Class See Also Send Feedback
Returns how many bits are necessary to hold a certain number

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static int BitsToHoldUInt(
    uint value
)
Visual Basic
Public Shared Function BitsToHoldUInt ( _
    value As UInteger _
) As Integer
Visual C++
public:
static int BitsToHoldUInt(
    unsigned int value
)

Parameters

value
Type: System..::..UInt32

[Missing <param name="value"/> documentation for "M:Lidgren.Network.NetUtility.BitsToHoldUInt(System.UInt32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.BitsToHoldUInt(System.UInt32)"]

See Also

NetUtility Class


BytesToHoldBits Method

[image]

Lidgren Network Library documentation
NetUtility..::..BytesToHoldBits Method
NetUtility Class See Also Send Feedback
Returns how many bytes are required to hold a certain number of bits

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static int BytesToHoldBits(
    int numBits
)
Visual Basic
Public Shared Function BytesToHoldBits ( _
    numBits As Integer _
) As Integer
Visual C++
public:
static int BytesToHoldBits(
    int numBits
)

Parameters

numBits
Type: System..::..Int32

[Missing <param name="numBits"/> documentation for "M:Lidgren.Network.NetUtility.BytesToHoldBits(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.BytesToHoldBits(System.Int32)"]

See Also

NetUtility Class


GetMacAddress Method

[image]

Lidgren Network Library documentation
NetUtility..::..GetMacAddress Method
NetUtility Class See Also Send Feedback
Returns the physical (MAC) address for the first usable network interface

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static PhysicalAddress GetMacAddress()
Visual Basic
Public Shared Function GetMacAddress As PhysicalAddress
Visual C++
public:
static PhysicalAddress^ GetMacAddress()

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.GetMacAddress"]

See Also

NetUtility Class


GetMyAddress Method

[image]

Lidgren Network Library documentation
NetUtility..::..GetMyAddress Method
NetUtility Class See Also Send Feedback
Gets my local IP address (not necessarily external) and subnet mask

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static IPAddress GetMyAddress(
    out IPAddress mask
)
Visual Basic
Public Shared Function GetMyAddress ( _
    <OutAttribute> ByRef mask As IPAddress _
) As IPAddress
Visual C++
public:
static IPAddress^ GetMyAddress(
    [OutAttribute] IPAddress^% mask
)

Parameters

mask
Type: System.Net..::..IPAddress %

[Missing <param name="mask"/> documentation for "M:Lidgren.Network.NetUtility.GetMyAddress(System.Net.IPAddress@)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.GetMyAddress(System.Net.IPAddress@)"]

See Also

NetUtility Class


GetWindowSize Method

[image]

Lidgren Network Library documentation
NetUtility..::..GetWindowSize Method
NetUtility Class See Also Send Feedback
Gets the window size used internally in the library for a certain delivery method

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static int GetWindowSize(
    NetDeliveryMethod method
)
Visual Basic
Public Shared Function GetWindowSize ( _
    method As NetDeliveryMethod _
) As Integer
Visual C++
public:
static int GetWindowSize(
    NetDeliveryMethod method
)

Parameters

method
Type: Lidgren.Network..::..NetDeliveryMethod

[Missing <param name="method"/> documentation for "M:Lidgren.Network.NetUtility.GetWindowSize(Lidgren.Network.NetDeliveryMethod)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.GetWindowSize(Lidgren.Network.NetDeliveryMethod)"]

See Also

NetUtility Class


IsLocal Method

[image] [image]

Lidgren Network Library documentation
NetUtility..::..IsLocal Method
NetUtility Class See Also Send Feedback

Overload List

Name | Description
IsLocal(IPAddress) | Returns true if the IPAddress supplied is on the same subnet as this host
IsLocal(IPEndPoint) | Returns true if the IPEndPoint supplied is on the same subnet as this host

See Also

NetUtility Class
NetUtility Members


IsLocal Method (IPAddress)

[image]

Lidgren Network Library documentation
NetUtility..::..IsLocal Method (IPAddress)
NetUtility Class See Also Send Feedback
Returns true if the IPAddress supplied is on the same subnet as this host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static bool IsLocal(
    IPAddress remote
)
Visual Basic
Public Shared Function IsLocal ( _
    remote As IPAddress _
) As Boolean
Visual C++
public:
static bool IsLocal(
    IPAddress^ remote
)

Parameters

remote
Type: System.Net..::..IPAddress

[Missing <param name="remote"/> documentation for "M:Lidgren.Network.NetUtility.IsLocal(System.Net.IPAddress)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.IsLocal(System.Net.IPAddress)"]

See Also

NetUtility Class
IsLocal Overload


IsLocal Method (IPEndPoint)

[image]

Lidgren Network Library documentation
NetUtility..::..IsLocal Method (IPEndPoint)
NetUtility Class See Also Send Feedback
Returns true if the IPEndPoint supplied is on the same subnet as this host

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static bool IsLocal(
    IPEndPoint endpoint
)
Visual Basic
Public Shared Function IsLocal ( _
    endpoint As IPEndPoint _
) As Boolean
Visual C++
public:
static bool IsLocal(
    IPEndPoint^ endpoint
)

Parameters

endpoint
Type: System.Net..::..IPEndPoint

[Missing <param name="endpoint"/> documentation for "M:Lidgren.Network.NetUtility.IsLocal(System.Net.IPEndPoint)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.IsLocal(System.Net.IPEndPoint)"]

See Also

NetUtility Class
IsLocal Overload


Resolve Method

[image] [image]

Lidgren Network Library documentation
NetUtility..::..Resolve Method
NetUtility Class See Also Send Feedback

Overload List

Name | Description
Resolve(String) | Get IPv4 address from notation (xxx.xxx.xxx.xxx) or hostname
Resolve(String, Int32) | Get IPv4 endpoint from notation (xxx.xxx.xxx.xxx) or hostname and port number

See Also

NetUtility Class
NetUtility Members


Resolve Method (String)

[image]

Lidgren Network Library documentation
NetUtility..::..Resolve Method (String)
NetUtility Class See Also Send Feedback
Get IPv4 address from notation (xxx.xxx.xxx.xxx) or hostname

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static IPAddress Resolve(
    string ipOrHost
)
Visual Basic
Public Shared Function Resolve ( _
    ipOrHost As String _
) As IPAddress
Visual C++
public:
static IPAddress^ Resolve(
    String^ ipOrHost
)

Parameters

ipOrHost
Type: System..::..String

[Missing <param name="ipOrHost"/> documentation for "M:Lidgren.Network.NetUtility.Resolve(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.Resolve(System.String)"]

See Also

NetUtility Class
Resolve Overload


Resolve Method (String, Int32)

[image]

Lidgren Network Library documentation
NetUtility..::..Resolve Method (String, Int32)
NetUtility Class See Also Send Feedback
Get IPv4 endpoint from notation (xxx.xxx.xxx.xxx) or hostname and port number

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static IPEndPoint Resolve(
    string ipOrHost,
    int port
)
Visual Basic
Public Shared Function Resolve ( _
    ipOrHost As String, _
    port As Integer _
) As IPEndPoint
Visual C++
public:
static IPEndPoint^ Resolve(
    String^ ipOrHost,
    int port
)

Parameters

ipOrHost
Type: System..::..String

[Missing <param name="ipOrHost"/> documentation for "M:Lidgren.Network.NetUtility.Resolve(System.String,System.Int32)"]

port
Type: System..::..Int32

[Missing <param name="port"/> documentation for "M:Lidgren.Network.NetUtility.Resolve(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.Resolve(System.String,System.Int32)"]

See Also

NetUtility Class
Resolve Overload


ToByteArray Method

[image]

Lidgren Network Library documentation
NetUtility..::..ToByteArray Method
NetUtility Class See Also Send Feedback
Convert a hexadecimal string to a byte array

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static byte[] ToByteArray(
    string hexString
)
Visual Basic
Public Shared Function ToByteArray ( _
    hexString As String _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ToByteArray(
    String^ hexString
)

Parameters

hexString
Type: System..::..String

[Missing <param name="hexString"/> documentation for "M:Lidgren.Network.NetUtility.ToByteArray(System.String)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.ToByteArray(System.String)"]

See Also

NetUtility Class


ToHexString Method

[image] [image]

Lidgren Network Library documentation
NetUtility..::..ToHexString Method
NetUtility Class See Also Send Feedback

Overload List

Name | Description
ToHexString(array<Byte>[]()[][]) | Create a hex string from an array of bytes
ToHexString(Int64) | Create a hex string from an Int64 value

See Also

NetUtility Class
NetUtility Members


ToHexString Method (Byte[])

[image]

Lidgren Network Library documentation
NetUtility..::..ToHexString Method (array<Byte>[]()[][])
NetUtility Class See Also Send Feedback
Create a hex string from an array of bytes

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static string ToHexString(
    byte[] data
)
Visual Basic
Public Shared Function ToHexString ( _
    data As Byte() _
) As String
Visual C++
public:
static String^ ToHexString(
    array<unsigned char>^ data
)

Parameters

data
Type: array< System..::..Byte >[]()[][]

[Missing <param name="data"/> documentation for "M:Lidgren.Network.NetUtility.ToHexString(System.Byte[])"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.ToHexString(System.Byte[])"]

See Also

NetUtility Class
ToHexString Overload


ToHexString Method (Int64)

[image]

Lidgren Network Library documentation
NetUtility..::..ToHexString Method (Int64)
NetUtility Class See Also Send Feedback
Create a hex string from an Int64 value

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static string ToHexString(
    long data
)
Visual Basic
Public Shared Function ToHexString ( _
    data As Long _
) As String
Visual C++
public:
static String^ ToHexString(
    long long data
)

Parameters

data
Type: System..::..Int64

[Missing <param name="data"/> documentation for "M:Lidgren.Network.NetUtility.ToHexString(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.ToHexString(System.Int64)"]

See Also

NetUtility Class
ToHexString Overload


ToHumanReadable Method

[image]

Lidgren Network Library documentation
NetUtility..::..ToHumanReadable Method
NetUtility Class See Also Send Feedback
Converts a number of bytes to a shorter, more readable string representation

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public static string ToHumanReadable(
    long bytes
)
Visual Basic
Public Shared Function ToHumanReadable ( _
    bytes As Long _
) As String
Visual C++
public:
static String^ ToHumanReadable(
    long long bytes
)

Parameters

bytes
Type: System..::..Int64

[Missing <param name="bytes"/> documentation for "M:Lidgren.Network.NetUtility.ToHumanReadable(System.Int64)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetUtility.ToHumanReadable(System.Int64)"]

See Also

NetUtility Class


NetXorEncryption Class

[image]

Lidgren Network Library documentation
NetXorEncryption Class
Members See Also Send Feedback
Example class; not very good encryption

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public class NetXorEncryption : INetEncryption
Visual Basic
Public Class NetXorEncryption _
    Implements INetEncryption
Visual C++
public ref class NetXorEncryption : INetEncryption

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetXorEncryption

See Also

NetXorEncryption Members


NetXorEncryption Members

[image] [image]

Lidgren Network Library documentation
NetXorEncryption Members
NetXorEncryption Class Constructors Methods See Also Send Feedback

The NetXorEncryption type exposes the following members.

Constructors

 | Name | Description
Public method | NetXorEncryption(array<Byte>[]()[][]) | NetXorEncryption constructor
Public method | NetXorEncryption(String) | NetXorEncryption constructor

Methods

 | Name | Description
Public method | Decrypt | Decrypt an incoming message
Public method | Encrypt | Encrypt an outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetXorEncryption Class


NetXorEncryption Constructor

[image] [image]

Lidgren Network Library documentation
NetXorEncryption Constructor
NetXorEncryption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NetXorEncryption(array<Byte>[]()[][]) | NetXorEncryption constructor
Public method | NetXorEncryption(String) | NetXorEncryption constructor

See Also

NetXorEncryption Class
NetXorEncryption Members


NetXorEncryption Constructor (Byte[])

[image]

Lidgren Network Library documentation
NetXorEncryption Constructor (array<Byte>[]()[][])
NetXorEncryption Class See Also Send Feedback
NetXorEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetXorEncryption(
    byte[] key
)
Visual Basic
Public Sub New ( _
    key As Byte() _
)
Visual C++
public:
NetXorEncryption(
    array<unsigned char>^ key
)

Parameters

key
Type: array< System..::..Byte >[]()[][]

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetXorEncryption.#ctor(System.Byte[])"]

See Also

NetXorEncryption Class
NetXorEncryption Overload


NetXorEncryption Constructor (String)

[image]

Lidgren Network Library documentation
NetXorEncryption Constructor (String)
NetXorEncryption Class See Also Send Feedback
NetXorEncryption constructor

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetXorEncryption(
    string key
)
Visual Basic
Public Sub New ( _
    key As String _
)
Visual C++
public:
NetXorEncryption(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetXorEncryption.#ctor(System.String)"]

See Also

NetXorEncryption Class
NetXorEncryption Overload


NetXorEncryption Methods

[image] [image]

Lidgren Network Library documentation
NetXorEncryption Methods
NetXorEncryption Class See Also Send Feedback

The NetXorEncryption type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt an incoming message
Public method | Encrypt | Encrypt an outgoing message
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetXorEncryption Class


Decrypt Method

[image]

Lidgren Network Library documentation
NetXorEncryption..::..Decrypt Method
NetXorEncryption Class See Also Send Feedback
Decrypt an incoming message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Decrypt(
    NetIncomingMessage msg
)
Visual Basic
Public Function Decrypt ( _
    msg As NetIncomingMessage _
) As Boolean
Visual C++
public:
virtual bool Decrypt(
    NetIncomingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetIncomingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetXorEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetXorEncryption.Decrypt(Lidgren.Network.NetIncomingMessage)"]

Implements

INetEncryption..::..Decrypt(NetIncomingMessage)

See Also

NetXorEncryption Class


Encrypt Method

[image]

Lidgren Network Library documentation
NetXorEncryption..::..Encrypt Method
NetXorEncryption Class See Also Send Feedback
Encrypt an outgoing message

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public bool Encrypt(
    NetOutgoingMessage msg
)
Visual Basic
Public Function Encrypt ( _
    msg As NetOutgoingMessage _
) As Boolean
Visual C++
public:
virtual bool Encrypt(
    NetOutgoingMessage^ msg
) sealed

Parameters

msg
Type: Lidgren.Network..::..NetOutgoingMessage

[Missing <param name="msg"/> documentation for "M:Lidgren.Network.NetXorEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Return Value

[Missing <returns> documentation for "M:Lidgren.Network.NetXorEncryption.Encrypt(Lidgren.Network.NetOutgoingMessage)"]

Implements

INetEncryption..::..Encrypt(NetOutgoingMessage)

See Also

NetXorEncryption Class


NetXtea Class

[image]

Lidgren Network Library documentation
NetXtea Class
Members See Also Send Feedback
Methods to encrypt and decrypt data using the XTEA algorithm

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public sealed class NetXtea : NetBlockEncryptionBase
Visual Basic
Public NotInheritable Class NetXtea _
    Inherits NetBlockEncryptionBase
Visual C++
public ref class NetXtea sealed : public NetBlockEncryptionBase

Inheritance Hierarchy

System..::..Object
Lidgren.Network..::..NetBlockEncryptionBase
Lidgren.Network..::..NetXtea

See Also

NetXtea Members


NetXtea Members

[image] [image]

Lidgren Network Library documentation
NetXtea Members
NetXtea Class Constructors Methods Properties See Also Send Feedback

The NetXtea type exposes the following members.

Constructors

 | Name | Description
Public method | NetXtea(array<Byte>[]()[][]) | 16 byte key
Public method | NetXtea(String) | String to hash for key
Public method | NetXtea(array<Byte>[]()[][], Int32) | 16 byte key

Methods

 | Name | Description
Public method | Decrypt | Decrypt an incoming message encrypted with corresponding Encrypt (Inherited from NetBlockEncryptionBase.)
Protected method | DecryptBlock | Decrypts a block of bytes (Overrides NetBlockEncryptionBase..::..DecryptBlock(array<Byte>[]()[][], Int32, array<Byte>[]()[][]).)
Public method | Encrypt | Encrypt am outgoing message with this algorithm; no writing can be done to the message after encryption, or message will be corrupted (Inherited from NetBlockEncryptionBase.)
Protected method | EncryptBlock | Encrypts a block of bytes (Overrides NetBlockEncryptionBase..::..EncryptBlock(array<Byte>[]()[][], Int32, array<Byte>[]()[][]).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BlockSize | Gets the block size for this cipher (Overrides NetBlockEncryptionBase..::..BlockSize.)

See Also

NetXtea Class


NetXtea Constructor

[image] [image]

Lidgren Network Library documentation
NetXtea Constructor
NetXtea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NetXtea(array<Byte>[]()[][]) | 16 byte key
Public method | NetXtea(String) | String to hash for key
Public method | NetXtea(array<Byte>[]()[][], Int32) | 16 byte key

See Also

NetXtea Class
NetXtea Members


NetXtea Constructor (Byte[])

[image]

Lidgren Network Library documentation
NetXtea Constructor (array<Byte>[]()[][])
NetXtea Class See Also Send Feedback
16 byte key

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetXtea(
    byte[] key
)
Visual Basic
Public Sub New ( _
    key As Byte() _
)
Visual C++
public:
NetXtea(
    array<unsigned char>^ key
)

Parameters

key
Type: array< System..::..Byte >[]()[][]

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetXtea.#ctor(System.Byte[])"]

See Also

NetXtea Class
NetXtea Overload


NetXtea Constructor (String)

[image]

Lidgren Network Library documentation
NetXtea Constructor (String)
NetXtea Class See Also Send Feedback
String to hash for key

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetXtea(
    string key
)
Visual Basic
Public Sub New ( _
    key As String _
)
Visual C++
public:
NetXtea(
    String^ key
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetXtea.#ctor(System.String)"]

See Also

NetXtea Class
NetXtea Overload


NetXtea Constructor (Byte[], Int32)

[image]

Lidgren Network Library documentation
NetXtea Constructor (array<Byte>[]()[][], Int32)
NetXtea Class See Also Send Feedback
16 byte key

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public NetXtea(
    byte[] key,
    int rounds
)
Visual Basic
Public Sub New ( _
    key As Byte(), _
    rounds As Integer _
)
Visual C++
public:
NetXtea(
    array<unsigned char>^ key,
    int rounds
)

Parameters

key
Type: array< System..::..Byte >[]()[][]

[Missing <param name="key"/> documentation for "M:Lidgren.Network.NetXtea.#ctor(System.Byte[],System.Int32)"]

rounds
Type: System..::..Int32

[Missing <param name="rounds"/> documentation for "M:Lidgren.Network.NetXtea.#ctor(System.Byte[],System.Int32)"]

See Also

NetXtea Class
NetXtea Overload


NetXtea Methods

[image] [image]

Lidgren Network Library documentation
NetXtea Methods
NetXtea Class See Also Send Feedback

The NetXtea type exposes the following members.

Methods

 | Name | Description
Public method | Decrypt | Decrypt an incoming message encrypted with corresponding Encrypt (Inherited from NetBlockEncryptionBase.)
Protected method | DecryptBlock | Decrypts a block of bytes (Overrides NetBlockEncryptionBase..::..DecryptBlock(array<Byte>[]()[][], Int32, array<Byte>[]()[][]).)
Public method | Encrypt | Encrypt am outgoing message with this algorithm; no writing can be done to the message after encryption, or message will be corrupted (Inherited from NetBlockEncryptionBase.)
Protected method | EncryptBlock | Encrypts a block of bytes (Overrides NetBlockEncryptionBase..::..EncryptBlock(array<Byte>[]()[][], Int32, array<Byte>[]()[][]).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetXtea Class


DecryptBlock Method

[image]

Lidgren Network Library documentation
NetXtea..::..DecryptBlock Method
NetXtea Class See Also Send Feedback
Decrypts a block of bytes

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
protected override void DecryptBlock(
    byte[] source,
    int sourceOffset,
    byte[] destination
)
Visual Basic
Protected Overrides Sub DecryptBlock ( _
    source As Byte(), _
    sourceOffset As Integer, _
    destination As Byte() _
)
Visual C++
protected:
virtual void DecryptBlock(
    array<unsigned char>^ source,
    int sourceOffset,
    array<unsigned char>^ destination
) override

Parameters

source
Type: array< System..::..Byte >[]()[][]

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetXtea.DecryptBlock(System.Byte[],System.Int32,System.Byte[])"]

sourceOffset
Type: System..::..Int32

[Missing <param name="sourceOffset"/> documentation for "M:Lidgren.Network.NetXtea.DecryptBlock(System.Byte[],System.Int32,System.Byte[])"]

destination
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destination"/> documentation for "M:Lidgren.Network.NetXtea.DecryptBlock(System.Byte[],System.Int32,System.Byte[])"]

See Also

NetXtea Class


EncryptBlock Method

[image]

Lidgren Network Library documentation
NetXtea..::..EncryptBlock Method
NetXtea Class See Also Send Feedback
Encrypts a block of bytes

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
protected override void EncryptBlock(
    byte[] source,
    int sourceOffset,
    byte[] destination
)
Visual Basic
Protected Overrides Sub EncryptBlock ( _
    source As Byte(), _
    sourceOffset As Integer, _
    destination As Byte() _
)
Visual C++
protected:
virtual void EncryptBlock(
    array<unsigned char>^ source,
    int sourceOffset,
    array<unsigned char>^ destination
) override

Parameters

source
Type: array< System..::..Byte >[]()[][]

[Missing <param name="source"/> documentation for "M:Lidgren.Network.NetXtea.EncryptBlock(System.Byte[],System.Int32,System.Byte[])"]

sourceOffset
Type: System..::..Int32

[Missing <param name="sourceOffset"/> documentation for "M:Lidgren.Network.NetXtea.EncryptBlock(System.Byte[],System.Int32,System.Byte[])"]

destination
Type: array< System..::..Byte >[]()[][]

[Missing <param name="destination"/> documentation for "M:Lidgren.Network.NetXtea.EncryptBlock(System.Byte[],System.Int32,System.Byte[])"]

See Also

NetXtea Class


NetXtea Properties

[image] [image]

Lidgren Network Library documentation
NetXtea Properties
NetXtea Class See Also Send Feedback

The NetXtea type exposes the following members.

Properties

 | Name | Description
Public property | BlockSize | Gets the block size for this cipher (Overrides NetBlockEncryptionBase..::..BlockSize.)

See Also

NetXtea Class


BlockSize Property

[image]

Lidgren Network Library documentation
NetXtea..::..BlockSize Property
NetXtea Class See Also Send Feedback
Gets the block size for this cipher

Namespace: Lidgren.Network
Assembly: Lidgren.Network (in Lidgren.Network.dll) Version: 2011.3.12.0 (2011.3.12.0)

Syntax

C#
public override int BlockSize { get; }
Visual Basic
Public Overrides ReadOnly Property BlockSize As Integer
    Get
Visual C++
public:
virtual property int BlockSize {
    int get () override;
}

See Also

NetXtea Class